aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-URI-GoogleChart
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-03-28 21:06:26 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-03-28 21:06:26 +0000
commita76bf7579a2982ba0697140e51baa282c9b7fa86 (patch)
tree6e1529d0dfc6498d342fc87c6025b016105cd4bd /graphics/p5-URI-GoogleChart
parent8ada7205267cdfc622b97bef2b4b8f869c40832b (diff)
downloadports-a76bf7579a2982ba0697140e51baa282c9b7fa86.tar.gz
ports-a76bf7579a2982ba0697140e51baa282c9b7fa86.zip
Notes
Diffstat (limited to 'graphics/p5-URI-GoogleChart')
-rw-r--r--graphics/p5-URI-GoogleChart/Makefile25
-rw-r--r--graphics/p5-URI-GoogleChart/distinfo3
-rw-r--r--graphics/p5-URI-GoogleChart/pkg-descr6
-rw-r--r--graphics/p5-URI-GoogleChart/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/graphics/p5-URI-GoogleChart/Makefile b/graphics/p5-URI-GoogleChart/Makefile
new file mode 100644
index 000000000000..57c4748583a1
--- /dev/null
+++ b/graphics/p5-URI-GoogleChart/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: graphics/p5-URI-GoogleChart
+# Date created: 28 March 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-GoogleChart
+PORTVERSION= 0.02
+CATEGORIES= graphics www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Generate Google Chart URIs
+
+BUILD_DEPENDS= p5-URI>0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.6.0+
+
+MAN3= URI::GoogleChart.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-URI-GoogleChart/distinfo b/graphics/p5-URI-GoogleChart/distinfo
new file mode 100644
index 000000000000..17949a6ae901
--- /dev/null
+++ b/graphics/p5-URI-GoogleChart/distinfo
@@ -0,0 +1,3 @@
+MD5 (URI-GoogleChart-0.02.tar.gz) = 5a3a84c1ca30186e5006b3d62e90fec7
+SHA256 (URI-GoogleChart-0.02.tar.gz) = 5ad17c0381a3beebbea0f55066287852d07f4cd180427c0568b561df13ed44fb
+SIZE (URI-GoogleChart-0.02.tar.gz) = 9163
diff --git a/graphics/p5-URI-GoogleChart/pkg-descr b/graphics/p5-URI-GoogleChart/pkg-descr
new file mode 100644
index 000000000000..a86c2e82100c
--- /dev/null
+++ b/graphics/p5-URI-GoogleChart/pkg-descr
@@ -0,0 +1,6 @@
+This module provide a constructor method for Google Chart URIs. Google
+will serve back PNG images of charts controlled by the provided
+parameters when these URI are dereferenced. Normally these URIs will be
+embedded as <img src='$chart'> tags in HTML documents.
+
+WWW: http://search.cpan.org/dist/URI-GoogleChart/
diff --git a/graphics/p5-URI-GoogleChart/pkg-plist b/graphics/p5-URI-GoogleChart/pkg-plist
new file mode 100644
index 000000000000..70b9416fd51a
--- /dev/null
+++ b/graphics/p5-URI-GoogleChart/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/URI/GoogleChart.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/GoogleChart/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/GoogleChart
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI
+@dirrmtry %%SITE_PERL%%/URI