aboutsummaryrefslogtreecommitdiff
path: root/graphics/panorama
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-23 04:28:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-23 04:28:59 +0000
commit5800193a297b109e1d6b8db53770c9147eaccfba (patch)
tree3339843523b80a2c536a74153bf1bf1c9a4d9660 /graphics/panorama
parent927c1bd82b062460f5cc285aff4807e0ed0bc84d (diff)
downloadports-5800193a297b109e1d6b8db53770c9147eaccfba.tar.gz
ports-5800193a297b109e1d6b8db53770c9147eaccfba.zip
Notes
Diffstat (limited to 'graphics/panorama')
-rw-r--r--graphics/panorama/files/patch-configure26
-rw-r--r--graphics/panorama/files/patch-plugins_image_filter_text_if_text.cpp12
2 files changed, 35 insertions, 3 deletions
diff --git a/graphics/panorama/files/patch-configure b/graphics/panorama/files/patch-configure
index 07dc917f0091..31f8accd4bdc 100644
--- a/graphics/panorama/files/patch-configure
+++ b/graphics/panorama/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Wed Feb 12 13:06:57 2003
-+++ configure Sat Dec 13 16:06:49 2003
+--- configure.orig Tue Feb 11 23:06:57 2003
++++ configure Mon Mar 22 23:22:46 2004
@@ -7699,7 +7699,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -18,7 +18,27 @@
fi
-@@ -10538,3 +10538,4 @@
+@@ -7964,7 +7964,8 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ _ACEOF
+ rm -f conftest.$ac_objext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+@@ -7999,7 +8000,8 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ _ACEOF
+ if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
+@@ -10538,3 +10540,4 @@
ln -s $ac_aux_dir/Makefile.deps . 2>/dev/null
ln -s $ac_aux_dir/install-sh . 2>/dev/null
diff --git a/graphics/panorama/files/patch-plugins_image_filter_text_if_text.cpp b/graphics/panorama/files/patch-plugins_image_filter_text_if_text.cpp
new file mode 100644
index 000000000000..cc265fa5caf8
--- /dev/null
+++ b/graphics/panorama/files/patch-plugins_image_filter_text_if_text.cpp
@@ -0,0 +1,12 @@
+--- plugins/image_filter/text/if_text.cpp.orig Mon Mar 22 23:23:31 2004
++++ plugins/image_filter/text/if_text.cpp Mon Mar 22 23:23:43 2004
+@@ -18,7 +18,8 @@
+
+ #include <cmath>
+ #include <string.h>
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "llapi/file.h"
+ #include "llapi/scene.h"
+ #include "if_text.h"