aboutsummaryrefslogtreecommitdiff
path: root/graphics/partio
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-09-18 20:22:21 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-09-18 20:22:21 +0000
commitca58284d4d6db7fa1f6d12ab23d7aafca67d2520 (patch)
treebef41ca4b22ee54064f89aada3a22ecc25f53529 /graphics/partio
parent4ae7963322c618ed59f6ebe2e182611fac28e580 (diff)
downloadports-ca58284d4d6db7fa1f6d12ab23d7aafca67d2520.tar.gz
ports-ca58284d4d6db7fa1f6d12ab23d7aafca67d2520.zip
Notes
Diffstat (limited to 'graphics/partio')
-rw-r--r--graphics/partio/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/graphics/partio/Makefile b/graphics/partio/Makefile
index 314ab7e7fab9..24d22c925798 100644
--- a/graphics/partio/Makefile
+++ b/graphics/partio/Makefile
@@ -10,23 +10,27 @@ COMMENT= C++ library for manipulating animation particle formats
LICENSE= BSD3CLAUSE
-USES= cmake:outsource gl shebangfix
+BUILD_DEPENDS= swig3.0:devel/swig30
+
+USES= cmake:outsource gl python shebangfix
SHEBANG_FILES= src/tools/partedit.py src/tools/partjson.py
USE_GL= gl glu glut
USE_LDCONFIG= yes
-USE_XORG= xi
+USE_XORG= xi xmu
USE_GITHUB= yes
GH_ACCOUNT= wdas
-OPTIONS_DEFINE= DOCS PYTHON # XXX: should probably use DOXYGEN
-OPTIONS_DEFAULT= PYTHON
+OPTIONS_DEFINE= DOCS DOXYGEN
+OPTIONS_DEFAULT= DOCS
-PYTHON_BROKEN_OFF= does not build without Python support
+# DOCS must be selected for PORTDOCS to work
+DOXYGEN_IMPLIES= DOCS
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_ALL_TARGET= all doc
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
-PYTHON_USES= python
-PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30
+
BINARY_ALIAS= swig=swig3.0
PORTDOCS= *
@@ -38,15 +42,12 @@ post-patch:
@${REINPLACE_CMD} -e '/install(TARGETS/d' \
${WRKSRC}/src/tests/CMakeLists.txt
-post-patch-PYTHON-off:
- @${REINPLACE_CMD} -e '/ADD_SUBDIRECTORY.*src\/py.*/d' \
- ${WRKSRC}/CMakeLists.txt
-
post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/ADD_SUBDIRECTORY.*src\/doc.*/d' \
${WRKSRC}/CMakeLists.txt
-post-build-DOCS-on:
- @${MAKE_CMD} -C ${BUILD_WRKSRC} doc
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/src/doc && ${INSTALL_DATA} tutorial.txt partio.tex ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>