aboutsummaryrefslogtreecommitdiff
path: root/graphics/passepartout/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-12-17 05:08:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-12-17 05:08:34 +0000
commit1ba15423054fd0f7f53b043635477c8522d27715 (patch)
tree608cc7a91cca9e9d8110389cef2e7d49b51eb9cc /graphics/passepartout/Makefile
parent19aaa9ef71a26d34a9ed860020bf0205b6da043f (diff)
Notes
Diffstat (limited to 'graphics/passepartout/Makefile')
-rw-r--r--graphics/passepartout/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/passepartout/Makefile b/graphics/passepartout/Makefile
index a8d809810ca8..b4c36ac6d235 100644
--- a/graphics/passepartout/Makefile
+++ b/graphics/passepartout/Makefile
@@ -4,18 +4,18 @@
#
# $FreeBSD$
# $MCom: ports/graphics/passepartout/Makefile,v 1.4 2006/09/30 15:31:05 ahze Exp $
+#
PORTNAME= passepartout
-PORTVERSION= 0.4
-PORTREVISION= 10
+PORTVERSION= 0.6
CATEGORIES= graphics gnome
MASTER_SITES= http://www.stacken.kth.se/project/pptout/files/
MAINTAINER= gnome@FreeBSD.org
COMMENT= DTP application for X
-LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20 \
- xml\\+\\+-1.0:${PORTSDIR}/textproc/libxml++
+LIB_DEPENDS= xml\\+\\+-1.0:${PORTSDIR}/textproc/libxml++ \
+ gnomecanvasmm-2.6:${PORTSDIR}/graphics/libgnomecanvasmm26
RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_BZIP2= yes
@@ -25,12 +25,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CFALGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
-MAN1= xml2ps.1 passepartout.1x
+MAN1= xml2ps.1 passepartout.1x
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_cxx
+IGNORE= does not build on FreeBSD 4.x
.endif
.if exists(${LOCALBASE}/lib/libfam.a)
@@ -38,7 +38,7 @@ WITH_FAM= yes
.endif
.if defined(WITH_FAM)
-LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
+USE_FAM= yes
.endif
.include <bsd.port.post.mk>