aboutsummaryrefslogtreecommitdiff
path: root/graphics/passepartout
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-08-19 04:49:33 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-08-19 04:49:33 +0000
commit4561a016eaec22014d5886f9c0dfe8639d5dff4b (patch)
tree2552713f5904e382cbdd35d3ff001b2bc47240b9 /graphics/passepartout
parent945decbdadb7c988725ef2f9470c68b9b0b6f57f (diff)
downloadports-4561a016eaec22014d5886f9c0dfe8639d5dff4b.tar.gz
ports-4561a016eaec22014d5886f9c0dfe8639d5dff4b.zip
Notes
Diffstat (limited to 'graphics/passepartout')
-rw-r--r--graphics/passepartout/Makefile4
-rw-r--r--graphics/passepartout/files/patch-src::pptout::widget::dialogwrap.cc14
-rw-r--r--graphics/passepartout/files/patch-src::ps::pdf.cc16
-rw-r--r--graphics/passepartout/files/patch-src::util::valueuint.h23
-rw-r--r--graphics/passepartout/pkg-plist1
5 files changed, 56 insertions, 2 deletions
diff --git a/graphics/passepartout/Makefile b/graphics/passepartout/Makefile
index 17be78439c6c..b05e323ddf5f 100644
--- a/graphics/passepartout/Makefile
+++ b/graphics/passepartout/Makefile
@@ -7,7 +7,7 @@
PORTNAME= passepartout
PORTVERSION= 0.4
-PORTREVISION= 3
+PORTREVISION= 5
CATEGORIES= graphics gnome
MASTER_SITES= http://www.stacken.kth.se/project/pptout/files/
@@ -27,7 +27,7 @@ USE_LIBTOOL_VER=13
CONFIGURE_ENV= CFALGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
-MAN= xml2ps.1 passepartout.1x
+MAN1= xml2ps.1 passepartout.1x
.include <bsd.port.pre.mk>
diff --git a/graphics/passepartout/files/patch-src::pptout::widget::dialogwrap.cc b/graphics/passepartout/files/patch-src::pptout::widget::dialogwrap.cc
new file mode 100644
index 000000000000..47481c09a2f3
--- /dev/null
+++ b/graphics/passepartout/files/patch-src::pptout::widget::dialogwrap.cc
@@ -0,0 +1,14 @@
+--- src/pptout/widget/dialogwrap.cc.orig Thu Aug 19 00:18:05 2004
++++ src/pptout/widget/dialogwrap.cc Thu Aug 19 00:19:35 2004
+@@ -24,9 +24,9 @@
+ Gtk::Button *b = manage(button);
+ // Note: It seems that activate means "in any way except a simple click".
+ // So we have to add callbacks for both activate and clicked.
+- b->signal_clicked().connect(bind(slot(*this, &Gtk::Dialog::on_response),
++ b->signal_clicked().connect(bind(slot(*this, &DialogWrap::on_response),
+ action_id));
+- b->signal_activate().connect(bind(slot(*this, &Gtk::Dialog::on_response),
++ b->signal_activate().connect(bind(slot(*this, &DialogWrap::on_response),
+ action_id));
+ return b;
+ }
diff --git a/graphics/passepartout/files/patch-src::ps::pdf.cc b/graphics/passepartout/files/patch-src::ps::pdf.cc
new file mode 100644
index 000000000000..165de6273f5d
--- /dev/null
+++ b/graphics/passepartout/files/patch-src::ps::pdf.cc
@@ -0,0 +1,16 @@
+--- src/ps/pdf.cc.orig Wed Aug 18 23:42:10 2004
++++ src/ps/pdf.cc Wed Aug 18 23:44:28 2004
+@@ -199,10 +199,10 @@
+ bytecount write(std::ostream *out, bool binary=true, bytecount offset=0)
+ {
+ Part::write(out, binary, offset);
+- std::string str(str());
++ const std::string& s(str());
+ if(out)
+- (*out) << str;
+- return offset+str.length();
++ (*out) << s;
++ return offset+s.length();
+ }
+
+ protected:
diff --git a/graphics/passepartout/files/patch-src::util::valueuint.h b/graphics/passepartout/files/patch-src::util::valueuint.h
new file mode 100644
index 000000000000..75fd7602f90c
--- /dev/null
+++ b/graphics/passepartout/files/patch-src::util::valueuint.h
@@ -0,0 +1,23 @@
+--- src/util/valueunit.h.orig Wed Aug 18 23:48:05 2004
++++ src/util/valueunit.h Thu Aug 19 00:04:04 2004
+@@ -15,10 +15,10 @@
+ const Value& value() const { return value_; }
+ const std::string& unit() const { return unit_; }
+
+-private:
++protected:
+ Value value_;
+ std::string unit_;
+- friend std::istream& operator >> <> (std::istream& in, ValueUnit<Value>& vu);
++ friend std::istream& operator >> (std::istream& in, ValueUnit<Value>& vu);
+ };
+
+ template <typename Tp>
+@@ -44,7 +44,6 @@
+ * Special case for float, since readig a float from "14em" barfs, guessing
+ * that the 'e' is for an exponent.
+ */
+-template<>
+ std::istream& operator >> (std::istream& in, ValueUnit<float>& vu) {
+ in >> std::ws;
+ std::string value;
diff --git a/graphics/passepartout/pkg-plist b/graphics/passepartout/pkg-plist
index 56a47dd703e4..b2f5386c5d99 100644
--- a/graphics/passepartout/pkg-plist
+++ b/graphics/passepartout/pkg-plist
@@ -28,3 +28,4 @@ share/xml/passepartout/xml2ps.dtd
@dirrm share/doc/passepartout/examples
@dirrm share/doc/passepartout
@dirrm share/xml/passepartout
+@unexec /bin/rmdir %D/share/xml 2> /dev/null || /usr/bin/true