aboutsummaryrefslogtreecommitdiff
path: root/graphics/pcl-pointclouds/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-01-16 05:53:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-01-16 05:53:01 +0000
commitce6c104549aed6542f7c6972658fd46570499c26 (patch)
tree9eec1a81f28801c75f43e7125a68a1f6dc1853ff /graphics/pcl-pointclouds/Makefile
parent49cf091bdba0f8a5daf3955e142311c9619bd94a (diff)
Notes
Diffstat (limited to 'graphics/pcl-pointclouds/Makefile')
-rw-r--r--graphics/pcl-pointclouds/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/graphics/pcl-pointclouds/Makefile b/graphics/pcl-pointclouds/Makefile
new file mode 100644
index 000000000000..0f7116c01efa
--- /dev/null
+++ b/graphics/pcl-pointclouds/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= pcl
+DISTVERSIONPREFIX= ${PORTNAME}-
+DISTVERSION= 1.8.1
+CATEGORIES= graphics math
+PKGNAMESUFFIX= -pointclouds
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Point Cloud Library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libexpat.so:textproc/expat2 \
+ libflann_cpp.so:math/flann \
+ libfreetype.so:print/freetype2 \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff \
+ libvtkCommonCore-6.2.so:math/vtk6
+
+USES= cmake:outsource eigen:3,build jpeg python
+USE_GITHUB= yes
+GH_ACCOUNT= PointCloudLibrary
+USE_GL= gl glu
+USE_XORG= x11 xext xt ice sm
+USE_LDCONFIG= yes
+
+PLIST_SUB= SHL3=${DISTVERSION} SHL2=${DISTVERSION:R}
+
+DATADIR= ${PREFIX}/share/${PORTNAME}-${DISTVERSION:R} # match the directory where the project installs .cmake files
+
+post-patch: # 10 doesn't have std::sqrt, switching to ::sqrt from math.h
+ @${GREP} -rl std::sqrt ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's|::std::sqrt|::sqrt|g ; s|std::sqrt|::sqrt|g'
+
+.include <bsd.port.mk>