aboutsummaryrefslogtreecommitdiff
path: root/graphics/pecl-imagick/Makefile
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2007-04-13 18:55:51 +0000
committerAndrey Slusar <anray@FreeBSD.org>2007-04-13 18:55:51 +0000
commit8b2352261f8a4c4c72698bca9c18d1cbced319ea (patch)
tree85766161744ff3eceb021c8872e8b7901ca68738 /graphics/pecl-imagick/Makefile
parent6122a9bc48b33ddd40c858f79d37fadd907c2659 (diff)
Provides a wrapper to the ImageMagick/GraphicsMagick library.
Notes
Notes: svn path=/head/; revision=189919
Diffstat (limited to 'graphics/pecl-imagick/Makefile')
-rw-r--r--graphics/pecl-imagick/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
new file mode 100644
index 000000000000..396ec427f98e
--- /dev/null
+++ b/graphics/pecl-imagick/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-imagick
+# Date created: 13 Apr 2007
+# Whom: Andrey Slusar <anray@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imagick
+PORTVERSION= 0.9.13
+CATEGORIES= graphics
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= anray@FreeBSD.org
+COMMENT= Provides a wrapper to the ImageMagick/GraphicsMagick library
+
+LIB_DEPENDS= Magick.10:${PORTSDIR}/graphics/ImageMagick
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --with-imagick=${LOCALBASE}
+
+.include <bsd.port.mk>