aboutsummaryrefslogtreecommitdiff
path: root/graphics/pecl-vips
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-06-16 13:14:08 +0000
committerRene Ladan <rene@FreeBSD.org>2019-06-16 13:14:08 +0000
commit62808d746ed5fc7a33b6a5b6056ff5a8ef694f37 (patch)
treed01e57538b7baefb1bcf3d50f7aa6f80850b9854 /graphics/pecl-vips
parentc50eb940fe6103240af28e61f97fb739da6eb293 (diff)
downloadports-62808d746ed5fc7a33b6a5b6056ff5a8ef694f37.tar.gz
ports-62808d746ed5fc7a33b6a5b6056ff5a8ef694f37.zip
Low-level PHP binding for libvips
This extension lets you use the libvips image processing library from PHP 7. It is intentionally very low-level: modules such as https://github.com/libvips/php-vips try to layer a nice API on top of this. WWW: https://github.com/libvips/php-vips-ext PR: 238609 Submitted by: punkt.de Hosting Team <mops@punkt.de> Event: Berlin hackathon 2019
Notes
Notes: svn path=/head/; revision=504342
Diffstat (limited to 'graphics/pecl-vips')
-rw-r--r--graphics/pecl-vips/Makefile18
-rw-r--r--graphics/pecl-vips/distinfo3
-rw-r--r--graphics/pecl-vips/pkg-descr8
3 files changed, 29 insertions, 0 deletions
diff --git a/graphics/pecl-vips/Makefile b/graphics/pecl-vips/Makefile
new file mode 100644
index 000000000000..ad32d7e6e08b
--- /dev/null
+++ b/graphics/pecl-vips/Makefile
@@ -0,0 +1,18 @@
+# Created by: punkt.de Hosting Team <mops@punkt.de>
+# $FreeBSD$
+
+PORTNAME= vips
+PORTVERSION= 1.0.9
+CATEGORIES= graphics
+
+MAINTAINER= mops@punkt.de
+COMMENT= PHP bindings for libvips
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libvips.so:graphics/vips
+
+USES= php:pecl pkgconfig
+
+.include <bsd.port.mk>
diff --git a/graphics/pecl-vips/distinfo b/graphics/pecl-vips/distinfo
new file mode 100644
index 000000000000..179c3acc6518
--- /dev/null
+++ b/graphics/pecl-vips/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557409772
+SHA256 (PECL/vips-1.0.9.tgz) = aec14fe6b059dbc919ba37364ef4cec0cfd674c6360a23ad689f07cc0c29ec14
+SIZE (PECL/vips-1.0.9.tgz) = 558066
diff --git a/graphics/pecl-vips/pkg-descr b/graphics/pecl-vips/pkg-descr
new file mode 100644
index 000000000000..f0a4e763be4f
--- /dev/null
+++ b/graphics/pecl-vips/pkg-descr
@@ -0,0 +1,8 @@
+Low-level PHP binding for libvips
+
+This extension lets you use the libvips image processing library
+from PHP 7. It is intentionally very low-level: modules such as
+https://github.com/libvips/php-vips try to layer a nice API on
+top of this.
+
+WWW: https://github.com/libvips/php-vips-ext