aboutsummaryrefslogtreecommitdiff
path: root/graphics/pencil2d
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-18 09:34:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-18 09:34:51 +0000
commit9309dcd68c2cafc36c516afe07c2b6293af1943b (patch)
treed26995e97a6ac0e6c07d94cd6758309205245340 /graphics/pencil2d
parent8fc23ca4c1e5a68b1e08fc16e8bc5b8ae44ee1ec (diff)
downloadports-9309dcd68c2cafc36c516afe07c2b6293af1943b.tar.gz
ports-9309dcd68c2cafc36c516afe07c2b6293af1943b.zip
Notes
Diffstat (limited to 'graphics/pencil2d')
-rw-r--r--graphics/pencil2d/Makefile9
-rw-r--r--graphics/pencil2d/distinfo14
-rw-r--r--graphics/pencil2d/files/patch-pencil2d.pro27
3 files changed, 17 insertions, 33 deletions
diff --git a/graphics/pencil2d/Makefile b/graphics/pencil2d/Makefile
index 99e35979fc3b..35db709fd8c4 100644
--- a/graphics/pencil2d/Makefile
+++ b/graphics/pencil2d/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pencil2d
DISTVERSIONPREFIX= v
-DISTVERSION= 0.6.5
+DISTVERSION= 0.6.6
CATEGORIES= graphics math
MAINTAINER= yuri@FreeBSD.org
@@ -15,11 +15,14 @@ RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
USES= compiler:c++11-lang desktop-file-utils gl gmake qmake qt:5 \
shared-mime-info
-USE_GITHUB= yes
-USE_QT= core gui multimedia svg widgets xml xmlpatterns buildtools_build
+USE_QT= core gui multimedia network svg widgets xml xmlpatterns buildtools_build
USE_GL= gl
+
+USE_GITHUB= yes
GH_PROJECT= pencil
+QMAKE_ARGS= NO_TESTS=1
+
PLIST_FILES= bin/pencil2d \
share/applications/org.pencil2d.Pencil2D.desktop \
share/bash-completion/completions/pencil2d \
diff --git a/graphics/pencil2d/distinfo b/graphics/pencil2d/distinfo
index 6ce21fe00170..c518d654e456 100644
--- a/graphics/pencil2d/distinfo
+++ b/graphics/pencil2d/distinfo
@@ -1,3 +1,11 @@
-TIMESTAMP = 1596418829
-SHA256 (pencil2d-pencil-v0.6.5_GH0.tar.gz) = 31903c54c8f0a79385cc5f519b380d26524219984e619204820b946c96fc2482
-SIZE (pencil2d-pencil-v0.6.5_GH0.tar.gz) = 3714951
+TIMESTAMP = 1613637454
+SHA256 (pencil2d-pencil-v0.6.6_GH0.tar.gz) = 9dd1f7dd35a86dea33ec4415ac92e7df146309a1f52139c908cbd8b4767e53ff
+SIZE (pencil2d-pencil-v0.6.6_GH0.tar.gz) = 3807612
+SHA256 (55bd74577f5e761d687625a211ee32a6f8f34839.patch) = 09e51140a9a5ad559bf010b1c63ab870c8f2640d09a52f56a44bea8c4c30dd26
+SIZE (55bd74577f5e761d687625a211ee32a6f8f34839.patch) = 1329
+SHA256 (89674f5d0990c2b62f8882f451bfdc14ba136257.patch) = 45f3bcc59b3d021964ff47e94994f99c1bdfe8bba35265101f6ec60843f60afb
+SIZE (89674f5d0990c2b62f8882f451bfdc14ba136257.patch) = 4020
+SHA256 (2af3d1dddd13ce9f003f076ab7af189cb6a233a2.patch) = cecc5a8d53892da549fd606ea22b6eb27dd531392edc136a111a22c427d7c3ce
+SIZE (2af3d1dddd13ce9f003f076ab7af189cb6a233a2.patch) = 929
+SHA256 (a6d8a92b23fe12f48f7d5be6abd148f09814051c.patch) = 45b5ba32dfb220aaf5bf4ad65a1d3b28fdf071af7e9dc0a81a9edfe1d47705a9
+SIZE (a6d8a92b23fe12f48f7d5be6abd148f09814051c.patch) = 1112
diff --git a/graphics/pencil2d/files/patch-pencil2d.pro b/graphics/pencil2d/files/patch-pencil2d.pro
deleted file mode 100644
index a8cc2054a246..000000000000
--- a/graphics/pencil2d/files/patch-pencil2d.pro
+++ /dev/null
@@ -1,27 +0,0 @@
---- pencil2d.pro.orig 2020-08-03 02:00:25 UTC
-+++ pencil2d.pro
-@@ -6,8 +6,8 @@ TEMPLATE = subdirs
-
- SUBDIRS = \ # sub-project names
- core_lib \
-- app \
-- tests
-+ app
-+# tests
-
- # build the project sequentially as listed in SUBDIRS !
- CONFIG += ordered
-@@ -15,11 +15,11 @@ CONFIG += ordered
- # where to find the sub projects - give the folders
- core_lib.subdir = core_lib
- app.subdir = app
--tests.subdir = tests
-+#tests.subdir = tests
-
- # what subproject depends on others
- app.depends = core_lib
--tests.depends = core_lib
-+#tests.depends = core_lib
-
- TRANSLATIONS += translations/pencil.ts \
- translations/pencil_ar.ts \