aboutsummaryrefslogtreecommitdiff
path: root/graphics/pgplot
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-12-08 03:14:30 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-12-08 03:14:30 +0000
commit34e6aeaae4ab9c8b22d9d4cf0cb6061bd67130af (patch)
tree608dadd36cdcf29aa8a34e5491b8237f165dc82c /graphics/pgplot
parent8dffb4e39da8e083918c8c7552cde59c3c645ba2 (diff)
downloadports-34e6aeaae4ab9c8b22d9d4cf0cb6061bd67130af.tar.gz
ports-34e6aeaae4ab9c8b22d9d4cf0cb6061bd67130af.zip
Notes
Diffstat (limited to 'graphics/pgplot')
-rw-r--r--graphics/pgplot/Makefile9
-rw-r--r--graphics/pgplot/files/drivers_64bit_patch33
-rw-r--r--graphics/pgplot/pkg-descr5
3 files changed, 42 insertions, 5 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 6e93eadc3abd..c237bd1bc69c 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pgplot
PORTVERSION= 5.2.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.astro.caltech.edu/pub/pgplot/
DISTNAME= ${PORTNAME}${PORTVERSION:R}
@@ -29,6 +29,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
+.if !empty(ARCH:M*64*)
+EXTRA_PATCHES += ${FILESDIR}/drivers_64bit_patch
+.endif
+
.ifndef(NOPORTDATA)
PORTDATA= grfont.dat
.endif
@@ -85,13 +89,14 @@ do-install:
.endif
.if defined(MAINTAINER_MODE) && !defined(BATCH)
+DEMO?= cpgdemo
check test: build
@cd ${WRKSRC}; ${CP} cpg/cpgdemo.c examples/pgdemo*.f ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
Makefile.demo ${_MAKE_JOBS} ${MAKE_ARGS}
@${SETENV} LD_LIBRARY_PATH="${LOCALBASE}/lib:${WRKSRC}" \
- PGPLOT_DIR="${WRKSRC}" PGPLOT_DEV="/xwin" ${WRKSRC}/cpgdemo
+ PGPLOT_DIR="${WRKSRC}" PGPLOT_DEV="/xwin" ${WRKSRC}/${DEMO}
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/pgplot/files/drivers_64bit_patch b/graphics/pgplot/files/drivers_64bit_patch
new file mode 100644
index 000000000000..33a8ddc5204f
--- /dev/null
+++ b/graphics/pgplot/files/drivers_64bit_patch
@@ -0,0 +1,33 @@
+--- drivers/gidriv.f.orig 1998-05-13 21:05:05.000000000 -0400
++++ drivers/gidriv.f 2011-12-07 16:57:04.000000000 -0500
+@@ -78,7 +78,7 @@
+ C Note: for 64-bit operating systems, change the following
+ C declaration to INTEGER*8:
+ C
+- INTEGER PIXMAP, WORK
++ INTEGER*8 PIXMAP, WORK
+ C
+ SAVE UNIT, IC, CTABLE, NPICT, MAXIDX, BX, BY, PIXMAP, FILENM
+ SAVE CDEFLT, STATE
+--- drivers/ppdriv.f.orig 1998-05-13 21:04:29.000000000 -0400
++++ drivers/ppdriv.f 2011-12-07 16:57:39.000000000 -0500
+@@ -68,7 +68,7 @@
+ C Note: for 64-bit operating systems, change the following
+ C declaration to INTEGER*8:
+ C
+- INTEGER PIXMAP
++ INTEGER*8 PIXMAP
+ C
+ SAVE UNIT, IC, CVAL, CTABLE, BX, BY, PIXMAP, NPICT, CDEFLT
+ SAVE STATE
+--- drivers/wddriv.f.orig 1998-05-13 21:03:53.000000000 -0400
++++ drivers/wddriv.f 2011-12-07 16:56:29.000000000 -0500
+@@ -61,7 +61,7 @@
+ C Note: for 64-bit operating systems, change the following
+ C declaration to INTEGER*8:
+ C
+- INTEGER PIXMAP
++ INTEGER*8 PIXMAP
+ C
+ SAVE UNIT, IC, CTABLE, NPICT, MAXIDX, BX, BY, PIXMAP, FILENM
+ SAVE CDEFLT, STATE
diff --git a/graphics/pgplot/pkg-descr b/graphics/pgplot/pkg-descr
index 3f6c6807e63c..52f84ff8fab1 100644
--- a/graphics/pgplot/pkg-descr
+++ b/graphics/pgplot/pkg-descr
@@ -1,13 +1,12 @@
PGPLOT is a Fortran subroutine package for drawing graphs on a variety
of display devices. For more details, see the manual ``PGPLOT Graphics
-Subroutine Library'' available from T. J. Pearson
+Subroutine Library'', available from T. J. Pearson.
The CPGPLOT library adds an intermediate level of wrapper functions
between C programs and the PGPLOT library. These functions hide the
system dependencies of calling PGPLOT behind a system independent
interface.
-Documentation and demo programs are available in the /usr/local/share/pgplot
-directory.
+Documentation and demo programs are included.
WWW: http://www.astro.caltech.edu/~tjp/pgplot/