aboutsummaryrefslogtreecommitdiff
path: root/graphics/php-facedetect
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-03-26 14:06:05 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-03-26 14:06:05 +0000
commitcad5b87dbc2adb65591e27c9ff6d80215962dc51 (patch)
tree11787c057cbad7cc19f92930685057c3616ca963 /graphics/php-facedetect
parent3141ced01bd44d88fb6fa9cf9534cb1c8576cee8 (diff)
downloadports-cad5b87dbc2adb65591e27c9ff6d80215962dc51.tar.gz
ports-cad5b87dbc2adb65591e27c9ff6d80215962dc51.zip
Notes
Diffstat (limited to 'graphics/php-facedetect')
-rw-r--r--graphics/php-facedetect/Makefile34
-rw-r--r--graphics/php-facedetect/distinfo3
-rw-r--r--graphics/php-facedetect/pkg-descr6
3 files changed, 43 insertions, 0 deletions
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
new file mode 100644
index 000000000000..38ad29132cdf
--- /dev/null
+++ b/graphics/php-facedetect/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: php5-facedetect
+# Date created: 2010-03-26
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= facedetect
+PORTVERSION= 1.0.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.xarg.org/download/
+PKGNAMEPREFIX= php-
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Face detection extension for PHP using OpenCV library
+
+LIB_DEPENDS= cv.2:${PORTSDIR}/graphics/opencv
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+CONFIGURE_ARGS+= --with-facedetect
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${TOUCH} ${WRKSRC}/cvconfig.h
+
+.include <bsd.port.mk>
diff --git a/graphics/php-facedetect/distinfo b/graphics/php-facedetect/distinfo
new file mode 100644
index 000000000000..936b2c56b59a
--- /dev/null
+++ b/graphics/php-facedetect/distinfo
@@ -0,0 +1,3 @@
+MD5 (facedetect-1.0.1.tar.gz) = 7b566742020e54bc5938d766f698001a
+SHA256 (facedetect-1.0.1.tar.gz) = 248f6d265219ae24e3c2f1c8b8e5801bcad4a70d5460a1f1d29cecdd04b7f188
+SIZE (facedetect-1.0.1.tar.gz) = 2791
diff --git a/graphics/php-facedetect/pkg-descr b/graphics/php-facedetect/pkg-descr
new file mode 100644
index 000000000000..c7585538b2c2
--- /dev/null
+++ b/graphics/php-facedetect/pkg-descr
@@ -0,0 +1,6 @@
+This extension provides a PHP implementation of the OpenCV library.
+The extension offers two new functions. In princible, they differ only by
+their return value. The first returns only the number of faces found on the
+given image and the other an associative array of their coordinates.
+
+WWW: http://www.xarg.org/project/php-facedetect/