aboutsummaryrefslogtreecommitdiff
path: root/graphics/php5-ffmpeg
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-09 17:35:36 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-09 17:35:36 +0000
commit8f9cb61e4e69bd1e17091c3de183b80ea72e8874 (patch)
treef6d7b257522b051d21bfe355eec458d4d32a7eb4 /graphics/php5-ffmpeg
parentaac3afae12b6eba84d827a678b72aa41687e8e79 (diff)
Notes
Diffstat (limited to 'graphics/php5-ffmpeg')
-rw-r--r--graphics/php5-ffmpeg/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 3044414ed70c..d47aaccbcc5f 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -16,7 +16,7 @@ COMMENT= The ffmpeg shared extension for php
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libavutil0.so:${PORTSDIR}/multimedia/ffmpeg0
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include/ffmpeg0
LDFLAGS+= -L${LOCALBASE}/lib/ffmpeg0
USE_BZIP2= yes
USE_PHP= yes
@@ -41,6 +41,8 @@ pre-configure:
-e 's,lavformat,lavformat0,g' \
-e 's,lavutil,lavutil0,g' \
-e 's,lswscale,lswscale0,g' \
+ -e 's,include/libavcodec,include/ffmpeg0/libavcodec,g' \
+ -e 's,/libavcodec.so,/ffmpeg0/libavcodec0.so,g' \
${WRKSRC}/configure
post-configure: