aboutsummaryrefslogtreecommitdiff
path: root/graphics/php5-ffmpeg
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-07-24 16:38:20 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-07-24 16:38:20 +0000
commitab5c533c96df6234b64e4f99978215af3f98aebc (patch)
tree187b1892fb8c00b1a03fd082eb3798992b00ee64 /graphics/php5-ffmpeg
parent2e88b1de64abfd339132c5718df65cdaa32379d4 (diff)
downloadports-ab5c533c96df6234b64e4f99978215af3f98aebc.tar.gz
ports-ab5c533c96df6234b64e4f99978215af3f98aebc.zip
Notes
Diffstat (limited to 'graphics/php5-ffmpeg')
-rw-r--r--graphics/php5-ffmpeg/Makefile2
-rw-r--r--graphics/php5-ffmpeg/files/patch-ffmpeg_frame.c29
2 files changed, 30 insertions, 1 deletions
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 05978b2874ed..769dce44fbee 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.6.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}-php/${PORTNAME}-php/${PORTVERSION}
PKGNAMEPREFIX= php5-
diff --git a/graphics/php5-ffmpeg/files/patch-ffmpeg_frame.c b/graphics/php5-ffmpeg/files/patch-ffmpeg_frame.c
new file mode 100644
index 000000000000..9c783972acd2
--- /dev/null
+++ b/graphics/php5-ffmpeg/files/patch-ffmpeg_frame.c
@@ -0,0 +1,29 @@
+--- ffmpeg_frame.c.orig 2010-07-21 10:31:08.581341617 +0200
++++ ffmpeg_frame.c 2010-07-21 10:31:21.405528178 +0200
+@@ -333,7 +333,7 @@
+
+ GET_FRAME_RESOURCE(getThis(), ff_frame);
+
+- _php_convert_frame(ff_frame, PIX_FMT_RGBA32);
++ _php_convert_frame(ff_frame, PIX_FMT_RGB32);
+
+ return_value->value.lval = _php_get_gd_image(ff_frame->width,
+ ff_frame->height);
+@@ -418,7 +418,7 @@
+
+ /* create a an av_frame and allocate space for it */
+ frame = avcodec_alloc_frame();
+- avpicture_alloc((AVPicture*)frame, PIX_FMT_RGBA32, width, height);
++ avpicture_alloc((AVPicture*)frame, PIX_FMT_RGB32, width, height);
+
+ /* copy the gd image to the av_frame */
+ _php_gd_image_to_avframe(gd_img, frame, width, height);
+@@ -429,7 +429,7 @@
+ /* set the ffpmeg_frame's properties */
+ ff_frame->width = width;
+ ff_frame->height = height;
+- ff_frame->pixel_format = PIX_FMT_RGBA32;
++ ff_frame->pixel_format = PIX_FMT_RGB32;
+ break;
+ default:
+ zend_error(E_ERROR, "Invalid argument\n");