aboutsummaryrefslogtreecommitdiff
path: root/graphics/phplot
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2008-02-21 12:15:16 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2008-02-21 12:15:16 +0000
commit323da97f75b6003fc55d0651ed01c4cc0fcb181f (patch)
treed3f7ef1ef654014331c1400c914ef0de333c23f1 /graphics/phplot
parent4e44e25db876a797565d7d5e00a3fb5a12973e52 (diff)
downloadports-323da97f75b6003fc55d0651ed01c4cc0fcb181f.tar.gz
ports-323da97f75b6003fc55d0651ed01c4cc0fcb181f.zip
Notes
Diffstat (limited to 'graphics/phplot')
-rw-r--r--graphics/phplot/Makefile113
-rw-r--r--graphics/phplot/distinfo9
-rw-r--r--graphics/phplot/pkg-plist246
3 files changed, 280 insertions, 88 deletions
diff --git a/graphics/phplot/Makefile b/graphics/phplot/Makefile
index 0740184bc15a..a5c84dbacef3 100644
--- a/graphics/phplot/Makefile
+++ b/graphics/phplot/Makefile
@@ -5,59 +5,90 @@
# $FreeBSD$
PORTNAME= phplot
-PORTVERSION= 4.4.6
-PORTREVISION= 3
+PORTVERSION= 5.0.5
CATEGORIES= graphics www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= phplot
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}docs-20080113.zip
MAINTAINER= yukinopo@livedoor.com
COMMENT= A PHP class for creating scientific and business charts
-USE_PHP= yes
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+USE_ZIP= yes
+USE_PHP= yes
+DEFAULT_PHP_VER= 5
+IGNORE_WITH_PHP= 4
NO_BUILD= YES
-WRKSRC= ${WRKDIR}/${DISTNAME}
-PHPLOT_DIR= lib/php/phplot
+PHPLOT_DIR= ${PREFIX}/include/php/phplot
-PHPLOT_EXAMPLE= share/phplot
+LIBS= phplot.php phplot_data.php rgb.inc.php
-LIBS= phplot.php phplot_data.php rgb.inc.php benjamingothic.ttf
+DOCS= DrawGraph.html GetCallback.html PHPlot.html PrintImage.html \
+ RemoveCallback.html SetBackgroundColor.html SetBgImage.html \
+ SetBrowserCache.html SetCallback.html SetDataBorderColors.html \
+ SetDataColors.html SetDataType.html SetDataValues.html \
+ SetDefaultDashedStyle.html SetDefaultTTFont.html SetDrawBrokenLines.html \
+ SetDrawDashedGrid.html SetDrawPlotAreaBackground.html \
+ SetDrawXDataLabelLines.html SetDrawXGrid.html SetDrawYDataLabelLines.html \
+ SetDrawYGrid.html SetErrorBarColors.html SetErrorBarLineWidth.html \
+ SetErrorBarShape.html SetErrorBarSize.html SetFileFormat.html \
+ SetFont.html SetGridColor.html SetImageBorderColor.html SetImageBorderType.html \
+ SetIsInline.html SetLabelColor.html SetLabelScalePosition.html SetLegend.html \
+ SetLegendPixels.html SetLegendStyle.html SetLegendWorld.html SetLightGridColor.html \
+ SetLineSpacing.html SetLineStyles.html SetLineWidths.html SetMarginsPixels.html \
+ SetNumXTicks.html SetNumYTicks.html SetNumberFormat.html SetOutputFile.html \
+ SetPlotAreaBgImage.html SetPlotAreaPixels.html SetPlotAreaWorld.html \
+ SetPlotBgColor.html SetPlotBorderType.html SetPlotType.html SetPointShapes.html \
+ SetPointSizes.html SetPrecisionX.html SetPrecisionY.html SetPrintImage.html \
+ SetRGBArray.html SetShading.html SetSkipBottomTick.html SetSkipLeftTick.html \
+ SetSkipRightTick.html SetSkipTopTick.html SetTTFPath.html SetTextColor.html \
+ SetTickColor.html SetTitle.html SetTitleColor.html SetTransparentColor.html \
+ SetUseTTF.html SetXAxisPosition.html SetXDataLabelPos.html SetXLabelAngle.html \
+ SetXLabelType.html SetXScaleType.html SetXTickCrossing.html SetXTickIncrement.html \
+ SetXTickLabelPos.html SetXTickLength.html SetXTickPos.html SetXTimeFormat.html \
+ SetXTitle.html SetYAxisPosition.html SetYDataLabelPos.html SetYLabelAngle.html \
+ SetYLabelType.html SetYScaleType.html SetYTickCrossing.html SetYTickIncrement.html \
+ SetYTickLabelPos.html SetYTickLength.html SetYTickPos.html SetYTimeFormat.html \
+ SetYTitle.html callbacks-access.html callbacks-names.html callbacks-objects.html \
+ callbacks.html changelog.html conc-colors.html conc-datatypes.html \
+ conc-errors.html conc-extradata.html conc-labels.html conc-overview.html \
+ conc-plottypes.html concepts.html dev-internal.html dev-layout.html dev-legend.html \
+ ex-area1.html ex-bars1.html ex-bars2.html ex-bars3.html ex-bars4.html ex-linepoints1.html \
+ ex-lines2.html ex-pie1.html ex-pie2.html ex-pie3.html ex-points1.html ex-points2.html \
+ ex-squared1.html ex-stackedbars1.html ex-stackedbars2.html ex-thinbarline1.html \
+ ex-thinbarline2.html ex-twoplot1.html examples.html functions.html index.html \
+ install-install.html install-next.html install.html part1.html part3.html \
+ phplotdoc.css preface.html ref-addlstyle.html ref-axes.html ref-callbacks.html \
+ ref-colorstyle.html ref-errorbars.html ref-grid.html ref-iocontrol.html \
+ ref-labels.html ref-legend.html ref-scaling.html ref-textfonts.html ref-ticks.html \
+ ref-titles.html reference.html start-multiple.html starting-create.html \
+ starting-custom.html starting-more.html starting-next.html starting-simple.html \
+ starting.html
-DOCS= internal_functions.html function_reference.html \
- index.html examples.html quick_start.php \
- user_functions.html user_internal_functions.html
+EXAMPLES= area1.png bars1.png bars2.png bars3.png bars4.png linepoints1.png lines1.png \
+ lines2.png pie1.png pie2.png pie3.png points1.png points2.png qs1.png qs2.png \
+ qs3.png squared1.png stackedbars1.png stackedbars2.png thinbarline1.png \
+ thinbarline2.png twoplot1.png
-EXAMPLES= 0cars.jpg benjamingothic.ttf create_chart.php \
- data.php data_date.php data_date2.php data_sample1.php data_sample2.php \
- data_sample3.php data_sample4.php example1.php example10.php \
- example11.php example12.php example13.php example2.php \
- example3.php example4.php example5.php example6.php \
- example7.php example8.php example9.php format_chart.php \
- inline_image.php rgb.inc.php test1.php test_setup.php
+IMAGES= colors.png error-image.png fonts.png gdinfo.png labels-pie.png labels.png \
+ layout.png legend-layout.png legendstyle.png ticksize.png typical-grid.png \
+ typical-legend.png typical-titles.png
-do-install:
- @${MKDIR} ${PREFIX}/${PHPLOT_DIR} 2>/dev/null||true
-.for FILE in ${SAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} \
- @${PREFIX}/${PHPLOT_DIR}/${FILE}
-.endfor
-
-.for FILE in ${LIBS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/${PHPLOT_DIR}
-.endfor
- @${MKDIR} ${PREFIX}/${PHPLOT_EXAMPLE}
- @${MKDIR} ${PREFIX}/${PHPLOT_EXAMPLE}/doc
- @${MKDIR} ${PREFIX}/${PHPLOT_EXAMPLE}/examples
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${PREFIX}/${PHPLOT_EXAMPLE}/doc
-.endfor
-
-.for FILE in ${EXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/examples/${FILE} ${PREFIX}/${PHPLOT_EXAMPLE}/examples
-.endfor
+OPTIONS= FONTS "Install TrueType fonts" on
+.if defined(WITH_FONTS)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.endif
+
+do-install:
+ @${MKDIR} ${PHPLOT_DIR} ${EXAMPLESDIR}/images ${DOCSDIR}
+ @${INSTALL_DATA} ${LIBS:S,^,${WRKSRC}/,} ${PHPLOT_DIR}/
+.if !defined(NOPORTDOCS)
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKDIR}/phplotdocs/,} ${DOCSDIR}/
+ @${INSTALL_DATA} ${EXAMPLES:S,^,${WRKDIR}/phplotdocs/examples/,} ${EXAMPLESDIR}/
+ @${INSTALL_DATA} ${IMAGES:S,^,${WRKDIR}/phplotdocs/images/,} ${EXAMPLESDIR}/images/
+.endif
.include <bsd.port.mk>
diff --git a/graphics/phplot/distinfo b/graphics/phplot/distinfo
index 6c5ca74ea347..1556f5c37914 100644
--- a/graphics/phplot/distinfo
+++ b/graphics/phplot/distinfo
@@ -1,3 +1,6 @@
-MD5 (phplot-4.4.6.tar.gz) = 8a5b34e09fa29f20e31814cbd8c0d0b5
-SHA256 (phplot-4.4.6.tar.gz) = 92017a35db4c7c32742e4497b0dafa101cc445538af697a3cfdcad36461aa45a
-SIZE (phplot-4.4.6.tar.gz) = 90005
+MD5 (phplot-5.0.5.zip) = 2f98adcff8761a3d5349c23c41636e66
+SHA256 (phplot-5.0.5.zip) = 63e55e404e75d7a2cb6b9adbd76c709b997b44fcb1cf9ac278854658d15a3242
+SIZE (phplot-5.0.5.zip) = 76667
+MD5 (phplotdocs-20080113.zip) = 3b923e8fc4abcf08301806411378f34e
+SHA256 (phplotdocs-20080113.zip) = 269627af1ccd25110e94a084501700e987448f684b12f37a0827a618d9a73239
+SIZE (phplotdocs-20080113.zip) = 448343
diff --git a/graphics/phplot/pkg-plist b/graphics/phplot/pkg-plist
index 7b27fd87cdc2..bc8dc01c5ca5 100644
--- a/graphics/phplot/pkg-plist
+++ b/graphics/phplot/pkg-plist
@@ -1,44 +1,202 @@
-lib/php/phplot/phplot.php
-lib/php/phplot/phplot_data.php
-lib/php/phplot/rgb.inc.php
-lib/php/phplot/benjamingothic.ttf
-@dirrm lib/php/phplot
-@unexec rmdir lib/php 2>/dev/null || true
-share/phplot/examples/test_setup.php
-share/phplot/examples/benjamingothic.ttf
-share/phplot/examples/create_chart.php
-share/phplot/examples/data.php
-share/phplot/examples/data_date.php
-share/phplot/examples/data_date2.php
-share/phplot/examples/data_sample1.php
-share/phplot/examples/data_sample2.php
-share/phplot/examples/data_sample3.php
-share/phplot/examples/data_sample4.php
-share/phplot/examples/example1.php
-share/phplot/examples/example10.php
-share/phplot/examples/example11.php
-share/phplot/examples/example12.php
-share/phplot/examples/example13.php
-share/phplot/examples/example2.php
-share/phplot/examples/example3.php
-share/phplot/examples/example4.php
-share/phplot/examples/example5.php
-share/phplot/examples/example6.php
-share/phplot/examples/example7.php
-share/phplot/examples/example8.php
-share/phplot/examples/example9.php
-share/phplot/examples/format_chart.php
-share/phplot/examples/inline_image.php
-share/phplot/examples/rgb.inc.php
-share/phplot/examples/test1.php
-share/phplot/examples/0cars.jpg
-share/phplot/doc/internal_functions.html
-share/phplot/doc/function_reference.html
-share/phplot/doc/index.html
-share/phplot/doc/examples.html
-share/phplot/doc/quick_start.php
-share/phplot/doc/user_functions.html
-share/phplot/doc/user_internal_functions.html
-@dirrm share/phplot/examples
-@dirrm share/phplot/doc
-@dirrm share/phplot
+include/php/phplot/phplot.php
+include/php/phplot/phplot_data.php
+include/php/phplot/rgb.inc.php
+%%PORTDOCS%%%%DOCSDIR%%/DrawGraph.html
+%%PORTDOCS%%%%DOCSDIR%%/GetCallback.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPlot.html
+%%PORTDOCS%%%%DOCSDIR%%/PrintImage.html
+%%PORTDOCS%%%%DOCSDIR%%/RemoveCallback.html
+%%PORTDOCS%%%%DOCSDIR%%/SetBackgroundColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetBgImage.html
+%%PORTDOCS%%%%DOCSDIR%%/SetBrowserCache.html
+%%PORTDOCS%%%%DOCSDIR%%/SetCallback.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDataBorderColors.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDataColors.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDataType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDataValues.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDefaultDashedStyle.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDefaultTTFont.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawBrokenLines.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawXGrid.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawDashedGrid.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawPlotAreaBackground.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawXDataLabelLines.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawYDataLabelLines.html
+%%PORTDOCS%%%%DOCSDIR%%/SetDrawYGrid.html
+%%PORTDOCS%%%%DOCSDIR%%/SetErrorBarColors.html
+%%PORTDOCS%%%%DOCSDIR%%/SetErrorBarLineWidth.html
+%%PORTDOCS%%%%DOCSDIR%%/SetErrorBarShape.html
+%%PORTDOCS%%%%DOCSDIR%%/SetErrorBarSize.html
+%%PORTDOCS%%%%DOCSDIR%%/SetFileFormat.html
+%%PORTDOCS%%%%DOCSDIR%%/SetFont.html
+%%PORTDOCS%%%%DOCSDIR%%/SetGridColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetImageBorderColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetImageBorderType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetIsInline.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLabelColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLabelScalePosition.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLegend.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLegendPixels.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLegendStyle.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLegendWorld.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLightGridColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLineSpacing.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLineStyles.html
+%%PORTDOCS%%%%DOCSDIR%%/SetLineWidths.html
+%%PORTDOCS%%%%DOCSDIR%%/SetMarginsPixels.html
+%%PORTDOCS%%%%DOCSDIR%%/SetNumXTicks.html
+%%PORTDOCS%%%%DOCSDIR%%/SetNumYTicks.html
+%%PORTDOCS%%%%DOCSDIR%%/SetNumberFormat.html
+%%PORTDOCS%%%%DOCSDIR%%/SetOutputFile.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPlotAreaBgImage.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPlotAreaPixels.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPlotAreaWorld.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPlotBgColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPlotBorderType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPlotType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPointShapes.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPointSizes.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPrecisionX.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPrecisionY.html
+%%PORTDOCS%%%%DOCSDIR%%/SetPrintImage.html
+%%PORTDOCS%%%%DOCSDIR%%/SetRGBArray.html
+%%PORTDOCS%%%%DOCSDIR%%/SetShading.html
+%%PORTDOCS%%%%DOCSDIR%%/SetSkipBottomTick.html
+%%PORTDOCS%%%%DOCSDIR%%/SetSkipLeftTick.html
+%%PORTDOCS%%%%DOCSDIR%%/SetSkipRightTick.html
+%%PORTDOCS%%%%DOCSDIR%%/SetSkipTopTick.html
+%%PORTDOCS%%%%DOCSDIR%%/SetTTFPath.html
+%%PORTDOCS%%%%DOCSDIR%%/SetTextColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetTickColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetTitle.html
+%%PORTDOCS%%%%DOCSDIR%%/SetTitleColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetTransparentColor.html
+%%PORTDOCS%%%%DOCSDIR%%/SetUseTTF.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXAxisPosition.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXDataLabelPos.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXLabelAngle.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXLabelType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXScaleType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTickCrossing.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTickIncrement.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTickLabelPos.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTickLength.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTickPos.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTimeFormat.html
+%%PORTDOCS%%%%DOCSDIR%%/SetXTitle.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYAxisPosition.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYDataLabelPos.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYLabelAngle.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYLabelType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYScaleType.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTickCrossing.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTickIncrement.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTickLabelPos.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTickLength.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTickPos.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTimeFormat.html
+%%PORTDOCS%%%%DOCSDIR%%/SetYTitle.html
+%%PORTDOCS%%%%DOCSDIR%%/callbacks-access.html
+%%PORTDOCS%%%%DOCSDIR%%/callbacks-names.html
+%%PORTDOCS%%%%DOCSDIR%%/callbacks-objects.html
+%%PORTDOCS%%%%DOCSDIR%%/callbacks.html
+%%PORTDOCS%%%%DOCSDIR%%/changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-colors.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-datatypes.html
+%%PORTDOCS%%%%DOCSDIR%%/concepts.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-errors.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-extradata.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-labels.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-overview.html
+%%PORTDOCS%%%%DOCSDIR%%/conc-plottypes.html
+%%PORTDOCS%%%%DOCSDIR%%/dev-internal.html
+%%PORTDOCS%%%%DOCSDIR%%/dev-layout.html
+%%PORTDOCS%%%%DOCSDIR%%/dev-legend.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-area1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-bars1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-bars2.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-bars3.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-bars4.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-linepoints1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-lines2.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-pie1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-pie2.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-pie3.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-points1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-points2.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-squared1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-stackedbars1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-stackedbars2.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-thinbarline1.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-thinbarline2.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-twoplot1.html
+%%PORTDOCS%%%%DOCSDIR%%/examples.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/install-install.html
+%%PORTDOCS%%%%DOCSDIR%%/install-next.html
+%%PORTDOCS%%%%DOCSDIR%%/install.html
+%%PORTDOCS%%%%DOCSDIR%%/part1.html
+%%PORTDOCS%%%%DOCSDIR%%/part3.html
+%%PORTDOCS%%%%DOCSDIR%%/phplotdoc.css
+%%PORTDOCS%%%%DOCSDIR%%/preface.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-addlstyle.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-axes.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-callbacks.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-colorstyle.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-errorbars.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-grid.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-iocontrol.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-labels.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-legend.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-scaling.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-textfonts.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-ticks.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-titles.html
+%%PORTDOCS%%%%DOCSDIR%%/reference.html
+%%PORTDOCS%%%%DOCSDIR%%/start-multiple.html
+%%PORTDOCS%%%%DOCSDIR%%/starting-create.html
+%%PORTDOCS%%%%DOCSDIR%%/starting-custom.html
+%%PORTDOCS%%%%DOCSDIR%%/starting-more.html
+%%PORTDOCS%%%%DOCSDIR%%/starting-next.html
+%%PORTDOCS%%%%DOCSDIR%%/starting-simple.html
+%%PORTDOCS%%%%DOCSDIR%%/starting.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/colors.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/error-image.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/fonts.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/gdinfo.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/labels-pie.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/labels.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/layout.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/legend-layout.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/legendstyle.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/ticksize.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/typical-grid.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/typical-legend.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/images/typical-titles.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/area1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/bars1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/bars2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/bars3.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/bars4.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/linepoints1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/lines1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/lines2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/pie1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/pie2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/pie3.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/points1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/points2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/qs1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/qs2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/qs3.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/squared1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/stackedbars1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/stackedbars2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/thinbarline1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/thinbarline2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/twoplot1.png
+@dirrmtry include/php/phplot
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/images
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%