aboutsummaryrefslogtreecommitdiff
path: root/graphics/phplot
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2001-12-03 03:02:56 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2001-12-03 03:02:56 +0000
commitd0c0d92dc0ebfa8663948580f9ce629f844d6cfa (patch)
tree28028f70a0e172178072fc539ac03c8497907943 /graphics/phplot
parent98bf0db6923a0a554b2e7ded035c1881212f7da9 (diff)
Notes
Diffstat (limited to 'graphics/phplot')
-rw-r--r--graphics/phplot/Makefile61
-rw-r--r--graphics/phplot/distinfo1
-rw-r--r--graphics/phplot/pkg-comment1
-rw-r--r--graphics/phplot/pkg-descr8
-rw-r--r--graphics/phplot/pkg-plist44
5 files changed, 115 insertions, 0 deletions
diff --git a/graphics/phplot/Makefile b/graphics/phplot/Makefile
new file mode 100644
index 000000000000..a1957c286846
--- /dev/null
+++ b/graphics/phplot/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: phplot
+# Date created: 21 Oct 2001
+# Whom: yukinopo@livedoor.com
+#
+# $FreeBSD$
+
+PORTNAME= phplot
+PORTVERSION= 4.4.6
+CATEGORIES= graphics www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phplot
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= yukinopo@livedoor.com
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+
+NO_BUILD= YES
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+PHPLOT_DIR= lib/php/phplot
+
+PHPLOT_EXAMPLE= share/phplot
+
+LIBS= phplot.php phplot_data.php rgb.inc.php benjamingothic.ttf
+
+DOCS= internal_functions.html function_reference.html \
+ index.html examples.html quick_start.php \
+ user_functions.html user_internal_functions.html
+
+EXAMPLES= 0cars.jpg benjamingothic.ttf create_chart.php \
+ data.php data_date.php data_date2.php data_sample1.php data_sample2.php \
+ data_sample3.php data_sample4.php example1.php example10.php \
+ example11.php example12.php example13.php example2.php \
+ example3.php example4.php example5.php example6.php \
+ example7.php example8.php example9.php format_chart.php \
+ inline_image.php rgb.inc.php test1.php test_setup.php
+
+do-install:
+ @${MKDIR} ${PREFIX}/${PHPLOT_DIR} 2>/dev/null||true
+.for FILE in ${SAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} \
+ @${PREFIX}/${PHPLOT_DIR}/${FILE}
+.endfor
+
+.for FILE in ${LIBS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/${PHPLOT_DIR}
+.endfor
+ @${MKDIR} ${PREFIX}/${PHPLOT_EXAMPLE}
+ @${MKDIR} ${PREFIX}/${PHPLOT_EXAMPLE}/doc
+ @${MKDIR} ${PREFIX}/${PHPLOT_EXAMPLE}/examples
+.for FILE in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${PREFIX}/${PHPLOT_EXAMPLE}/doc
+.endfor
+
+.for FILE in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${FILE} ${PREFIX}/${PHPLOT_EXAMPLE}/examples
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/phplot/distinfo b/graphics/phplot/distinfo
new file mode 100644
index 000000000000..93254ae34557
--- /dev/null
+++ b/graphics/phplot/distinfo
@@ -0,0 +1 @@
+MD5 (phplot-4.4.6.tar.gz) = 8a5b34e09fa29f20e31814cbd8c0d0b5
diff --git a/graphics/phplot/pkg-comment b/graphics/phplot/pkg-comment
new file mode 100644
index 000000000000..4e68126cb785
--- /dev/null
+++ b/graphics/phplot/pkg-comment
@@ -0,0 +1 @@
+A PHP class for creating scientific and business charts
diff --git a/graphics/phplot/pkg-descr b/graphics/phplot/pkg-descr
new file mode 100644
index 000000000000..f1a3f7081273
--- /dev/null
+++ b/graphics/phplot/pkg-descr
@@ -0,0 +1,8 @@
+A graph library for dynamic scientific, business, and stock-market charts.
+Written in PHP and supports, PHP3, PHP4, TTF (or no ttf), and GD versions 1.2 -
+latest version. Includes Pie, Bar, Line, Area, Point and combination plots.
+
+WWW: http://www.phplot.com
+
+- K.Shiomi
+yukinopo@livedoor.com
diff --git a/graphics/phplot/pkg-plist b/graphics/phplot/pkg-plist
new file mode 100644
index 000000000000..0a0335012d5e
--- /dev/null
+++ b/graphics/phplot/pkg-plist
@@ -0,0 +1,44 @@
+lib/php/phplot/phplot.php
+lib/php/phplot/phplot_data.php
+lib/php/phplot/rgb.inc.php
+lib/php/phplot/benjamingothic.ttf
+@dirrm lib/php/phplot
+@unexec rmdir lib/php 2>/dev/null || true
+share/phplot/examples/test_setup.php
+share/phplot/examples/benjamingothic.ttf
+share/phplot/examples/create_chart.php
+share/phplot/examples/data.php
+share/phplot/examples/data_date.php
+share/phplot/examples/data_date2.php
+share/phplot/examples/data_sample1.php
+share/phplot/examples/data_sample2.php
+share/phplot/examples/data_sample3.php
+share/phplot/examples/data_sample4.php
+share/phplot/examples/example1.php
+share/phplot/examples/example10.php
+share/phplot/examples/example11.php
+share/phplot/examples/example12.php
+share/phplot/examples/example13.php
+share/phplot/examples/example2.php
+share/phplot/examples/example3.php
+share/phplot/examples/example4.php
+share/phplot/examples/example5.php
+share/phplot/examples/example6.php
+share/phplot/examples/example7.php
+share/phplot/examples/example8.php
+share/phplot/examples/example9.php
+share/phplot/examples/format_chart.php
+share/phplot/examples/inline_image.php
+share/phplot/examples/rgb.inc.php
+share/phplot/examples/test1.php
+share/phplot/examples/0cars.jpg
+share/phplot/doc/internal_functions.html
+share/phplot/doc/function_reference.html
+share/phplot/doc/index.html
+share/phplot/doc/examples.html
+share/phplot/doc/quick_start.php
+share/phplot/doc/user_functions.html
+share/phplot/doc/user_internal_functions.html
+@dirrm share/phplot/examples
+@dirrm share/phplot/doc
+@dirrm share/phplot