aboutsummaryrefslogtreecommitdiff
path: root/graphics/piddle/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-04-06 09:06:21 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-04-06 09:06:21 +0000
commit3a0e552ef8dfddc82b030ba5c6f68e2144980970 (patch)
treee8a218623223c9efe65118c848cda1ec174cfde2 /graphics/piddle/Makefile
parentd44c1a7d3dfc14a490d28be0c19734e7c28f68e5 (diff)
Notes
Diffstat (limited to 'graphics/piddle/Makefile')
-rw-r--r--graphics/piddle/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/graphics/piddle/Makefile b/graphics/piddle/Makefile
new file mode 100644
index 000000000000..886960d86d7b
--- /dev/null
+++ b/graphics/piddle/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: piddle
+# Version required: 1.0b1
+# Date created: 29 Feb 2000
+# Whom: dom@myrddin.demon.co.uk
+#
+# $FreeBSD$
+#
+
+DISTNAME= piddle-1.0b1-5
+PKGNAME= piddle-1.0b1
+CATEGORIES= graphics python
+MASTER_SITES= http://download.sourceforge.net/piddle/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dom@myrddin.demon.co.uk
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+NO_BUILD= yes
+
+PYTHON?= ${LOCALBASE}/bin/python
+PYTHONLIBDIR?= ${LOCALBASE}/lib/python1.5
+PIDDLEDIR= ${PYTHONLIBDIR}/site-packages/piddle
+PIDDLEDOCDIR= ${PREFIX}/share/doc/piddle
+PIDDLEEGDIR= ${PREFIX}/share/examples/piddle
+
+post-extract:
+ @${ECHO} "===> Removing DOS line endings."
+.for file in pdfdoc.py pdfgen.py pdfgeom.py pdfmetrics.py pdfutils.py piddlePDF.py
+ @${TR} -d '\r' < ${WRKSRC}/${file} > ${WRKSRC}/${file}.new
+ @${MV} ${WRKSRC}/${file}.new ${WRKSRC}/${file}
+.endfor
+
+do-install:
+ ${MKDIR} ${PIDDLEDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.py ${PIDDLEDIR}
+ ${ECHO} 'piddle' > ${PIDDLEDIR}.pth
+ @${PYTHON} ${PYTHONLIBDIR}/compileall.py ${PIDDLEDIR}
+ @${PYTHON} -O ${PYTHONLIBDIR}/compileall.py ${PIDDLEDIR}
+ ${MKDIR} ${PIDDLEDOCDIR}
+ (cd ${WRKSRC}/docs ; tar cf - *) | \
+ (cd ${PIDDLEDOCDIR} ; tar xf -)
+ ${MKDIR} ${PIDDLEEGDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${PIDDLEEGDIR}
+
+.include <bsd.port.mk>