aboutsummaryrefslogtreecommitdiff
path: root/graphics/piglit
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-09-11 09:05:07 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-09-11 09:05:07 +0000
commit6413df5ff862faf135b11cbcfc0ce1292f45eafd (patch)
tree919bce820b33ce6b6ca049529fbcea701b9ac648 /graphics/piglit
parent20d18a411da274b48ff888eed4c9b259dd4ce5c8 (diff)
downloadports-6413df5ff862faf135b11cbcfc0ce1292f45eafd.tar.gz
ports-6413df5ff862faf135b11cbcfc0ce1292f45eafd.zip
Notes
Diffstat (limited to 'graphics/piglit')
-rw-r--r--graphics/piglit/Makefile5
-rw-r--r--graphics/piglit/distinfo6
-rw-r--r--graphics/piglit/files/patch-CMakeLists.txt11
-rw-r--r--graphics/piglit/files/pkg-message.in2
-rw-r--r--graphics/piglit/pkg-plist32
5 files changed, 34 insertions, 22 deletions
diff --git a/graphics/piglit/Makefile b/graphics/piglit/Makefile
index 2a1c8cbd86dc..e9d7f6cf2458 100644
--- a/graphics/piglit/Makefile
+++ b/graphics/piglit/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= piglit
-PORTVERSION= 20170922
-PORTREVISION= 3
+PORTVERSION= 20180910
CATEGORIES= graphics
MAINTAINER= x11@FreeBSD.org
@@ -28,7 +27,7 @@ RUN_DEPENDS= ${PYNUMPY} \
USE_GITHUB= yes
GH_ACCOUNT= dumbbell
GH_PROJECT= piglit
-GH_TAGNAME= 60996b829c85f3df192bc6228108c0a8eaa38afd
+GH_TAGNAME= a0db4427446ab50882a721ae3084fa26cc9e751a
USES= cmake:outsource compiler:c11 pkgconfig python:2.7 shebangfix
USE_GL= egl gbm gl glu
diff --git a/graphics/piglit/distinfo b/graphics/piglit/distinfo
index d182fa9ab59c..5b6e4e55c7bc 100644
--- a/graphics/piglit/distinfo
+++ b/graphics/piglit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506092254
-SHA256 (dumbbell-piglit-20170922-60996b829c85f3df192bc6228108c0a8eaa38afd_GH0.tar.gz) = e2d862b5aebb2847283ad12657cf39afcb9e0fbe3edcd348988639348e991b13
-SIZE (dumbbell-piglit-20170922-60996b829c85f3df192bc6228108c0a8eaa38afd_GH0.tar.gz) = 24048349
+TIMESTAMP = 1536577804
+SHA256 (dumbbell-piglit-20180910-a0db4427446ab50882a721ae3084fa26cc9e751a_GH0.tar.gz) = 68dd9a924438dd0a7b12d2f003340c7726523c333b6da86ee6ee33f99d4840da
+SIZE (dumbbell-piglit-20180910-a0db4427446ab50882a721ae3084fa26cc9e751a_GH0.tar.gz) = 24171368
diff --git a/graphics/piglit/files/patch-CMakeLists.txt b/graphics/piglit/files/patch-CMakeLists.txt
index 5f5e68c16b5a..e4839f9a88cf 100644
--- a/graphics/piglit/files/patch-CMakeLists.txt
+++ b/graphics/piglit/files/patch-CMakeLists.txt
@@ -5,16 +5,7 @@
ENDIF()
-set(Python_ADDITIONAL_VERSIONS
-- 3.6 3.5 3.4 3.3 2.7)
+- 3.7 3.6 3.5 3.4 2.7)
find_package(PythonInterp REQUIRED)
find_package(PythonSix 1.5.2 REQUIRED)
find_package(PythonNumpy 1.7.0 REQUIRED)
-@@ -382,7 +380,7 @@ endif()
-
- check_c_source_compiles(
- "
-- #define _POSIX_C_SOURCE 199309L
-+ #define _POSIX_C_SOURCE 200112L
- #include <time.h>
- int main() { return clock_gettime(CLOCK_MONOTONIC, NULL); }
- "
diff --git a/graphics/piglit/files/pkg-message.in b/graphics/piglit/files/pkg-message.in
index 650e55cf61b0..adddf3931bb3 100644
--- a/graphics/piglit/files/pkg-message.in
+++ b/graphics/piglit/files/pkg-message.in
@@ -4,7 +4,7 @@ default maxvnodes:
sysctl kern.maxvnodes=$(($(sysctl -n kern.maxvnodes) * 2))
Instructions to use Piglit are available in:
- %%DOCSDIR%%/README
+ %%DOCSDIR%%/README.md
The same documentation is also available online:
http://cgit.freedesktop.org/piglit/tree/README
diff --git a/graphics/piglit/pkg-plist b/graphics/piglit/pkg-plist
index 2e27224be51b..642b5de5ce81 100644
--- a/graphics/piglit/pkg-plist
+++ b/graphics/piglit/pkg-plist
@@ -1,6 +1,6 @@
bin/piglit
%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/RELEASE
@dir %%DATADIR%%/generated_tests/modules
@dir %%DATADIR%%/generated_tests/templates/gen_builtin_packing_tests
@@ -23,28 +23,32 @@ bin/piglit
@dir %%DATADIR%%/generated_tests/templates/gen_vp_tex
@dir %%DATADIR%%/generated_tests/templates/gen_vs_in_fp64
@dir %%DATADIR%%/generated_tests/templates/interpolation-qualifier-built-in-variable
-@dir %%DATADIR%%/tests/bugs
@dir %%DATADIR%%/tests/cl/api
@dir %%DATADIR%%/tests/cl/custom
@dir %%DATADIR%%/tests/cl/interop
-@dir %%DATADIR%%/tests/egl/spec/egl-1.4
@dir %%DATADIR%%/tests/egl/spec/egl_chromium_sync_control
@dir %%DATADIR%%/tests/egl/spec/egl_ext_client_extensions
+@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_drm
@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_enumeration
@dir %%DATADIR%%/tests/egl/spec/egl_ext_device_query
+@dir %%DATADIR%%/tests/egl/spec/egl_ext_image_dma_buf_import_modifiers
+@dir %%DATADIR%%/tests/egl/spec/egl_ext_platform_device
@dir %%DATADIR%%/tests/egl/spec/egl_khr_create_context
@dir %%DATADIR%%/tests/egl/spec/egl_khr_fence_sync
@dir %%DATADIR%%/tests/egl/spec/egl_khr_get_all_proc_addresses
@dir %%DATADIR%%/tests/egl/spec/egl_khr_gl_image
@dir %%DATADIR%%/tests/egl/spec/egl_khr_surfaceless_context
+@dir %%DATADIR%%/tests/egl/spec/egl_mesa_device_software
@dir %%DATADIR%%/tests/egl/spec/egl_mesa_platform_surfaceless
+@dir %%DATADIR%%/tests/egl/spec/egl-1.4
@dir %%DATADIR%%/tests/fbo
@dir %%DATADIR%%/tests/general
-@dir %%DATADIR%%/tests/glean
@dir %%DATADIR%%/tests/glx
@dir %%DATADIR%%/tests/hiz
@dir %%DATADIR%%/tests/perf
@dir %%DATADIR%%/tests/security
+@dir %%DATADIR%%/tests/spec/amd_depth_clamp_separate
+@dir %%DATADIR%%/tests/spec/amd_framebuffer_multisample_advanced
@dir %%DATADIR%%/tests/spec/amd_performance_monitor
@dir %%DATADIR%%/tests/spec/amd_pinned_memory
@dir %%DATADIR%%/tests/spec/amd_seamless_cubemap_per_texture
@@ -89,11 +93,13 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_occlusion_query2
@dir %%DATADIR%%/tests/spec/arb_pipeline_statistics_query
@dir %%DATADIR%%/tests/spec/arb_point_parameters
+@dir %%DATADIR%%/tests/spec/arb_point_sprite
@dir %%DATADIR%%/tests/spec/arb_post_depth_coverage
@dir %%DATADIR%%/tests/spec/arb_program_interface_query
@dir %%DATADIR%%/tests/spec/arb_provoking_vertex
@dir %%DATADIR%%/tests/spec/arb_query_buffer_object
@dir %%DATADIR%%/tests/spec/arb_robustness
+@dir %%DATADIR%%/tests/spec/arb_sample_locations
@dir %%DATADIR%%/tests/spec/arb_sample_shading/execution
@dir %%DATADIR%%/tests/spec/arb_sampler_objects
@dir %%DATADIR%%/tests/spec/arb_seamless_cube_map
@@ -107,6 +113,7 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_texture_buffer_object
@dir %%DATADIR%%/tests/spec/arb_texture_buffer_range
@dir %%DATADIR%%/tests/spec/arb_texture_compression
+@dir %%DATADIR%%/tests/spec/arb_texture_cube_map
@dir %%DATADIR%%/tests/spec/arb_texture_float
@dir %%DATADIR%%/tests/spec/arb_texture_multisample
@dir %%DATADIR%%/tests/spec/arb_texture_stencil8
@@ -114,9 +121,9 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_texture_storage_multisample
@dir %%DATADIR%%/tests/spec/arb_texture_view
@dir %%DATADIR%%/tests/spec/arb_timer_query
+@dir %%DATADIR%%/tests/spec/arb_transform_feedback_overflow_query
@dir %%DATADIR%%/tests/spec/arb_transform_feedback2
@dir %%DATADIR%%/tests/spec/arb_transform_feedback3
-@dir %%DATADIR%%/tests/spec/arb_transform_feedback_overflow_query
@dir %%DATADIR%%/tests/spec/arb_vertex_array_bgra
@dir %%DATADIR%%/tests/spec/arb_vertex_array_object
@dir %%DATADIR%%/tests/spec/arb_vertex_buffer_object
@@ -125,19 +132,29 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/arb_viewport_array
@dir %%DATADIR%%/tests/spec/ati_draw_buffers
@dir %%DATADIR%%/tests/spec/ati_envmap_bumpmap
+@dir %%DATADIR%%/tests/spec/ati_fragment_shader
@dir %%DATADIR%%/tests/spec/ext_depth_bounds_test
+@dir %%DATADIR%%/tests/spec/ext_disjoint_timer_query
@dir %%DATADIR%%/tests/spec/ext_fog_coord
@dir %%DATADIR%%/tests/spec/ext_frag_depth
@dir %%DATADIR%%/tests/spec/ext_framebuffer_blit
@dir %%DATADIR%%/tests/spec/ext_framebuffer_multisample
@dir %%DATADIR%%/tests/spec/ext_framebuffer_multisample_blit_scaled
+@dir %%DATADIR%%/tests/spec/ext_framebuffer_object
@dir %%DATADIR%%/tests/spec/ext_image_dma_buf_import
@dir %%DATADIR%%/tests/spec/ext_memory_object
+@dir %%DATADIR%%/tests/spec/ext_memory_object_fd
+@dir %%DATADIR%%/tests/spec/ext_occlusion_query_boolean
@dir %%DATADIR%%/tests/spec/ext_packed_depth_stencil
@dir %%DATADIR%%/tests/spec/ext_packed_float
@dir %%DATADIR%%/tests/spec/ext_polygon_offset_clamp
+@dir %%DATADIR%%/tests/spec/ext_render_snorm
+@dir %%DATADIR%%/tests/spec/ext_semaphore
+@dir %%DATADIR%%/tests/spec/ext_semaphore_fd
+@dir %%DATADIR%%/tests/spec/ext_texture_env_combine
@dir %%DATADIR%%/tests/spec/ext_texture_format_bgra8888
@dir %%DATADIR%%/tests/spec/ext_texture_integer
+@dir %%DATADIR%%/tests/spec/ext_texture_norm16
@dir %%DATADIR%%/tests/spec/ext_texture_swizzle
@dir %%DATADIR%%/tests/spec/ext_timer_query
@dir %%DATADIR%%/tests/spec/ext_transform_feedback
@@ -154,6 +171,7 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/gl-3.0/api
@dir %%DATADIR%%/tests/spec/gl-3.2/layered-rendering
@dir %%DATADIR%%/tests/spec/gl-3.3
+@dir %%DATADIR%%/tests/spec/gl-4.3
@dir %%DATADIR%%/tests/spec/gl-4.4
@dir %%DATADIR%%/tests/spec/gl-4.5
@dir %%DATADIR%%/tests/spec/gles-2.0
@@ -165,17 +183,21 @@ bin/piglit
@dir %%DATADIR%%/tests/spec/glx_ext_import_context
@dir %%DATADIR%%/tests/spec/glx_mesa_query_renderer
@dir %%DATADIR%%/tests/spec/glx_oml_sync_control
+@dir %%DATADIR%%/tests/spec/intel_blackhole_render
@dir %%DATADIR%%/tests/spec/intel_conservative_rasterization
@dir %%DATADIR%%/tests/spec/khr_debug
@dir %%DATADIR%%/tests/spec/mesa_pack_invert
@dir %%DATADIR%%/tests/spec/nv_conditional_render
+@dir %%DATADIR%%/tests/spec/nv_fog_distance
@dir %%DATADIR%%/tests/spec/nv_image_formats
@dir %%DATADIR%%/tests/spec/nv_texture_barrier
+@dir %%DATADIR%%/tests/spec/nv_texture_env_combine4
@dir %%DATADIR%%/tests/spec/oes_compressed_paletted_texture
@dir %%DATADIR%%/tests/spec/oes_draw_elements_base_vertex
@dir %%DATADIR%%/tests/spec/oes_draw_texture
@dir %%DATADIR%%/tests/spec/oes_fixed_point
@dir %%DATADIR%%/tests/spec/oes_matrix_get
+@dir %%DATADIR%%/tests/spec/oes_required_internalformat
@dir %%DATADIR%%/tests/spec/oes_texture_float
@dir %%DATADIR%%/tests/texturing/shaders
@dir %%DATADIR%%/tests/wgl