aboutsummaryrefslogtreecommitdiff
path: root/graphics/pinpoint
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-27 15:32:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-27 15:32:43 +0000
commit8cfb12fa57e3e8a8401a40211c47e35542b4b954 (patch)
tree5a5d5c8048b2dc0b933a976c26f2749b3a51e96a /graphics/pinpoint
parentf83333be849b20b5ca96384c6c705c47661f79f8 (diff)
downloadports-8cfb12fa57e3e8a8401a40211c47e35542b4b954.tar.gz
ports-8cfb12fa57e3e8a8401a40211c47e35542b4b954.zip
Notes
Diffstat (limited to 'graphics/pinpoint')
-rw-r--r--graphics/pinpoint/Makefile36
-rw-r--r--graphics/pinpoint/distinfo2
-rw-r--r--graphics/pinpoint/files/patch-pinpoint.c24
-rw-r--r--graphics/pinpoint/pkg-descr5
-rw-r--r--graphics/pinpoint/pkg-plist17
5 files changed, 84 insertions, 0 deletions
diff --git a/graphics/pinpoint/Makefile b/graphics/pinpoint/Makefile
new file mode 100644
index 000000000000..af404a0b6545
--- /dev/null
+++ b/graphics/pinpoint/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pinpoint
+# Date created: 26 June 2011
+# Whom: lichray@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pinpoint
+DISTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= GNOME
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A tool for making hackers do excellent presentations
+
+LIB_DEPENDS= clutter-glx-1.0:${PORTSDIR}/graphics/clutter
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack librsvg2
+GNU_CONFIGURE= yes
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS= GST "Enable live videos as slide backgrounds" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GST)
+LIB_DEPENDS+= clutter-gst-1.0:${PORTSDIR}/multimedia/clutter-gst
+.else
+CONFIGURE_ARGS+= --enable-cluttergst=no
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/pinpoint/distinfo b/graphics/pinpoint/distinfo
new file mode 100644
index 000000000000..8ead85a27498
--- /dev/null
+++ b/graphics/pinpoint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pinpoint-0.1.2.tar.bz2) = 365a566de86b69e483c92f608ec099a0ebcfac3a0e88072a49997db0b887bbed
+SIZE (pinpoint-0.1.2.tar.bz2) = 788823
diff --git a/graphics/pinpoint/files/patch-pinpoint.c b/graphics/pinpoint/files/patch-pinpoint.c
new file mode 100644
index 000000000000..284cda444560
--- /dev/null
+++ b/graphics/pinpoint/files/patch-pinpoint.c
@@ -0,0 +1,24 @@
+--- pinpoint.c.orig 2011-05-23 07:49:55.000000000 -0500
++++ pinpoint.c 2011-06-26 04:23:53.780817124 -0500
+@@ -31,6 +31,21 @@
+
+ #include "pinpoint.h"
+
++#ifndef __GLIBC__
++/* ref: http://lists.freebsd.org/pipermail/freebsd-ports/2009-June/055131.html */
++
++char *strchrnul(const char *s, int c) {
++ char *i;
++ for (i = (char*)s; *i != '\0'; ++i) {
++ if (*i == c) {
++ return i;
++ }
++ }
++ return i;
++}
++
++#endif
++
+ GList *pp_slides = NULL; /* list of slide text */
+ GList *pp_slidep = NULL; /* current slide */
+
diff --git a/graphics/pinpoint/pkg-descr b/graphics/pinpoint/pkg-descr
new file mode 100644
index 000000000000..f257e57da782
--- /dev/null
+++ b/graphics/pinpoint/pkg-descr
@@ -0,0 +1,5 @@
+Pinpoint a simple presentation tool that hopes to avoid audience death
+by bullet point and instead encourage presentations containing beautiful
+images and small amounts of concise text in slides.
+
+WWW: http://live.gnome.org/Pinpoint
diff --git a/graphics/pinpoint/pkg-plist b/graphics/pinpoint/pkg-plist
new file mode 100644
index 000000000000..f84534100744
--- /dev/null
+++ b/graphics/pinpoint/pkg-plist
@@ -0,0 +1,17 @@
+bin/pinpoint
+%%DATADIR%%/action.json
+%%DATADIR%%/fade.json
+%%DATADIR%%/page-curl-both.json
+%%DATADIR%%/page-curl.json
+%%DATADIR%%/sheet.json
+%%DATADIR%%/slide-in-left.json
+%%DATADIR%%/slide-left.json
+%%DATADIR%%/slide-up.json
+%%DATADIR%%/spin-bg.json
+%%DATADIR%%/spin-text.json
+%%DATADIR%%/spin.json
+%%DATADIR%%/swing.json
+%%DATADIR%%/text-slide-down.json
+%%DATADIR%%/text-slide-left.json
+%%DATADIR%%/text-slide-up.json
+@dirrm %%DATADIR%%