aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
committerAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
commit8503536d3896846d823f7f76be54e0a99da8d8b6 (patch)
tree1a89e4038216ead71b008f2a5091474964e1c341 /graphics/pixie/Makefile
parentc20d04e3929dbe1763fc1dfaaa677c2353cd7883 (diff)
downloadports-8503536d3896846d823f7f76be54e0a99da8d8b6.tar.gz
ports-8503536d3896846d823f7f76be54e0a99da8d8b6.zip
Notes
Diffstat (limited to 'graphics/pixie/Makefile')
-rw-r--r--graphics/pixie/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index fdc4971e68d9..22005cba9d21 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_REINPLACE= yes
USE_GL= yes
USE_X_PREFIX= yes
-USE_AUTOTOOLS= automake:15:env autoconf:213 libtool:13
+USE_AUTOTOOLS= automake:15:env autoconf:253 libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
CXXFLAGS="${CXXFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -52,10 +52,12 @@ post-patch:
@${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'
+
pre-configure:
@(cd ${WRKSRC} && ${ACLOCAL} && \
${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} --add-missing && \
${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} -i)
+ @${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' ${WRKSRC}/aclocal.m4
do-install:
# exes