aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-09-21 19:14:51 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-09-21 19:14:51 +0000
commit8539155732cd511d8940ef6463fa1e876e55ac42 (patch)
tree7ea656e8abcec2791aa0521cc9de2cc22c257a09 /graphics/pixie/Makefile
parentcfeba5a927284c9b105640338ccfe4f4acfae5ae (diff)
downloadports-8539155732cd511d8940ef6463fa1e876e55ac42.tar.gz
ports-8539155732cd511d8940ef6463fa1e876e55ac42.zip
Notes
Diffstat (limited to 'graphics/pixie/Makefile')
-rw-r--r--graphics/pixie/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index f2baf58ccc9c..32f0f3d8d9f4 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pixie
-PORTVERSION= 1.4.5
+PORTVERSION= 1.4.6
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -47,8 +47,8 @@ NOT_FOR_ARCHS= alpha
.endif
post-patch:
- @${REINPLACE_CMD} -i "" -e 's|malloc\.h|stdlib\.h|g' \
- `${FIND} -E ${WRKSRC} -iregex '.*\.(cpp|h)'`
+ @${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
+ ${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'
pre-configure:
@(cd ${WRKSRC} && ${ACLOCAL} && \
@@ -78,12 +78,8 @@ do-install:
.endfor
.for i in ${PIXIE_SHLIBS}
- ${INSTALL_DATA} ${WRKSRC}/src/${i}/.libs/${i}.a \
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/${i}.so \
${PREFIX}/lib/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/${i}.so.0 \
- ${PREFIX}/lib/${PORTNAME}
- ${LN} -sf ${PREFIX}/lib/${PORTNAME}/${i}.so.0 \
- ${PREFIX}/lib/${PORTNAME}/${i}.so
.endfor
# includes