aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-17 08:21:26 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-17 08:21:26 +0000
commitc78285f1f68d016cb1368c8888b71f21b3eee825 (patch)
treeb05471b8da83e966c74102c817a93ee7b9162821 /graphics/pixie
parentfa662b330c0309a50c7a41a0597c448b1099981b (diff)
downloadports-c78285f1f68d016cb1368c8888b71f21b3eee825.tar.gz
ports-c78285f1f68d016cb1368c8888b71f21b3eee825.zip
- Update to 2.2.2
- Fix build with gcc4.2 - Take maintainership
Notes
Notes: svn path=/head/; revision=207446
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile68
-rw-r--r--graphics/pixie/distinfo6
-rw-r--r--graphics/pixie/files/patch-configure.in50
-rw-r--r--graphics/pixie/files/patch-src_common_containers.h11
-rw-r--r--graphics/pixie/files/patch-src_file_file.cpp36
-rw-r--r--graphics/pixie/files/patch-src_ri_renderer.h35
-rw-r--r--graphics/pixie/files/patch-src_ri_texmake.cpp47
-rw-r--r--graphics/pixie/pkg-plist67
8 files changed, 44 insertions, 276 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index 490e14a55563..1e94a8d815fd 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -6,31 +6,41 @@
#
PORTNAME= pixie
-PORTVERSION= 1.6.3
-PORTREVISION= 2
+PORTVERSION= 2.2.2
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= Pixie-src-${PORTVERSION}
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= beech@FreeBSD.org
COMMENT= A photorealistic renderer with Pixar's RenderMan-like interface
+BUILD_DEPENDS= flex:${PORTSDIR}/textproc/flex \
+ bison:${PORTSDIR}/devel/bison
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- fltk_gl.1:${PORTSDIR}/x11-toolkits/fltk
+ fltk_gl.1:${PORTSDIR}/x11-toolkits/fltk \
+ IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+PORTDOCS=*
USE_GL= yes
-USE_X_PREFIX= yes
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
USE_AUTOTOOLS= autoconf:261 aclocal:19 automake:19 libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
- CXXFLAGS="${CXXFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+CONFIGURE_ENV= CFLAGS="-O0 -fPIC -pipe -I${LOCALBASE}/include" \
+ CXXFLAGS="-O0 -pipe -fPIC -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/OpenEXR" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="${PTHREAD_LIBS}"
-CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/${PORTNAME} --with-shaderdir=${PREFIX}/share/${PORTNAME}/shaders --with-modeldir=${PREFIX}/share/${PORTNAME} --with-texturedir=${PREFIX}/share/${PORTNAME} --with-proceduraldir=${PREFIX}/share/${PORTNAME} --with-displaysdir=${PREFIX}/lib/${PORTNAME}
-USE_LDCONFIG= %%PREFIX%%/lib/${PORTNAME}
+CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/${PORTNAME} \
+ --with-shaderdir=${PREFIX}/share/${PORTNAME}/shaders \
+ --with-modeldir=${PREFIX}/share/${PORTNAME} \
+ --with-texturedir=${PREFIX}/share/${PORTNAME} \
+ --with-proceduraldir=${PREFIX}/share/${PORTNAME} \
+ --with-displaysdir=${PREFIX}/lib/${PORTNAME} \
+ --with-openexr=${LOCALBASE}/lib \
+ --enable-openexr-threads --disable-openexrtest
+
+USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
WRKSRC= ${WRKDIR}/Pixie
PIXIE_EXES= precomp rndr sdrc sdrinfo show texmake
@@ -40,10 +50,6 @@ SUB_LIST+= PORTNAME=${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-patch:
@${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'
@@ -63,8 +69,16 @@ do-install:
# libs
# avoid conflicts by installing in separate dir
- @${MKDIR} ${PREFIX}/lib/${PORTNAME}
-.for i in sdr ri common
+ @${INSTALL} -d ${PREFIX}/lib/${PORTNAME}
+.for i in common
+ ${INSTALL_DATA} ${WRKSRC}/src/${i}/.libs/libpixie${i}.a \
+ ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/libpixie${i}.so.0 \
+ ${PREFIX}/lib/${PORTNAME}
+ ${LN} -sf ${PREFIX}/lib/${PORTNAME}/libpixie${i}.so.0 \
+ ${PREFIX}/lib/${PORTNAME}/libpixie${i}.so
+.endfor
+.for i in sdr ri
${INSTALL_DATA} ${WRKSRC}/src/${i}/.libs/lib${i}.a \
${PREFIX}/lib/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/lib${i}.so.0 \
@@ -79,26 +93,20 @@ do-install:
.endfor
# includes
- @${MKDIR} ${PREFIX}/include/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/src/sdr/sdr.h ${PREFIX}/include/${PORTNAME}
+ @${INSTALL} -d ${PREFIX}/include/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/src/sdr/sdr.h ${PREFIX}/include/${PORTNAME}
.for i in dlo dsply implicit ri shadeop
${INSTALL_DATA} ${WRKSRC}/src/ri/${i}.h ${PREFIX}/include/${PORTNAME}
.endfor
# shaders
- @${MKDIR} ${DATADIR}
- @${MKDIR} ${DATADIR}/shaders
- ${INSTALL_DATA} ${WRKSRC}/shaders/* ${DATADIR}/shaders
+ @${INSTALL} -d ${DATADIR}
+ @${INSTALL} -d ${DATADIR}/shaders
+ @${INSTALL_DATA} ${WRKSRC}/shaders/* ${DATADIR}/shaders
# docs
.ifndef (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.htm ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.jpg ${DOCSDIR}
-.for i in figures rayshadow running softshadow
- @${MKDIR} ${DOCSDIR}/${i}
- ${INSTALL_DATA} ${WRKSRC}/doc/${i}/* ${DOCSDIR}/${i}
-.endfor
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/pixie/distinfo b/graphics/pixie/distinfo
index cc219307a667..aa1c21233a11 100644
--- a/graphics/pixie/distinfo
+++ b/graphics/pixie/distinfo
@@ -1,3 +1,3 @@
-MD5 (Pixie-src-1.6.3.tgz) = fa36424619d5dda8515f009e01df2207
-SHA256 (Pixie-src-1.6.3.tgz) = 19cd9aee4b360cde8bb12862b6e312498fd3a257d58d6d133150324a433180b6
-SIZE (Pixie-src-1.6.3.tgz) = 6125284
+MD5 (Pixie-src-2.2.2.tgz) = c4360ceca89319bcf60a15be96cbd245
+SHA256 (Pixie-src-2.2.2.tgz) = 8dce667e751bb1baa13803ad2d467fee90b53553a9089b51ceb1c58fd86742fc
+SIZE (Pixie-src-2.2.2.tgz) = 9501446
diff --git a/graphics/pixie/files/patch-configure.in b/graphics/pixie/files/patch-configure.in
deleted file mode 100644
index 3b54c04a888f..000000000000
--- a/graphics/pixie/files/patch-configure.in
+++ /dev/null
@@ -1,50 +0,0 @@
---- configure.in.orig
-+++ configure.in
-@@ -23,9 +23,9 @@
- dnl ---------------------------------------------------
- dnl Check standard libraries
- dnl
--AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
-+dnl AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
- AC_CHECK_LIB(m, sin,,[AC_MSG_ERROR([math library is not found])],)
--AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
-+dnl AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
-
- dnl ---------------------------------------------------
- dnl Find X
-@@ -52,18 +52,24 @@
- dnl Find FLTK
- dnl
-
-+saved_LIBS="${LIBS}"
-+
-+LIBS="$LIBS -lGL"
-+
- have_fltk=false
- AC_CHECK_LIB(fltk,main,LIBFLTK="-lfltk")
--AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL" have_fltk=true])
-+AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL -lstdc++" have_fltk=true])
- AM_CONDITIONAL(BUILD_SHOW, test x$have_fltk = xtrue)
-
-+LIBS="${saved_LIBS}"
-+
- dnl ---------------------------------------------------
- dnl Find libtiff
- dnl
-
- saved_LIBS="$LIBS"
-
--AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
-+dnl AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
- AC_CHECK_LIB(tiff,TIFFOpen,,[AC_MSG_ERROR([libtiff not found])],)
-
- TIFF_LIBS="$LIBS"
-@@ -141,7 +147,7 @@
- dnl
-
- AC_ARG_ENABLE(selfcontained,
--AS_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup (overrides custom directory settings)]),
-+AC_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup (overrides custom directory settings)]),
- [case "${enableval}" in
- yes) docdir="${prefix}/doc"
- shaderdir="${prefix}/shaders"
diff --git a/graphics/pixie/files/patch-src_common_containers.h b/graphics/pixie/files/patch-src_common_containers.h
deleted file mode 100644
index 7749590213ea..000000000000
--- a/graphics/pixie/files/patch-src_common_containers.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common/containers.h.orig
-+++ src/common/containers.h
-@@ -591,7 +591,7 @@
- memoryBase = new unsigned char[pageSize+16];
- memory = memoryBase+16;
- available = pageSize;
-- savedPages = NULL;
-+ savedPages = (T64*)NULL;
- }
-
- ~CMemStack() {
diff --git a/graphics/pixie/files/patch-src_file_file.cpp b/graphics/pixie/files/patch-src_file_file.cpp
deleted file mode 100644
index f5f2f3a01fcc..000000000000
--- a/graphics/pixie/files/patch-src_file_file.cpp
+++ /dev/null
@@ -1,36 +0,0 @@
---- src/file/file.cpp.orig
-+++ src/file/file.cpp
-@@ -56,13 +56,13 @@
- // Date last edited : 5/9/2002
- CFramebuffer(const char *name,int width,int height,int numSamples,const char *samples,TDisplayParameterFunction findParameter) {
- int i;
-- char *comment = NULL;
-+ char *comment = (char*)NULL;
- float *tmp;
- float worldToNDC[16];
- float worldToCamera[16];
- char *software;
- char desc[1024];
-- const char *compression = NULL;
-+ const char *compression = (char*)NULL;
-
- // Open the image file
- image = TIFFOpen(name,"w");
-@@ -189,7 +189,7 @@
- scanlineUsage = new int[height];
-
- for (i=0;i<height;i++) {
-- scanlines[i] = NULL;
-+ scanlines[i] = (unsigned char*)NULL;
- scanlineUsage[i] = width;
- }
-
-@@ -315,7 +315,7 @@
- if (scanlines[lastSavedLine] != NULL) {
- TIFFWriteScanline(image,scanlines[lastSavedLine],lastSavedLine,0);
- delete [] scanlines[lastSavedLine];
-- scanlines[lastSavedLine] = NULL;
-+ scanlines[lastSavedLine] = (unsigned char*)NULL;
- }
- } else {
- break;
diff --git a/graphics/pixie/files/patch-src_ri_renderer.h b/graphics/pixie/files/patch-src_ri_renderer.h
deleted file mode 100644
index c0b6aa9a5e5f..000000000000
--- a/graphics/pixie/files/patch-src_ri_renderer.h
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/ri/renderer.h.orig
-+++ src/ri/renderer.h
-@@ -107,7 +107,7 @@
- class CRendererContext : public CRiInterface {
- public:
-
-- CRendererContext(char *ribName=NULL,char *netString=NULL);
-+ CRendererContext(char *ribName=(char*)NULL,char *netString=(char*)NULL);
- ~CRendererContext();
-
- ///////////////////////////////////////////////////////////////////////
-@@ -253,7 +253,7 @@
- CEnvironment *environmentLoad(const char *,TSearchpath *,float *); // Load a new environment map
-
- // Delayed object junk
-- void processDelayedObject(CDelayedObject *,void (*subdivisionFunction)(char *,float),char *,const float *,const float *,CRay *ray = NULL);
-+ void processDelayedObject(CDelayedObject *,void (*subdivisionFunction)(char *,float),char *,const float *,const float *,CRay *ray = (CRay*)NULL);
-
- void addObject(CObject *); // Add an object into the scene
- void addInstance(void *); // Add an instance into the scene
-@@ -267,11 +267,11 @@
- CVariable *retrieveVariable(const char *);
-
- // Locate (download) a file
-- int locateFileEx(char *,const char *,const char *extension=NULL,TSearchpath *search=NULL);
-- int locateFile(char *,const char *,TSearchpath *search=NULL);
-+ int locateFileEx(char *,const char *,const char *extension=(char*)NULL,TSearchpath *search=(TSearchpath *)NULL);
-+ int locateFile(char *,const char *,TSearchpath *search=(TSearchpath *)NULL);
-
- // Open (download) a file
-- FILE *openFile(const char *,const char *,const char *extension=NULL,TSearchpath *search=NULL);
-+ FILE *openFile(const char *,const char *,const char *extension=(char*)NULL,TSearchpath *search=(TSearchpath *)NULL);
-
- // The following functions are about texture management and are implemented in texture.cpp
- void rendererThread(void *);
diff --git a/graphics/pixie/files/patch-src_ri_texmake.cpp b/graphics/pixie/files/patch-src_ri_texmake.cpp
deleted file mode 100644
index 4f778299e8e0..000000000000
--- a/graphics/pixie/files/patch-src_ri_texmake.cpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/ri/texmake.cpp.orig
-+++ src/ri/texmake.cpp
-@@ -455,7 +455,7 @@
- RtFilterFunc filter = filt;
- float filterWidth = fwidth;
- float filterHeight = fheight;
-- char *outPath = NULL;
-+ char *outPath = (char*)NULL;
- int pyramidSize;
- char inputFileName[OS_MAX_PATH_LENGTH];
- TIFF *outHandle;
-@@ -522,7 +522,7 @@
- RtFilterFunc filter = filt;
- float filterWidth = fwidth;
- float filterHeight = fheight;
-- char *outPath = NULL;
-+ char *outPath = (char*)NULL;
- int pyramidSize;
- char inputFileName[OS_MAX_PATH_LENGTH];
- TIFF *outHandle;
-@@ -618,7 +618,7 @@
- RtFilterFunc filter = filt;
- float filterWidth = fwidth;
- float filterHeight = fheight;
-- char *outPath = NULL;
-+ char *outPath = (char*)NULL;
- int pyramidSize;
- char inputFileName[OS_MAX_PATH_LENGTH];
- TIFF *outHandle;
-@@ -723,7 +723,7 @@
- RtFilterFunc filter = filt;
- float filterWidth = fwidth;
- float filterHeight = fheight;
-- char *outPath = NULL;
-+ char *outPath = (char*)NULL;
- int pyramidSize;
- char inputFileName[OS_MAX_PATH_LENGTH];
- TIFF *outHandle;
-@@ -793,7 +793,7 @@
- RtFilterFunc filter = filt;
- float filterWidth = fwidth;
- float filterHeight = fheight;
-- char *outPath = NULL;
-+ char *outPath = (char*)NULL;
- int pyramidSize;
- char inputFileName[OS_MAX_PATH_LENGTH];
- TIFF *outHandle;
diff --git a/graphics/pixie/pkg-plist b/graphics/pixie/pkg-plist
index c43a321314e3..9666b7d95cef 100644
--- a/graphics/pixie/pkg-plist
+++ b/graphics/pixie/pkg-plist
@@ -12,9 +12,9 @@ include/pixie/sdr.h
include/pixie/shadeop.h
lib/pixie/file.so
lib/pixie/framebuffer.so
-lib/pixie/libcommon.a
-lib/pixie/libcommon.so
-lib/pixie/libcommon.so.0
+lib/pixie/libpixiecommon.a
+lib/pixie/libpixiecommon.so
+lib/pixie/libpixiecommon.so.0
lib/pixie/libri.a
lib/pixie/libri.so
lib/pixie/libri.so.0
@@ -22,62 +22,6 @@ lib/pixie/libsdr.a
lib/pixie/libsdr.so
lib/pixie/libsdr.so.0
lib/pixie/rgbe.so
-%%PORTDOCS%%%%DOCSDIR%%/attributes.htm
-%%PORTDOCS%%%%DOCSDIR%%/autoraytracing.htm
-%%PORTDOCS%%%%DOCSDIR%%/display.htm
-%%PORTDOCS%%%%DOCSDIR%%/dso.htm
-%%PORTDOCS%%%%DOCSDIR%%/figures/Thumbs.db
-%%PORTDOCS%%%%DOCSDIR%%/figures/caustic1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/caustic2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/directPhoton.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/ex1_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/ex1_precompute.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/ex3_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/ex3g_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/ex5_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/ex6.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tcaustic1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tcaustic2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tdirectPhoton.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tex1_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tex1_precompute.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tex3_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tex5_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tex6.jpg
-%%PORTDOCS%%%%DOCSDIR%%/figures/tx3g_beauty.jpg
-%%PORTDOCS%%%%DOCSDIR%%/gi.htm
-%%PORTDOCS%%%%DOCSDIR%%/hardshaders.htm
-%%PORTDOCS%%%%DOCSDIR%%/hiders.htm
-%%PORTDOCS%%%%DOCSDIR%%/index.htm
-%%PORTDOCS%%%%DOCSDIR%%/logo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/network.htm
-%%PORTDOCS%%%%DOCSDIR%%/occlusionculling.htm
-%%PORTDOCS%%%%DOCSDIR%%/options.htm
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/index.html
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/logo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/shadow.rib
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/shadow1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/shadow2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/shadowShade.rib
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/tshadow1.jpg
-%%PORTDOCS%%%%DOCSDIR%%/rayshadow/tshadow2.jpg
-%%PORTDOCS%%%%DOCSDIR%%/raytracing.htm
-%%PORTDOCS%%%%DOCSDIR%%/raytracingsl.htm
-%%PORTDOCS%%%%DOCSDIR%%/running/index.html
-%%PORTDOCS%%%%DOCSDIR%%/running/logo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/sdrlib.htm
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/Thumbs.db
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/index.html
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/logo.jpg
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/shadow.JPG
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/shadow.rib
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/shadow.tif
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/shadow2.JPG
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/tshadow.JPG
-%%PORTDOCS%%%%DOCSDIR%%/softshadow/tshadow2.JPG
-%%PORTDOCS%%%%DOCSDIR%%/tips.htm
-%%PORTDOCS%%%%DOCSDIR%%/tsm.htm
-%%PORTDOCS%%%%DOCSDIR%%/versions.htm
%%DATADIR%%/shaders/ambientindirect.sdr
%%DATADIR%%/shaders/ambientindirect.sl
%%DATADIR%%/shaders/ambientlight.sdr
@@ -134,10 +78,5 @@ lib/pixie/rgbe.so
%%DATADIR%%/shaders/spotlight.sl
@dirrm %%DATADIR%%/shaders
@dirrm %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/softshadow
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/running
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/rayshadow
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/figures
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/pixie
@dirrm include/pixie