aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-06 19:48:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-06 19:48:00 +0000
commit397cec7c50e741e507e69b6f060651610d2ecc99 (patch)
treebc047ee03cfbaba0162e1fbb1d94c59dd2d64a5b /graphics/pixie
parentb75d05b9cf9ee34fda6699062cd3a4288778f065 (diff)
downloadports-397cec7c50e741e507e69b6f060651610d2ecc99.tar.gz
ports-397cec7c50e741e507e69b6f060651610d2ecc99.zip
Notes
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile3
-rw-r--r--graphics/pixie/distinfo4
-rw-r--r--graphics/pixie/files/patch-Makefile.am4
-rw-r--r--graphics/pixie/files/patch-src_common_containers.h4
-rw-r--r--graphics/pixie/files/patch-src_ri_renderer.h4
5 files changed, 9 insertions, 10 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index c1029df1eb62..b07bb90d4009 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pixie
-PORTVERSION= 1.3.16
-PORTREVISION= 1
+PORTVERSION= 1.3.22
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/pixie/distinfo b/graphics/pixie/distinfo
index 03d032651c1f..1636dcb2b313 100644
--- a/graphics/pixie/distinfo
+++ b/graphics/pixie/distinfo
@@ -1,2 +1,2 @@
-MD5 (Pixie-src-1.3.16.tgz) = c82693b10c7a9c2be7bf21be03bc8434
-SIZE (Pixie-src-1.3.16.tgz) = 4949175
+MD5 (Pixie-src-1.3.22.tgz) = 195ef1e327738224b0693bb0994caefd
+SIZE (Pixie-src-1.3.22.tgz) = 4916714
diff --git a/graphics/pixie/files/patch-Makefile.am b/graphics/pixie/files/patch-Makefile.am
index 634dfae7f1a9..a1a216519a35 100644
--- a/graphics/pixie/files/patch-Makefile.am
+++ b/graphics/pixie/files/patch-Makefile.am
@@ -1,5 +1,5 @@
---- Makefile.am.orig Sun Aug 29 21:35:42 2004
-+++ Makefile.am Sun Aug 29 21:37:04 2004
+--- Makefile.am.orig
++++ Makefile.am
@@ -2,7 +2,7 @@
topdir = $(prefix)
diff --git a/graphics/pixie/files/patch-src_common_containers.h b/graphics/pixie/files/patch-src_common_containers.h
index 6740262f98f1..7749590213ea 100644
--- a/graphics/pixie/files/patch-src_common_containers.h
+++ b/graphics/pixie/files/patch-src_common_containers.h
@@ -1,11 +1,11 @@
--- src/common/containers.h.orig
+++ src/common/containers.h
-@@ -589,7 +589,7 @@
+@@ -591,7 +591,7 @@
memoryBase = new unsigned char[pageSize+16];
memory = memoryBase+16;
available = pageSize;
- savedPages = NULL;
-+ savedPages = (T32 *)NULL;
++ savedPages = (T64*)NULL;
}
~CMemStack() {
diff --git a/graphics/pixie/files/patch-src_ri_renderer.h b/graphics/pixie/files/patch-src_ri_renderer.h
index 3bd61fbdf500..c0b6aa9a5e5f 100644
--- a/graphics/pixie/files/patch-src_ri_renderer.h
+++ b/graphics/pixie/files/patch-src_ri_renderer.h
@@ -13,8 +13,8 @@
CEnvironment *environmentLoad(const char *,TSearchpath *,float *); // Load a new environment map
// Delayed object junk
-- void processDelayedObject(CDelayedObject *,void (*subdivisionFunction)(char *,float),char *,float,CRay *ray = NULL);
-+ void processDelayedObject(CDelayedObject *,void (*subdivisionFunction)(char *,float),char *,float,CRay *ray = (CRay *)NULL);
+- void processDelayedObject(CDelayedObject *,void (*subdivisionFunction)(char *,float),char *,const float *,const float *,CRay *ray = NULL);
++ void processDelayedObject(CDelayedObject *,void (*subdivisionFunction)(char *,float),char *,const float *,const float *,CRay *ray = (CRay*)NULL);
void addObject(CObject *); // Add an object into the scene
void addInstance(void *); // Add an instance into the scene