aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
committerAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
commit8503536d3896846d823f7f76be54e0a99da8d8b6 (patch)
tree1a89e4038216ead71b008f2a5091474964e1c341 /graphics/pixie
parentc20d04e3929dbe1763fc1dfaaa677c2353cd7883 (diff)
downloadports-8503536d3896846d823f7f76be54e0a99da8d8b6.tar.gz
ports-8503536d3896846d823f7f76be54e0a99da8d8b6.zip
Notes
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile4
-rw-r--r--graphics/pixie/files/patch-configure.in27
2 files changed, 13 insertions, 18 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index fdc4971e68d9..22005cba9d21 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_REINPLACE= yes
USE_GL= yes
USE_X_PREFIX= yes
-USE_AUTOTOOLS= automake:15:env autoconf:213 libtool:13
+USE_AUTOTOOLS= automake:15:env autoconf:253 libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
CXXFLAGS="${CXXFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -52,10 +52,12 @@ post-patch:
@${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'
+
pre-configure:
@(cd ${WRKSRC} && ${ACLOCAL} && \
${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} --add-missing && \
${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} -i)
+ @${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' ${WRKSRC}/aclocal.m4
do-install:
# exes
diff --git a/graphics/pixie/files/patch-configure.in b/graphics/pixie/files/patch-configure.in
index ed2b9d16c61d..d62e365896ca 100644
--- a/graphics/pixie/files/patch-configure.in
+++ b/graphics/pixie/files/patch-configure.in
@@ -1,8 +1,6 @@
---- configure.in.orig Fri Jul 16 00:52:52 2004
-+++ configure.in Sun Aug 29 22:09:21 2004
-@@ -21,9 +21,9 @@
- dnl ---------------------------------------------------
- dnl Check standard libraries
+--- configure.in.orig Tue Nov 22 06:30:25 2005
++++ configure.in Wed Jan 25 00:38:57 2006
+@@ -23,5 +23,5 @@
dnl
-AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
+dnl AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
@@ -10,11 +8,7 @@
-AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
+dnl AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
- dnl ---------------------------------------------------
- dnl Find X
-@@ -50,9 +50,13 @@
- dnl Find FLTK
- dnl
+@@ -52,5 +52,9 @@
+saved_LIBS="${LIBS}"
+
@@ -25,14 +19,13 @@
-AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL" have_fltk=true])
+AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL -lstdc++" have_fltk=true])
AM_CONDITIONAL(BUILD_SHOW, test x$have_fltk = xtrue)
-
- dnl ---------------------------------------------------
-@@ -61,7 +65,7 @@
-
- saved_LIBS="$LIBS"
+@@ -63,3 +67,3 @@
-AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
+dnl AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
AC_CHECK_LIB(tiff,TIFFOpen,,[AC_MSG_ERROR([libtiff not found])],)
-
- TIFF_LIBS="$LIBS"
+@@ -100,3 +104,3 @@
+ AC_ARG_ENABLE(selfcontained,
+-AS_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup]),
++AC_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup]),
+ [case "${enableval}" in