aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixie
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-01 15:54:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-01 15:54:30 +0000
commitc73a0b41bef83383e6dde4520d0f634376f361e3 (patch)
treee05112d05e35da09c3f972d55a6d18844e47c224 /graphics/pixie
parent68aa89a55c4d61ff4e1c7e37194c583abec681b0 (diff)
downloadports-c73a0b41bef83383e6dde4520d0f634376f361e3.tar.gz
ports-c73a0b41bef83383e6dde4520d0f634376f361e3.zip
Notes
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile104
-rw-r--r--graphics/pixie/distinfo1
-rw-r--r--graphics/pixie/files/patch-configure.in62
-rw-r--r--graphics/pixie/files/patch-src-framebuffer-Makefile.am13
-rw-r--r--graphics/pixie/pkg-descr24
-rw-r--r--graphics/pixie/pkg-message5
-rw-r--r--graphics/pixie/pkg-plist126
7 files changed, 335 insertions, 0 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
new file mode 100644
index 000000000000..3c065ad239b9
--- /dev/null
+++ b/graphics/pixie/Makefile
@@ -0,0 +1,104 @@
+# New ports collection makefile for: pixie
+# Date created: 29 Jan 2004
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pixie
+PORTVERSION= 1.3.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Pixie-src-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tiamat@comset.net
+COMMENT= A photorealistic renderer with Pixar's RenderMan-like interface
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_REINPLACE= yes
+USE_GL= yes
+USE_X_PREFIX= yes
+USE_AUTOCONF= yes
+USE_AUTOHEADER= yes
+USE_AUTOMAKE= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="${PTHREAD_LIBS}"
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib/${PORTNAME}
+
+WRKSRC= ${WRKDIR}/Pixie
+PIXIE_EXES= precomp rndr sdrc sdrinfo texmake
+PIXIE_SHLIBS= file framebuffer rgbe
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch:
+ @${WRKSRC}/makeunix
+ @${REINPLACE_CMD} -e 's|malloc\.h|stdlib\.h|g' \
+ `${FIND} -E ${WRKSRC} -iregex '.*\.(cpp|h)'`
+
+do-install:
+# exes
+.for i in ${PIXIE_EXES}
+ if [ "`${FILE} -b ${WRKSRC}/src/${i}/${i} | ${GREP} script`" ]; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/${i} ${PREFIX}/bin; \
+ else \
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/${i} ${PREFIX}/bin; \
+ fi;
+.endfor
+
+# libs
+ # avoid conflicts by installing in separate dir
+ @${MKDIR} ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/sdr/libsdr.a ${PREFIX}/lib/${PORTNAME}
+
+ ${INSTALL_DATA} ${WRKSRC}/src/ri/.libs/libri.a ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/ri/.libs/libri.la ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ri/.libs/libri.so.0 ${PREFIX}/lib/${PORTNAME}
+ ${LN} -sf ${PREFIX}/lib/${PORTNAME}/libri.so.0 ${PREFIX}/lib/${PORTNAME}/libri.so
+
+.for i in ${PIXIE_SHLIBS}
+ ${INSTALL_DATA} ${WRKSRC}/src/${i}/.libs/${i}.a \
+ ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/${i}/.libs/${i}.la \
+ ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/${i}.so.0 \
+ ${PREFIX}/lib/${PORTNAME}
+ ${LN} -sf ${PREFIX}/lib/${PORTNAME}/${i}.so.0 \
+ ${PREFIX}/lib/${PORTNAME}/${i}.so
+.endfor
+
+# includes
+ @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/sdr/sdr.h ${PREFIX}/include/${PORTNAME}
+.for i in dsply implicit ri shadeop
+ ${INSTALL_DATA} ${WRKSRC}/src/ri/${i}.h ${PREFIX}/include/${PORTNAME}
+.endfor
+
+# shaders
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/shaders
+ ${INSTALL_DATA} ${WRKSRC}/shaders/* ${DATADIR}/shaders
+
+# docs
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.htm ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/figures
+ ${INSTALL_DATA} ${WRKSRC}/doc/figures/*.jpg ${DOCSDIR}/figures
+.endif
+
+post-install:
+ @(${SED} -e 's|%%PREFIX%%|${PREFIX}|; s|%%PORTNAME%%|${PORTNAME}|' \
+ <pkg-message >${PKGMESSAGE} && ${CAT} ${PKGMESSAGE})
+
+.include <bsd.port.mk>
diff --git a/graphics/pixie/distinfo b/graphics/pixie/distinfo
new file mode 100644
index 000000000000..58a587d2a380
--- /dev/null
+++ b/graphics/pixie/distinfo
@@ -0,0 +1 @@
+MD5 (Pixie-src-1.3.1.tgz) = 112b2684fb52b6511a65c78f78f7f019
diff --git a/graphics/pixie/files/patch-configure.in b/graphics/pixie/files/patch-configure.in
new file mode 100644
index 000000000000..cde4f2c25160
--- /dev/null
+++ b/graphics/pixie/files/patch-configure.in
@@ -0,0 +1,62 @@
+--- configure.in.orig Sun Jan 25 04:16:25 2004
++++ configure.in Fri Jan 30 18:33:19 2004
+@@ -22,8 +22,8 @@
+ dnl CPU - OS specific compiler flags
+ dnl
+ case $compiler in
+- gcc)
+- CFLAGS="-O3 -fstrict-aliasing -funroll-loops -ffast-math -fomit-frame-pointer -fno-rtti -fno-exceptions"
++ cc|gcc)
++ CFLAGS+="-O3 -fstrict-aliasing -funroll-loops -ffast-math -fomit-frame-pointer -fno-rtti -fno-exceptions"
+
+ dnl --------------------------------------
+ dnl Add the CPU dependent optimizations
+@@ -48,20 +48,20 @@
+ ;;
+ icc)
+ ;;
+- cc)
+- CFLAGS="-O3 -apo -LNO -IPA"
+- CXXFLAGS="$CFLAGS"
+- LDFLAGS="${LDFLAGS} -s -IPA"
+- ;;
++dnl cc)
++dnl CFLAGS="-O3 -apo -LNO -IPA"
++dnl CXXFLAGS="$CFLAGS"
++dnl LDFLAGS="${LDFLAGS} -s -IPA"
++dnl ;;
+ esac
+
+
+ dnl ---------------------------------------------------
+ dnl Check standard libraries
+ dnl
+-AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
++dnl AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
+ AC_CHECK_LIB(m, sin,,[AC_MSG_ERROR([math library is not found])],)
+-AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
++dnl AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
+
+ dnl ---------------------------------------------------
+ dnl Find X
+@@ -90,8 +90,8 @@
+
+ FLTK_EXTRA=
+
+-AC_CHECK_LIB(fltk,main,LIBFLTK="-lfltk")
+-AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL" FLTK_EXTRA=show])
++dnl AC_CHECK_LIB(fltk,main,LIBFLTK="-lfltk")
++dnl AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL" FLTK_EXTRA=show])
+
+ FLTK_EXTRA=
+
+@@ -101,7 +101,7 @@
+
+ saved_LIBS="${LIBS}"
+
+-AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
++dnl AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
+ AC_CHECK_LIB(tiff,TIFFOpen,,[AC_MSG_ERROR([libtiff not found])],)
+
+ TIFF_LIBS="${LIBS}"
+
diff --git a/graphics/pixie/files/patch-src-framebuffer-Makefile.am b/graphics/pixie/files/patch-src-framebuffer-Makefile.am
new file mode 100644
index 000000000000..6a34b4744b8c
--- /dev/null
+++ b/graphics/pixie/files/patch-src-framebuffer-Makefile.am
@@ -0,0 +1,13 @@
+--- src/framebuffer/Makefile.am.orig Sun Jan 25 04:16:25 2004
++++ src/framebuffer/Makefile.am Fri Jan 30 18:30:57 2004
+@@ -1,6 +1,6 @@
+ lib_LTLIBRARIES = framebuffer.la
+
+-CFLAGS = $(CFLAGS) @X_CFLAGS@
++CFLAGS = @X_CFLAGS@
+ framebuffer_la_SOURCES = framebuffer.cpp fbx.cpp
+ framebuffer_la_LIBADD = ../common/libcommon.a @X_LIBS@
+ framebuffer_la_LDFLAGS = -module @X_LDFLAGS@
+
+
+
diff --git a/graphics/pixie/pkg-descr b/graphics/pixie/pkg-descr
new file mode 100644
index 000000000000..fc7f4a8cc5f0
--- /dev/null
+++ b/graphics/pixie/pkg-descr
@@ -0,0 +1,24 @@
+Pixie is a RenderMan like photorealistic renderer. It is being developed
+in the hope that it will be useful for graphics research and for people
+who can not afford a commercial renderer.
+
+Some of supported features:
+* All RenderMan 3.4 primitives
+* Programmable shading (RenderMan Shading Language)
+* High quality texture/shadow/environment mapping
+* High dynamic range input/output
+* Raytracing
+* Motion blur
+* Depth of field
+* Reyes style rendering (very fast)
+* Occlusion culling
+* Area light sources
+* Network parallel rendering
+* DSO shaders
+* Global illumination
+* Photon mapping
+
+WWW: http://pixie.sourceforge.net/
+
+- Igor Pokrovsky
+tiamat@comset.net
diff --git a/graphics/pixie/pkg-message b/graphics/pixie/pkg-message
new file mode 100644
index 000000000000..63cbbb286458
--- /dev/null
+++ b/graphics/pixie/pkg-message
@@ -0,0 +1,5 @@
+******************************************************************************
+ Before running any Pixie executable make sure to add the following
+ directory to your LD_LIBRARY_PATH environment variable:
+ %%PREFIX%%/lib/%%PORTNAME%%
+******************************************************************************
diff --git a/graphics/pixie/pkg-plist b/graphics/pixie/pkg-plist
new file mode 100644
index 000000000000..b4a2fe5e6c72
--- /dev/null
+++ b/graphics/pixie/pkg-plist
@@ -0,0 +1,126 @@
+bin/precomp
+bin/rndr
+bin/sdrc
+bin/sdrinfo
+bin/texmake
+include/pixie/dsply.h
+include/pixie/implicit.h
+include/pixie/ri.h
+include/pixie/sdr.h
+include/pixie/shadeop.h
+lib/pixie/file.a
+lib/pixie/file.la
+lib/pixie/file.so
+lib/pixie/file.so.0
+lib/pixie/framebuffer.a
+lib/pixie/framebuffer.la
+lib/pixie/framebuffer.so
+lib/pixie/framebuffer.so.0
+lib/pixie/libri.a
+lib/pixie/libri.la
+lib/pixie/libri.so
+lib/pixie/libri.so.0
+lib/pixie/libsdr.a
+lib/pixie/rgbe.a
+lib/pixie/rgbe.la
+lib/pixie/rgbe.so
+lib/pixie/rgbe.so.0
+%%PORTDOCS%%%%DOCSDIR%%/arealight.htm
+%%PORTDOCS%%%%DOCSDIR%%/attributes.htm
+%%PORTDOCS%%%%DOCSDIR%%/autoraytracing.htm
+%%PORTDOCS%%%%DOCSDIR%%/contents.htm
+%%PORTDOCS%%%%DOCSDIR%%/display.htm
+%%PORTDOCS%%%%DOCSDIR%%/documentation.htm
+%%PORTDOCS%%%%DOCSDIR%%/dso.htm
+%%PORTDOCS%%%%DOCSDIR%%/extraprimitives.htm
+%%PORTDOCS%%%%DOCSDIR%%/figures/caustic1.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/caustic2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/directPhoton.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/ex1_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/ex1_precompute.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/ex3_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/ex3g_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/ex5_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/ex6.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tcaustic1.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tcaustic2.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tdirectPhoton.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tex1_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tex1_precompute.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tex3_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tex5_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tex6.jpg
+%%PORTDOCS%%%%DOCSDIR%%/figures/tx3g_beauty.jpg
+%%PORTDOCS%%%%DOCSDIR%%/gi.htm
+%%PORTDOCS%%%%DOCSDIR%%/hardshaders.htm
+%%PORTDOCS%%%%DOCSDIR%%/header.htm
+%%PORTDOCS%%%%DOCSDIR%%/hiders.htm
+%%PORTDOCS%%%%DOCSDIR%%/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/network.htm
+%%PORTDOCS%%%%DOCSDIR%%/occlusionculling.htm
+%%PORTDOCS%%%%DOCSDIR%%/options.htm
+%%PORTDOCS%%%%DOCSDIR%%/raytracing.htm
+%%PORTDOCS%%%%DOCSDIR%%/raytracingsl.htm
+%%PORTDOCS%%%%DOCSDIR%%/running.htm
+%%PORTDOCS%%%%DOCSDIR%%/sdrlib.htm
+%%PORTDOCS%%%%DOCSDIR%%/tips.htm
+%%PORTDOCS%%%%DOCSDIR%%/tsm.htm
+%%PORTDOCS%%%%DOCSDIR%%/versions.htm
+%%DATADIR%%/shaders/ambientindirect.sdr
+%%DATADIR%%/shaders/ambientindirect.sl
+%%DATADIR%%/shaders/ambientlight.sdr
+%%DATADIR%%/shaders/ambientlight.sl
+%%DATADIR%%/shaders/ambientocclusion.sdr
+%%DATADIR%%/shaders/ambientocclusion.sl
+%%DATADIR%%/shaders/arealight.sdr
+%%DATADIR%%/shaders/arealight.sl
+%%DATADIR%%/shaders/constant.sdr
+%%DATADIR%%/shaders/constant.sl
+%%DATADIR%%/shaders/distantlight.sdr
+%%DATADIR%%/shaders/distantlight.sl
+%%DATADIR%%/shaders/fog.sdr
+%%DATADIR%%/shaders/fog.sl
+%%DATADIR%%/shaders/glass.sdr
+%%DATADIR%%/shaders/glass.sl
+%%DATADIR%%/shaders/matte.sdr
+%%DATADIR%%/shaders/matte.sl
+%%DATADIR%%/shaders/metal.sdr
+%%DATADIR%%/shaders/metal.sl
+%%DATADIR%%/shaders/mirror.sdr
+%%DATADIR%%/shaders/mirror.sl
+%%DATADIR%%/shaders/mtorDirectionalLight.sdr
+%%DATADIR%%/shaders/mtorDirectionalLight.sl
+%%DATADIR%%/shaders/mtorLambert.sdr
+%%DATADIR%%/shaders/mtorLambert.sl
+%%DATADIR%%/shaders/mtorPhong.sdr
+%%DATADIR%%/shaders/mtorPhong.sl
+%%DATADIR%%/shaders/paintedmatte.sdr
+%%DATADIR%%/shaders/paintedmatte.sl
+%%DATADIR%%/shaders/paintedplastic.sdr
+%%DATADIR%%/shaders/paintedplastic.sl
+%%DATADIR%%/shaders/plastic.sdr
+%%DATADIR%%/shaders/plastic.sl
+%%DATADIR%%/shaders/pointlight.sdr
+%%DATADIR%%/shaders/pointlight.sl
+%%DATADIR%%/shaders/rayarea.sdr
+%%DATADIR%%/shaders/rayarea.sl
+%%DATADIR%%/shaders/raydistant.sdr
+%%DATADIR%%/shaders/raydistant.sl
+%%DATADIR%%/shaders/raypoint.sdr
+%%DATADIR%%/shaders/raypoint.sl
+%%DATADIR%%/shaders/shadowarea.sdr
+%%DATADIR%%/shaders/shadowarea.sl
+%%DATADIR%%/shaders/shadowdistant.sdr
+%%DATADIR%%/shaders/shadowdistant.sl
+%%DATADIR%%/shaders/shadowpoint.sdr
+%%DATADIR%%/shaders/shadowpoint.sl
+%%DATADIR%%/shaders/shadowspot.sdr
+%%DATADIR%%/shaders/shadowspot.sl
+%%DATADIR%%/shaders/spotlight.sdr
+%%DATADIR%%/shaders/spotlight.sl
+@dirrm %%DATADIR%%/shaders
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/figures
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/pixie
+@dirrm include/pixie