aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixieplus
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-12-07 20:04:58 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-12-07 20:04:58 +0000
commitbe0393db47a7519e941b46f7b6b1f14ced70d82e (patch)
tree45eed355e997b854bddd8db51dddf8c9d2d2535e /graphics/pixieplus
parent5c509a070c7d6dcc6a2811fba3f9f721bfed66e9 (diff)
downloadports-be0393db47a7519e941b46f7b6b1f14ced70d82e.tar.gz
ports-be0393db47a7519e941b46f7b6b1f14ced70d82e.zip
Notes
Diffstat (limited to 'graphics/pixieplus')
-rw-r--r--graphics/pixieplus/Makefile8
-rw-r--r--graphics/pixieplus/files/blob_private.h102
-rw-r--r--graphics/pixieplus/files/exception_private.h92
-rw-r--r--graphics/pixieplus/files/image_private.h47
-rw-r--r--graphics/pixieplus/files/patch-app_compressedgif.cpp13
5 files changed, 261 insertions, 1 deletions
diff --git a/graphics/pixieplus/Makefile b/graphics/pixieplus/Makefile
index ec0134232373..4f073ad6be15 100644
--- a/graphics/pixieplus/Makefile
+++ b/graphics/pixieplus/Makefile
@@ -7,13 +7,14 @@
PORTNAME= pixieplus
PORTVERSION= 0.5.4.1
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= http://people.fruitsalad.org/avleeuwen/distfiles/${PORTNAME}/
MAINTAINER= avleeuwen@piwebs.com
COMMENT= A free, fast, and feature packed image browser and viewer for KDE
-LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick \
+LIB_DEPENDS= Magick.7:${PORTSDIR}/graphics/ImageMagick \
ungif.5:${PORTSDIR}/graphics/libungif
GNU_CONFIGURE= yes
@@ -29,4 +30,9 @@ USE_BZIP2= yes
BROKEN= "Does not compile on 4.x"
.endif
+post-patch:
+ @${CP} ${FILESDIR}/blob_private.h ${WRKSRC}/app/
+ @${CP} ${FILESDIR}/exception_private.h ${WRKSRC}/app/
+ @${CP} ${FILESDIR}/image_private.h ${WRKSRC}/app/
+
.include <bsd.port.post.mk>
diff --git a/graphics/pixieplus/files/blob_private.h b/graphics/pixieplus/files/blob_private.h
new file mode 100644
index 000000000000..2d3b7d24b18a
--- /dev/null
+++ b/graphics/pixieplus/files/blob_private.h
@@ -0,0 +1,102 @@
+/*
+ Copyright 1999-2004 ImageMagick Studio LLC, a non-profit organization
+ dedicated to making software imaging solutions freely available.
+
+ You may not use this file except in compliance with the License.
+ obtain a copy of the License at
+
+ http://www.imagemagick.org/www/Copyright.html
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
+ ImageMagick Binary Large OBjects private methods.
+*/
+#ifndef _MAGICK_BLOB_PRIVATE_H
+#define _MAGICK_BLOB_PRIVATE_H
+
+#if defined(__cplusplus) || defined(c_plusplus)
+extern "C" {
+#endif
+
+#include "magick/image.h"
+#include "magick/stream.h"
+
+#if !defined(MagickMaxBufferSize)
+#define MagickMaxBufferSize 0x3c005UL
+#endif
+
+typedef enum
+{
+ UndefinedBlobMode,
+ ReadBlobMode,
+ ReadBinaryBlobMode,
+ WriteBlobMode,
+ WriteBinaryBlobMode,
+ IOBinaryBlobMode
+} BlobMode;
+
+typedef int
+ *(*BlobFifo)(const Image *,const void *,const size_t);
+
+typedef struct _BlobInfo
+ BlobInfo;
+
+extern MagickExport BlobInfo
+ *CloneBlobInfo(const BlobInfo *),
+ *ReferenceBlob(BlobInfo *);
+
+extern MagickExport char
+ *ReadBlobString(Image *,char *);
+
+extern MagickExport int
+ EOFBlob(const Image *),
+ ReadBlobByte(Image *),
+ SyncBlob(Image *);
+
+extern MagickExport MagickBooleanType
+ OpenBlob(const ImageInfo *,Image *,const BlobMode,ExceptionInfo *),
+ UnmapBlob(void *,const size_t);
+
+extern MagickExport MagickOffsetType
+ SeekBlob(Image *,const MagickOffsetType,const int),
+ TellBlob(const Image *image);
+
+extern MagickExport ssize_t
+ ReadBlob(Image *,const size_t,unsigned char *),
+ WriteBlob(Image *,const size_t,const unsigned char *),
+ WriteBlobByte(Image *,const unsigned char),
+ WriteBlobLSBLong(Image *,const unsigned long),
+ WriteBlobLSBShort(Image *,const unsigned short),
+ WriteBlobMSBLong(Image *,const unsigned long),
+ WriteBlobMSBShort(Image *,const unsigned short),
+ WriteBlobString(Image *,const char *);
+
+extern MagickExport unsigned char
+ *DetachBlob(BlobInfo *),
+ *ImageToBlob(const ImageInfo *,Image *,size_t *,ExceptionInfo *),
+ *MapBlob(int,const MapMode,const MagickOffsetType,const size_t);
+
+extern MagickExport unsigned long
+ ReadBlobLSBLong(Image *),
+ ReadBlobMSBLong(Image *);
+
+extern MagickExport unsigned short
+ ReadBlobLSBShort(Image *),
+ ReadBlobMSBShort(Image *);
+
+extern MagickExport void
+ AttachBlob(BlobInfo *,const void *,const size_t),
+ CloseBlob(Image *),
+ GetBlobInfo(BlobInfo *),
+ MSBOrderLong(unsigned char *,const size_t),
+ MSBOrderShort(unsigned char *,const size_t);
+
+#if defined(__cplusplus) || defined(c_plusplus)
+}
+#endif
+
+#endif
diff --git a/graphics/pixieplus/files/exception_private.h b/graphics/pixieplus/files/exception_private.h
new file mode 100644
index 000000000000..f19dfb58f895
--- /dev/null
+++ b/graphics/pixieplus/files/exception_private.h
@@ -0,0 +1,92 @@
+/*
+ Copyright 1999-2004 ImageMagick Studio LLC, a non-profit organization
+ dedicated to making software imaging solutions freely available.
+
+ You may not use this file except in compliance with the License.
+ obtain a copy of the License at
+
+ http://www.imagemagick.org/www/Copyright.html
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
+ ImageMagick private exception methods.
+*/
+#ifndef _MAGICK_EXCEPTION_PRIVATE_H
+#define _MAGICK_EXCEPTION_PRIVATE_H
+
+#if defined(__cplusplus) || defined(c_plusplus)
+extern "C" {
+#endif
+
+#include "magick/log.h"
+
+#define ThrowBinaryException(severity,tag,context) \
+{ \
+ if (image != (Image *) NULL) \
+ (void) ThrowMagickException(&image->exception,GetMagickModule(),severity, \
+ tag,context); \
+ return(MagickFalse); \
+}
+#define ThrowFileException(exception,severity,tag,context) \
+ (void) ThrowMagickException(exception,GetMagickModule(),severity,tag, \
+ context,strerror(errno));
+#define ThrowImageException(severity,tag) \
+{ \
+ (void) ThrowMagickException(exception,GetMagickModule(),severity,tag, \
+ image->filename); \
+ return((Image *) NULL); \
+}
+#define ThrowMagickFatalException(severity,tag,context) \
+{ \
+ ExceptionInfo \
+ exception; \
+ \
+ GetExceptionInfo(&exception); \
+ (void) ThrowMagickException(&exception,GetMagickModule(),severity,tag, \
+ context); \
+ CatchException(&exception); \
+ DestroyExceptionInfo(&exception); \
+}
+#define ThrowReaderException(severity,tag) \
+{ \
+ (void) ThrowMagickException(exception,GetMagickModule(),severity,tag, \
+ image_info->filename); \
+ if ((image) != (Image *) NULL) \
+ { \
+ CloseBlob(image); \
+ DestroyImageList(image); \
+ } \
+ return((Image *) NULL); \
+}
+#define ThrowWriterException(severity,tag) \
+{ \
+ assert(image != (Image *) NULL); \
+ (void) ThrowMagickException(&image->exception,GetMagickModule(),severity, \
+ tag,image->filename); \
+ if (image_info->adjoin != MagickFalse) \
+ while (image->previous != (Image *) NULL) \
+ image=image->previous; \
+ CloseBlob(image); \
+ return(MagickFalse); \
+}
+#define ThrowXWindowException(severity,tag,context) \
+{ \
+ ExceptionInfo \
+ exception; \
+ \
+ GetExceptionInfo(&exception); \
+ (void) ThrowMagickException(&exception,GetMagickModule(),severity,tag, \
+ context); \
+ CatchException(&exception); \
+ DestroyExceptionInfo(&exception); \
+}
+
+#if defined(__cplusplus) || defined(c_plusplus)
+}
+#endif
+
+#endif
diff --git a/graphics/pixieplus/files/image_private.h b/graphics/pixieplus/files/image_private.h
new file mode 100644
index 000000000000..a9ca74713be0
--- /dev/null
+++ b/graphics/pixieplus/files/image_private.h
@@ -0,0 +1,47 @@
+/*
+ Copyright 1999-2004 ImageMagick Studio LLC, a non-profit organization
+ dedicated to making software imaging solutions freely available.
+
+ You may not use this file except in compliance with the License.
+ obtain a copy of the License at
+
+ http://www.imagemagick.org/www/Copyright.html
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
+ ImageMagick private image methods.
+*/
+#ifndef _MAGICK_IMAGE_PRIVATE_H
+#define _MAGICK_IMAGE_PRIVATE_H
+
+#if defined(__cplusplus) || defined(c_plusplus)
+extern "C" {
+#endif
+
+extern MagickExport const char
+ *BackgroundColor,
+ *BorderColor,
+ *DefaultTileFrame,
+ *DefaultTileGeometry,
+ *DefaultTileLabel,
+ *ForegroundColor,
+ *MatteColor,
+ *LoadImageTag,
+ *LoadImagesTag,
+ *PSDensityGeometry,
+ *PSPageGeometry,
+ *SaveImageTag,
+ *SaveImagesTag;
+
+extern MagickExport const unsigned long
+ UndefinedCompressionQuality;
+
+#if defined(__cplusplus) || defined(c_plusplus)
+}
+#endif
+
+#endif
diff --git a/graphics/pixieplus/files/patch-app_compressedgif.cpp b/graphics/pixieplus/files/patch-app_compressedgif.cpp
new file mode 100644
index 000000000000..38797e000e0c
--- /dev/null
+++ b/graphics/pixieplus/files/patch-app_compressedgif.cpp
@@ -0,0 +1,13 @@
+--- app/compressedgif.cpp.orig Sat May 22 16:02:26 2004
++++ app/compressedgif.cpp Sun Nov 28 21:37:00 2004
+@@ -9,6 +9,10 @@
+ #include <api.h>
+ #include <assert.h>
+
++#include "blob_private.h"
++#include "image_private.h"
++#include "exception_private.h"
++
+ #ifndef False
+ #define False 0
+ #endif