aboutsummaryrefslogtreecommitdiff
path: root/graphics/pixieplus
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-21 14:14:19 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-21 14:14:19 +0000
commita205fecd19913fe22d866aedbefd7583cd2608dd (patch)
tree8cdf3636df80e711e8303d736d225ef1cee736d7 /graphics/pixieplus
parent2ae5f9daf1b0b125719af03c172666233c0ecb70 (diff)
downloadports-a205fecd19913fe22d866aedbefd7583cd2608dd.tar.gz
ports-a205fecd19913fe22d866aedbefd7583cd2608dd.zip
Notes
Diffstat (limited to 'graphics/pixieplus')
-rw-r--r--graphics/pixieplus/Makefile2
-rw-r--r--graphics/pixieplus/files/patch-app-compressedgif.cpp109
-rw-r--r--graphics/pixieplus/files/patch-app-ifapp.cpp11
-rw-r--r--graphics/pixieplus/files/patch-configure91
4 files changed, 212 insertions, 1 deletions
diff --git a/graphics/pixieplus/Makefile b/graphics/pixieplus/Makefile
index b4b65137d4bf..d64665ed49d8 100644
--- a/graphics/pixieplus/Makefile
+++ b/graphics/pixieplus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pixieplus
PORTVERSION= 0.5.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics kde
MASTER_SITES= http://people.fruitsalad.org/avleeuwen/distfiles/${PORTNAME}/
diff --git a/graphics/pixieplus/files/patch-app-compressedgif.cpp b/graphics/pixieplus/files/patch-app-compressedgif.cpp
new file mode 100644
index 000000000000..5c3068ecfb24
--- /dev/null
+++ b/graphics/pixieplus/files/patch-app-compressedgif.cpp
@@ -0,0 +1,109 @@
+--- app/compressedgif.cpp.orig Fri May 21 14:05:50 2004
++++ app/compressedgif.cpp Fri May 21 14:28:14 2004
+@@ -63,7 +63,7 @@
+ if (byte_count >= 254) \
+ { \
+ (void) WriteBlobByte(image,byte_count); \
+- (void) WriteBlob(image,byte_count,(char *) packet); \
++ (void) WriteBlob(image,byte_count,(const unsigned char *) packet); \
+ byte_count=0; \
+ } \
+ datum>>=8; \
+@@ -280,7 +280,7 @@
+ if (byte_count >= 254)
+ {
+ (void) WriteBlobByte(image,byte_count);
+- (void) WriteBlob(image,byte_count,(char *) packet);
++ (void) WriteBlob(image,byte_count,(const unsigned char *) packet);
+ byte_count=0;
+ }
+ }
+@@ -290,7 +290,7 @@
+ if (byte_count > 0)
+ {
+ (void) WriteBlobByte(image,byte_count);
+- (void) WriteBlob(image,byte_count,(char *) packet);
++ (void) WriteBlob(image,byte_count,(const unsigned char *) packet);
+ }
+ /*
+ Free encoder memory.
+@@ -359,7 +359,7 @@
+ assert(image->signature == MagickSignature);
+ status=OpenBlob(image_info,image,WriteBinaryBlobMode,&image->exception);
+ if (status == false)
+- ThrowWriterException(FileOpenError,"Unable to open file",image);
++ ThrowWriterException(FileOpenError,"Unable to open file");
+ /*
+ Determine image bounding box.
+ */
+@@ -384,7 +384,7 @@
+ colormap=(unsigned char *) AcquireMemory(768);
+ if ((global_colormap == (unsigned char *) NULL) ||
+ (colormap == (unsigned char *) NULL))
+- ThrowWriterException(ResourceLimitError,"Memory allocation failed",image);
++ ThrowWriterException(ResourceLimitError,"Memory allocation failed");
+ for (i=0; i < 768; i++)
+ colormap[i]=0;
+ /*
+@@ -392,12 +392,12 @@
+ */
+ if ((GetImageAttribute(image,"comment") == (ImageAttribute *) NULL) &&
+ !image_info->adjoin && !image->matte)
+- (void) WriteBlob(image,6,"GIF87a");
++ (void) WriteBlob(image,6,(const unsigned char*)"GIF87a");
+ else
+ if (LocaleCompare(image_info->magick,"GIF87") == 0)
+- (void) WriteBlob(image,6,"GIF87a");
++ (void) WriteBlob(image,6,(const unsigned char*)"GIF87a");
+ else
+- (void) WriteBlob(image,6,"GIF89a");
++ (void) WriteBlob(image,6,(const unsigned char*)"GIF89a");
+ page.x=image->page.x;
+ page.y=image->page.y;
+ if ((image->page.width != 0) && (image->page.height != 0))
+@@ -437,7 +437,7 @@
+ LiberateMemory((void **) &global_colormap);
+ LiberateMemory((void **) &colormap);
+ ThrowWriterException(ResourceLimitError,
+- "Memory allocation failed",image)
++ "Memory allocation failed")
+ }
+ image->colormap[opacity]=image->background_color;
+ for (y=0; y < (long) image->rows; y++)
+@@ -515,7 +515,7 @@
+ break;
+ (void) WriteBlobByte(image,(long) j); /* background color */
+ (void) WriteBlobByte(image,0x0); /* reserved */
+- (void) WriteBlob(image,3*(1 << bits_per_pixel),(char *) colormap);
++ (void) WriteBlob(image,3*(1 << bits_per_pixel),(const unsigned char*)colormap);
+ for (j=0; j < 768; j++)
+ global_colormap[j]=colormap[j];
+ }
+@@ -570,7 +570,7 @@
+ (void) WriteBlobByte(image,0x21);
+ (void) WriteBlobByte(image,0xff);
+ (void) WriteBlobByte(image,0x0b);
+- (void) WriteBlob(image,11,"NETSCAPE2.0");
++ (void) WriteBlob(image,11,(const unsigned char*)"NETSCAPE2.0");
+ (void) WriteBlobByte(image,0x03);
+ (void) WriteBlobByte(image,0x01);
+ (void) WriteBlobLSBShort(image,image->iterations);
+@@ -602,7 +602,7 @@
+ c|=0x80;
+ c|=(bits_per_pixel-1); /* size of local colormap */
+ (void) WriteBlobByte(image,c);
+- (void) WriteBlob(image,3*(1 << bits_per_pixel),(char *) colormap);
++ (void) WriteBlob(image,3*(1 << bits_per_pixel),(const unsigned char*) colormap);
+ }
+ /*
+ Write the image data.
+@@ -614,8 +614,7 @@
+ {
+ LiberateMemory((void **) &global_colormap);
+ LiberateMemory((void **) &colormap);
+- ThrowWriterException(ResourceLimitError,"Memory allocation failed",
+- image)
++ ThrowWriterException(ResourceLimitError,"Memory allocation failed")
+ }
+ (void) WriteBlobByte(image,0x0);
+ if (image->next == (Image *) NULL)
diff --git a/graphics/pixieplus/files/patch-app-ifapp.cpp b/graphics/pixieplus/files/patch-app-ifapp.cpp
new file mode 100644
index 000000000000..65e391b2da31
--- /dev/null
+++ b/graphics/pixieplus/files/patch-app-ifapp.cpp
@@ -0,0 +1,11 @@
+--- app/ifapp.cpp.orig Fri May 21 14:01:17 2004
++++ app/ifapp.cpp Fri May 21 14:03:11 2004
+@@ -34,7 +34,7 @@
+ // ImageMagick message and progress stubs
+ extern "C"{
+ unsigned int magickMonitor(const char *msg, const off_t value,
+- const size_t span, ExceptionInfo *)
++ const long long unsigned int span, ExceptionInfo *)
+ {
+ if(!appPtr)
+ return(true);
diff --git a/graphics/pixieplus/files/patch-configure b/graphics/pixieplus/files/patch-configure
new file mode 100644
index 000000000000..7e3054ebf13c
--- /dev/null
+++ b/graphics/pixieplus/files/patch-configure
@@ -0,0 +1,91 @@
+--- configure.orig Fri May 21 13:53:33 2004
++++ configure Fri May 21 13:53:39 2004
+@@ -3098,7 +3098,7 @@
+ if test "$GXX" = "yes" || test "$CXX" = "KCC"; then
+ if test "$kde_use_debug_code" != "no"; then
+ if test "$CXX" = "KCC"; then
+- CXXFLAGS="+K0 -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings $CXXFLAGS"
++ CXXFLAGS="+K0 -Wall -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings $CXXFLAGS"
+ else
+ if test "$kde_use_debug_code" = "full"; then
+ CXXFLAGS="-g3 $CXXFLAGS"
+@@ -3335,11 +3335,11 @@
+ if test "$GCC" = "yes"; then
+ case $host in
+ *-*-linux-gnu)
+- CFLAGS="-ansi -W -Wall -pedantic -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE $CFLAGS"
++ CFLAGS="-ansi -W -Wall -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE $CFLAGS"
+ CXXFLAGS="-ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion $CXXFLAGS"
+ ;;
+ esac
+- CXXFLAGS="-Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings $CXXFLAGS"
++ CXXFLAGS="-Wall -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings $CXXFLAGS"
+
+ echo "$as_me:3344: checking whether $CXX supports -Wundef" >&5
+ echo $ECHO_N "checking whether $CXX supports -Wundef... $ECHO_C" >&6
+@@ -14996,7 +14996,7 @@
+ fi
+
+ # This can be used to rebuild libtool when needed
+-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool13/ltmain.sh"
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool --silent'
+@@ -16553,7 +16553,7 @@
+ kde_safe_LIBS="$LIBS"
+ LIBS="$LIBS $X_EXTRA_LIBS"
+ if test "$GCC" = "yes"; then
+-CXXFLAGS="$CXXFLAGS -pedantic-errors"
++CXXFLAGS="$CXXFLAGS -errors"
+ fi
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 16559 "configure"
+@@ -18767,8 +18767,8 @@
+ USE_THREADS=""
+ if test -z "$LIBPTHREAD"; then
+
+-echo "$as_me:18770: checking whether $CXX supports -pthread" >&5
+-echo $ECHO_N "checking whether $CXX supports -pthread... $ECHO_C" >&6
++echo "$as_me:18770: checking whether $CXX supports -lc_r" >&5
++echo $ECHO_N "checking whether $CXX supports -lc_r... $ECHO_C" >&6
+ kde_cache=`echo pthread | sed 'y% .=/+-%____p_%'`
+ if eval "test \"\${kde_cv_prog_cxx_$kde_cache+set}\" = set"; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+@@ -18783,7 +18783,7 @@
+ ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+
+ save_CXXFLAGS="$CXXFLAGS"
+- CXXFLAGS="$CXXFLAGS -pthread"
++ CXXFLAGS="$CXXFLAGS -lc_r"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 18788 "configure"
+ #include "confdefs.h"
+@@ -18827,7 +18827,7 @@
+ echo "$as_me:18827: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ :
+- USE_THREADS="-pthread"
++ USE_THREADS="-lc_r"
+ else
+ echo "$as_me:18832: result: no" >&5
+ echo "${ECHO_T}no" >&6
+@@ -21614,15 +21614,15 @@
+ { (exit 1); exit 1; }; }
+ fi
+
+-echo "$as_me:21617: checking for magick/resource.h" >&5
+-echo $ECHO_N "checking for magick/resource.h... $ECHO_C" >&6
++echo "$as_me:21617: checking for magick/resource_.h" >&5
++echo $ECHO_N "checking for magick/resource_.h... $ECHO_C" >&6
+ if test "${ac_cv_header_magick_resource_h+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 21623 "configure"
+ #include "confdefs.h"
+-#include <magick/resource.h>
++#include <magick/resource_.h>
+ _ACEOF
+ if { (eval echo "$as_me:21627: \"$ac_cpp conftest.$ac_ext\"") >&5
+ (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1