aboutsummaryrefslogtreecommitdiff
path: root/graphics/png/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-28 06:47:48 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-28 06:47:48 +0000
commitde78af3ac53da4687d22975cd2e236a0668d9a0d (patch)
treed9c023ed56bfb9a9663ac490476a1cca76b1c499 /graphics/png/Makefile
parent1c61847a1158728babbb2e3016e7b369abef3304 (diff)
downloadports-de78af3ac53da4687d22975cd2e236a0668d9a0d.tar.gz
ports-de78af3ac53da4687d22975cd2e236a0668d9a0d.zip
Notes
Diffstat (limited to 'graphics/png/Makefile')
-rw-r--r--graphics/png/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 1d3f17a2869c..42cab5850d53 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -6,14 +6,10 @@
#
PORTNAME= png
-PORTVERSION= 1.2.43
+PORTVERSION= 1.4.1
CATEGORIES= graphics
-MASTER_SITES= SF/lib${PORTNAME}/03-lib${PORTNAME}-previous/${PORTVERSION}
+MASTER_SITES= SF/lib${PORTNAME}/01-lib${PORTNAME}-master/${PORTVERSION}
DISTNAME= lib${PORTNAME}-${PORTVERSION}
-#PATCH_SITES= ${MASTER_SITES}
-#PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
-#PATCHFILES=
-#PATCH_DIST_STRIP= -p1
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Library for manipulating PNG images
@@ -23,7 +19,7 @@ ALL_TARGET= all libpng-config test
MAKE_FLAGS= ccopts="${CFLAGS}" ldopts="${LDFLAGS}" -f
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-SHLIB_VER= 5
+SHLIB_VER= 6
USE_BZIP2= yes
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
@@ -47,7 +43,7 @@ post-install:
${SED} -e 's|@PREFIX@|${PREFIX}|' ${WRKSRC}/scripts/libpng.pc.in \
> ${WRKSRC}/scripts/libpng.pc
${INSTALL_DATA} ${WRKSRC}/scripts/libpng.pc \
- ${PREFIX}/libdata/pkgconfig/libpng12.pc
- ${LN} -sf libpng12.pc ${PREFIX}/libdata/pkgconfig/libpng.pc
+ ${PREFIX}/libdata/pkgconfig/libpng14.pc
+ ${LN} -sf libpng14.pc ${PREFIX}/libdata/pkgconfig/libpng.pc
.include <bsd.port.post.mk>