aboutsummaryrefslogtreecommitdiff
path: root/graphics/png/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-01-29 20:20:56 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-01-29 20:20:56 +0000
commit52f7e4ba0e7b067b8bb6ed51de218226c435737e (patch)
tree78986abdce92b9236a86cc40b2b509ca5d95e587 /graphics/png/Makefile
parentd8de079d4362ec252d83043415dc2ceb754b0d8a (diff)
Notes
Diffstat (limited to 'graphics/png/Makefile')
-rw-r--r--graphics/png/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index e0964e46bc05..9bc737be122a 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -7,6 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libpng.org/pub/png/src/ \
ftp://swrinde.nde.swri.edu/pub/png/src/ \
@@ -38,5 +39,13 @@ post-extract:
pre-install:
@[ -d ${PREFIX}/include/libpng ] || ${MKDIR} ${PREFIX}/include/libpng
+ @[ -d ${PREFIX}/libdata/pkgconfig ] || \
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+
+post-install:
+ ${CAT} ${WRKSRC}/scripts/libpng.pc.in | ${SED} -e \
+ 's|@PREFIX@|${PREFIX}|' > ${WRKSRC}/scripts/libpng.pc
+ ${INSTALL_DATA} ${WRKSRC}/scripts/libpng.pc \
+ ${PREFIX}/libdata/pkgconfig/libpng12.pc
.include <bsd.port.post.mk>