aboutsummaryrefslogtreecommitdiff
path: root/graphics/png/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-07-09 08:17:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-07-09 08:17:13 +0000
commitd136899793c339f5ddbd10c8c6ec9da00bcb1788 (patch)
tree77f2e0f7d3d7da8fb05682e63788de08c25e2c01 /graphics/png/Makefile
parent8b5844abdd0da7daf5ca80c430a011cb3b9f01f6 (diff)
Notes
Diffstat (limited to 'graphics/png/Makefile')
-rw-r--r--graphics/png/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 07b9bac313b9..f524248b3597 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -15,14 +15,15 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Library for manipulating PNG images
+MAKE_JOBS_SAFE= yes
+
+USE_XZ= yes
+USE_LDCONFIG= yes
+
MAKEFILE= ${WRKSRC}/scripts/makefile.freebsd
ALL_TARGET= all libpng-config test
MAKE_FLAGS= ccopts="${CFLAGS}" ldopts="${LDFLAGS}" -f
-MAKE_JOBS_SAFE= yes
-USE_LDCONFIG= yes
SHLIB_VER= 6
-USE_XZ= yes
-
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
@@ -38,6 +39,7 @@ OPTIONS= APNG "Animated PNG support" Off
MASTER_SITES+= SF/vdubapngmod/lib${PORTNAME}-apng-patch/${PORTVERSION}:apng \
http://littlesvr.ca/apng/diff/:apng
DISTFILES+= ${DISTNAME}-apng.patch:apng
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
.if defined(WITH_APNG)
USE_DOS2UNIX= ${DISTNAME}-apng.patch