aboutsummaryrefslogtreecommitdiff
path: root/graphics/png2html/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-08-26 04:08:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-08-26 04:08:00 +0000
commit5172fcebd2be95eb3e3f07afe44398de9752b32f (patch)
treea6394491c6e0c316778a5d8a14d8ae9b73f22d3f /graphics/png2html/Makefile
parentd24d4d2dda63ccd5d3d2d1cf4ea8b1a9dbae37a3 (diff)
downloadports-5172fcebd2be95eb3e3f07afe44398de9752b32f.tar.gz
ports-5172fcebd2be95eb3e3f07afe44398de9752b32f.zip
Notes
Diffstat (limited to 'graphics/png2html/Makefile')
-rw-r--r--graphics/png2html/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/png2html/Makefile b/graphics/png2html/Makefile
index f26e06953e4d..6765d8849fc2 100644
--- a/graphics/png2html/Makefile
+++ b/graphics/png2html/Makefile
@@ -9,22 +9,23 @@ PORTNAME= png2html
PORTVERSION= 1.1
PORTREVISION= 7
CATEGORIES= graphics
-MASTER_SITES= http://www.engr.mun.ca/~holden/
+MASTER_SITES= http://www.geoffholden.com/content/projects/png2html/
MAINTAINER= ports@FreeBSD.org
COMMENT= Takes a PNG image and transforms it into HTML
+LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
gd.4:${PORTSDIR}/graphics/gd
PLIST_FILES= bin/png2html
-do-configure:
- @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
- @${SED} -e 's|CHANGE_ME|${PREFIX}|' \
- < ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
+post-patch:
+ @${REINPLACE_CMD} 's|CHANGE_ME|${LOCALBASE}|g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/png2html ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/png2html ${PREFIX}/bin
.include <bsd.port.mk>