aboutsummaryrefslogtreecommitdiff
path: root/graphics/png
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-10-20 14:05:04 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-10-20 14:05:04 +0000
commiteb028d04510a0e1609290633a29a6d67aa5c0297 (patch)
tree26ca842c2f23ef654c7da7ff50765c23e23b70d8 /graphics/png
parent5cf189139ca84688037be89fe8164816e7b0808b (diff)
downloadports-eb028d04510a0e1609290633a29a6d67aa5c0297.tar.gz
ports-eb028d04510a0e1609290633a29a6d67aa5c0297.zip
Notes
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile5
-rw-r--r--graphics/png/files/patch-aa14
-rw-r--r--graphics/png/files/patch-icc53
3 files changed, 68 insertions, 4 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 12cbb3313020..8617921b12ff 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -22,6 +22,7 @@ MAINTAINER= ache@FreeBSD.org
COMMENT= Library for manipulating PNG images
MAKEFILE= ${WRKSRC}/scripts/makefile.freebsd
+ALL_TARGET= all test
INSTALLS_SHLIB= yes
SHLIB_VER= 5
@@ -44,8 +45,8 @@ pre-install:
${MKDIR} ${PREFIX}/libdata/pkgconfig
post-install:
- ${CAT} ${WRKSRC}/scripts/libpng.pc.in | ${SED} -e \
- 's|@PREFIX@|${PREFIX}|' > ${WRKSRC}/scripts/libpng.pc
+ ${SED} -e 's|@PREFIX@|${PREFIX}|' ${WRKSRC}/scripts/libpng.pc.in \
+ > ${WRKSRC}/scripts/libpng.pc
${INSTALL_DATA} ${WRKSRC}/scripts/libpng.pc \
${PREFIX}/libdata/pkgconfig/libpng12.pc
diff --git a/graphics/png/files/patch-aa b/graphics/png/files/patch-aa
index 1d3c9840bfe1..e676e57368a7 100644
--- a/graphics/png/files/patch-aa
+++ b/graphics/png/files/patch-aa
@@ -1,5 +1,5 @@
---- scripts/makefile.freebsd.bak Sat May 18 18:46:45 2002
-+++ scripts/makefile.freebsd Thu May 30 08:55:41 2002
+--- scripts/makefile.freebsd Sat May 18 10:46:45 2002
++++ scripts/makefile.freebsd Mon Oct 20 00:05:40 2003
@@ -25,7 +25,7 @@
DPADD+= ${LIBM} ${LIBZ}
@@ -9,3 +9,13 @@
CFLAGS+= -DPNG_NO_ASSEMBLER_CODE
.endif
+@@ -34,7 +34,7 @@
+ pngwtran.c pngmem.c pngerror.c pngpread.c pnggccrd.c
+
+-pngtest: pngtest.o libpng.a
++pngtest: pngtest.o ${SHLIB_NAME}
+- ${CC} ${CFLAGS} -L. -static -o pngtest pngtest.o -lpng -lz -lm
++ ${CC} ${CFLAGS} -L. -Wl,-rpath=${.OBJDIR} -o pngtest pngtest.o -lpng -lz -lm
+
+ CLEANFILES= pngtest pngtest.o pngout.png
+
diff --git a/graphics/png/files/patch-icc b/graphics/png/files/patch-icc
new file mode 100644
index 000000000000..6fcef39d88b7
--- /dev/null
+++ b/graphics/png/files/patch-icc
@@ -0,0 +1,53 @@
+This patch is needed by Intel's C Compiler (icc), which otherwise
+gets confused and treats _const4 and _const6 as undefined symbols.
+
+I don't see, how it can hurt the GCC either.
+
+ -mi
+
+--- pnggccrd.c Thu Oct 3 07:32:28 2002
++++ pnggccrd.c Sun Oct 19 23:55:15 2003
+@@ -327,7 +327,7 @@
+ static unsigned long long _mask48_0 = 0x4040808080808080LL;
+
+-static unsigned long long _const4 = 0x0000000000FFFFFFLL;
++static const unsigned long long _const4 = 0x0000000000FFFFFFLL;
+ //static unsigned long long _const5 = 0x000000FFFFFF0000LL; // NOT USED
+-static unsigned long long _const6 = 0x00000000000000FFLL;
++static const unsigned long long _const6 = 0x00000000000000FFLL;
+
+ // These are used in the row-filter routines and should/would be local
+@@ -344,33 +344,4 @@
+ #endif
+
+-void /* PRIVATE */
+-png_squelch_warnings(void)
+-{
+-#ifdef PNG_THREAD_UNSAFE_OK
+- _dif = _dif;
+- _patemp = _patemp;
+- _pbtemp = _pbtemp;
+- _pctemp = _pctemp;
+- _MMXLength = _MMXLength;
+-#endif
+- _const4 = _const4;
+- _const6 = _const6;
+- _mask8_0 = _mask8_0;
+- _mask16_1 = _mask16_1;
+- _mask16_0 = _mask16_0;
+- _mask24_2 = _mask24_2;
+- _mask24_1 = _mask24_1;
+- _mask24_0 = _mask24_0;
+- _mask32_3 = _mask32_3;
+- _mask32_2 = _mask32_2;
+- _mask32_1 = _mask32_1;
+- _mask32_0 = _mask32_0;
+- _mask48_5 = _mask48_5;
+- _mask48_4 = _mask48_4;
+- _mask48_3 = _mask48_3;
+- _mask48_2 = _mask48_2;
+- _mask48_1 = _mask48_1;
+- _mask48_0 = _mask48_0;
+-}
+ #endif /* PNG_ASSEMBLER_CODE_SUPPORTED */
+