aboutsummaryrefslogtreecommitdiff
path: root/graphics/png
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-12-08 13:28:18 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-12-08 13:28:18 +0000
commit36ad2c62cc50596d5594000da8308226104e7358 (patch)
tree4b10f727a8bd200ed7e5334136c420dc8ea46e97 /graphics/png
parent74559808043728cfc1334a9435169dfac4b4ec55 (diff)
downloadports-36ad2c62cc50596d5594000da8308226104e7358.tar.gz
ports-36ad2c62cc50596d5594000da8308226104e7358.zip
Notes
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile2
-rw-r--r--graphics/png/files/patch-pnggccrd.c33
2 files changed, 34 insertions, 1 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 8617921b12ff..45e99d658f9a 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.libpng.org/pub/png/src/ \
ftp://swrinde.nde.swri.edu/pub/png/src/ \
diff --git a/graphics/png/files/patch-pnggccrd.c b/graphics/png/files/patch-pnggccrd.c
new file mode 100644
index 000000000000..4a6e690ace8f
--- /dev/null
+++ b/graphics/png/files/patch-pnggccrd.c
@@ -0,0 +1,33 @@
+--- pnggccrd.c.orig Thu Dec 4 15:52:22 2003
++++ pnggccrd.c Thu Dec 4 16:00:18 2003
+@@ -1767,7 +1767,8 @@
+
+ : "1" (sptr), // esi // input regs
+ "2" (dp), // edi
+- "0" (width) // ecx
++ "0" (width), // ecx
++ "rim" (_const4)
+ // doesn't work "i" (0x0000000000FFFFFFLL) // %1 (a.k.a. _const4)
+
+ #if 0 /* %mm0, ..., %mm4 not supported by gcc 2.7.2.3 or egcs 1.1 */
+@@ -1811,7 +1812,8 @@
+
+ : "1" (sptr), // esi // input regs
+ "2" (dp), // edi
+- "0" (width) // ecx
++ "0" (width), // ecx
++ "rim" (_const4)
+
+ #if 0 /* %mm0, ..., %mm2 not supported by gcc 2.7.2.3 or egcs 1.1 */
+ : "%mm0", "%mm1", "%mm2" // clobber list
+@@ -1865,7 +1867,9 @@
+
+ : "1" (sptr), // esi // input regs
+ "2" (dp), // edi
+- "0" (width_mmx) // ecx
++ "0" (width_mmx), // ecx
++ "rim" (_const4),
++ "rim" (_const6)
+
+ #if 0 /* %mm0, ..., %mm3 not supported by gcc 2.7.2.3 or egcs 1.1 */
+ : "%mm0", "%mm1" // clobber list