aboutsummaryrefslogtreecommitdiff
path: root/graphics/png
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-07-29 06:07:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-07-29 06:07:57 +0000
commitb4d96c127554d4fa3a13e3d0e1d6f674f6e9f4b3 (patch)
treebec08f79839aec305be3a3c8cba746491ad95727 /graphics/png
parent8f280973e3cde1b7aaec159f89cf4775000e2fb8 (diff)
downloadports-b4d96c127554d4fa3a13e3d0e1d6f674f6e9f4b3.tar.gz
ports-b4d96c127554d4fa3a13e3d0e1d6f674f6e9f4b3.zip
Notes
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile12
-rw-r--r--graphics/png/files/patch-CMakeLists.txt12
-rw-r--r--graphics/png/pkg-plist4
3 files changed, 6 insertions, 22 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 160c5ae8bf73..5a4b25acc6d3 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -3,6 +3,7 @@
PORTNAME= png
PORTVERSION= 1.6.17
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/lib${PORTNAME}/lib${PORTNAME}16/${PORTVERSION}
PATCH_SITES= SF/apng/lib${PORTNAME}/lib${PORTNAME}16/
@@ -11,13 +12,13 @@ DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= portmgr@FreeBSD.org
COMMENT= Library for manipulating PNG images
-USES= cmake cpe tar:xz
+USES= cpe libtool tar:xz
CPE_PRODUCT= libpng
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DPNG_MAN_DIR:STRING=man
-
OPTIONS_DEFINE=APNG PNGTEST
OPTIONS_DEFAULT=APNG PNGTEST
APNG_DESC=Enable Animated PNG support
@@ -29,11 +30,6 @@ PNGTEST_DESC=Enable Regression Test (recommended)
PATCHFILES= ${DISTNAME}-apng.patch.gz
.endif
-post-patch:
- ${REINPLACE_CMD} \
- -e 's|LIBDIR}/pkgconfig|LIBDIR}data/pkgconfig|' \
- ${WRKSRC}/CMakeLists.txt
-
.if ${PORT_OPTIONS:MPNGTEST}
post-build:
(cd ${BUILD_WRKSRC}; if ! ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} test; then \
diff --git a/graphics/png/files/patch-CMakeLists.txt b/graphics/png/files/patch-CMakeLists.txt
deleted file mode 100644
index d44645cb91c3..000000000000
--- a/graphics/png/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,12 +0,0 @@
---- CMakeLists.txt.orig 2015-03-26 13:06:23 UTC
-+++ CMakeLists.txt
-@@ -50,9 +50,6 @@ option(PNGARG "Disable ANSI-C pro
- # SET LIBNAME
- set(PNG_LIB_NAME png${PNGLIB_MAJOR}${PNGLIB_MINOR})
-
--# to distinguish between debug and release lib
--set(CMAKE_DEBUG_POSTFIX "d")
--
- # Use the prebuilt pnglibconf.h file from the scripts folder
- # TODO: fix this by building with awk; without this no cmake build can be
- # configured directly (to do so indirectly use your local awk to build a
diff --git a/graphics/png/pkg-plist b/graphics/png/pkg-plist
index 08374d0e5fac..f5483e7f386e 100644
--- a/graphics/png/pkg-plist
+++ b/graphics/png/pkg-plist
@@ -1,5 +1,7 @@
bin/libpng-config
bin/libpng16-config
+bin/png-fix-itxt
+bin/pngfix
include/libpng16/png.h
include/libpng16/pngconf.h
include/libpng16/pnglibconf.h
@@ -8,8 +10,6 @@ include/pngconf.h
include/pnglibconf.h
lib/libpng.a
lib/libpng.so
-lib/libpng/libpng16-%%CMAKE_BUILD_TYPE%%.cmake
-lib/libpng/libpng16.cmake
lib/libpng16.a
lib/libpng16.so
lib/libpng16.so.16