aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngquant
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2016-02-12 20:45:01 +0000
committerAlex Kozlov <ak@FreeBSD.org>2016-02-12 20:45:01 +0000
commite4ecece968c9c64f7ebe756d2a237f50a75663c9 (patch)
treeade7ec4801c12dd4afa6efe09182690256b41b70 /graphics/pngquant
parent8a8e1be6d5f1e6a84d87fca8ff06eb8c9f3bdec7 (diff)
downloadports-e4ecece968c9c64f7ebe756d2a237f50a75663c9.tar.gz
ports-e4ecece968c9c64f7ebe756d2a237f50a75663c9.zip
Notes
Diffstat (limited to 'graphics/pngquant')
-rw-r--r--graphics/pngquant/Makefile11
-rw-r--r--graphics/pngquant/files/patch-lib_configure41
2 files changed, 43 insertions, 9 deletions
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
index 602186ef5853..a49b68b2a3a8 100644
--- a/graphics/pngquant/Makefile
+++ b/graphics/pngquant/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pngquant
PORTVERSION= 2.5.2
+PORTREVISION= 1
DISTVERSIONSUFFIX= -src
CATEGORIES= graphics
MASTER_SITES= http://pngquant.org/
@@ -14,7 +15,6 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -42,14 +42,7 @@ SSE_CFLAGS= -DUSE_SSE=1 -msse2
OPENMP_CFLAGS= -fopenmp
OPENMP_LDFLAGS= -lgomp -pthread
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MDEBUG)
-CFLAGS+= -DNDEBUG
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-$$(MAKEFLAGS)||' ${WRKSRC}/Makefile
+DEBUG_CFLAGS_OFF= -DNDEBUG
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pngquant ${STAGEDIR}${PREFIX}/bin
diff --git a/graphics/pngquant/files/patch-lib_configure b/graphics/pngquant/files/patch-lib_configure
new file mode 100644
index 000000000000..da66afb0f590
--- /dev/null
+++ b/graphics/pngquant/files/patch-lib_configure
@@ -0,0 +1,41 @@
+Index: lib/configure
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env bash
++#!/bin/sh
+
+ CONFIG="config.mk"
+ PREFIX="/usr/local"
+@@ -80,7 +80,7 @@
+
+ # If someone runs sudo make install as very first command, and configure later,
+ # $CONFIG cannot be overwritten, and must be deleted before continuing.
+-if [[ -f "$CONFIG" && ! -w "$CONFIG" ]]; then
++if [ -f "$CONFIG" -a ! -w "$CONFIG" ]; then
+ echo "Cannot overwrite file $CONFIG! Please delete it."
+ exit 1
+ fi
+@@ -135,10 +135,8 @@
+
+ # SSE
+ if [ "$SSE" = 'auto' ]; then
+- if [[ "$(uname -m)" =~ (amd|x86_)64 ||
+- "$(grep -E -m1 "^flags" /proc/cpuinfo)" =~ "sse" ]]; then
+- SSE=1
+- fi
++ echo $(uname -m) | grep -E -q '(amd|x86_)64' && SSE=1
++ grep -E -m1 -q '^flags.*sse' /proc/cpuinfo 2>/dev/null && SSE=1
+ fi
+
+ if [ "$SSE" -eq 1 ]; then
+@@ -161,9 +159,8 @@
+ else
+ OPENMPFLAGS="-fopenmp"
+ fi
+- if [[ "$("$CC" -xc -E $OPENMPFLAGS <(echo "#ifdef _OPENMP
+- #include <omp.h>
+- #endif") 2>&1)" =~ "omp_get_thread_num" ]]; then
++ if echo "$(printf '#ifdef _OPENMP\n#include <omp.h>\n#endif\n' | \
++ "$CC" -xc -E $OPENMPFLAGS - 2>&1)" | grep -q omp_get_thread_num; then
+ cflags "$OPENMPFLAGS"
+ lflags "$OPENMPFLAGS"
+ status "OpenMP" "yes"