aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngwriter
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-11-24 20:50:04 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-11-24 20:50:04 +0000
commit3d077b8362bc739f7b69fab5a570c32644691e7d (patch)
tree76444ca7d82551bb1e3ec44002061464f66f7552 /graphics/pngwriter
parentb83fdefc02d9eee72fb19077bab87ad72a8855a9 (diff)
downloadports-3d077b8362bc739f7b69fab5a570c32644691e7d.tar.gz
ports-3d077b8362bc739f7b69fab5a570c32644691e7d.zip
Notes
Diffstat (limited to 'graphics/pngwriter')
-rw-r--r--graphics/pngwriter/Makefile34
1 files changed, 20 insertions, 14 deletions
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index ae630d2e4344..5db6e4e79fc2 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -12,20 +12,18 @@ PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A C++ library for creating PNG images
+MAINTAINER= nemysis@gmx.ch
+COMMENT= C++ library for creating PNG images
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype:${PORTSDIR}/print/freetype2
USE_PKGCONFIG= yes
-BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
+WRKSRC= ${WRKDIR}/${DISTNAME}
CXXFLAGS+= `pkg-config --cflags freetype2 libpng15` -I${LOCALBASE}/include
-PORTDOCS= *
-PORTEXAMPLES= *
PLIST_FILES= include/pngwriter.h \
lib/libpngwriter.a \
%%DATADIR%%/fonts/FreeMonoBold.ttf \
@@ -33,24 +31,32 @@ PLIST_FILES= include/pngwriter.h \
PLIST_DIRS= %%DATADIR%%/fonts \
%%DATADIR%%
+PORTDOCS= *
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
post-extract:
@${FIND} ${WRKSRC} -name "\.*" -delete
do-build:
- cd ${BUILD_WRKSRC} \
+ cd ${WRKSRC}/src \
&& ${CXX} ${CXXFLAGS} -c pngwriter.cc -o pngwriter.o \
&& ${AR} rv libpngwriter.a pngwriter.o
do-install:
${INSTALL_DATA} ${WRKSRC}/src/pngwriter.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/src/libpngwriter.a ${PREFIX}/lib
- @${MKDIR} ${DATADIR}/fonts
- @(cd ${WRKSRC}/fonts && ${COPYTREE_SHARE} . ${DATADIR}/fonts)
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} fonts ${DATADIR})
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>