aboutsummaryrefslogtreecommitdiff
path: root/graphics/pngwriter
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-07 09:31:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-07 09:31:04 +0000
commit16e2f3a07e562662c1e9fa72de64dfa28dfc075a (patch)
treeb136ba1ca8c8f16f747f6fa2c9d65dbdc971afd6 /graphics/pngwriter
parent13362e5e25683cef5a6d0d358a94f7eade052f31 (diff)
downloadports-16e2f3a07e562662c1e9fa72de64dfa28dfc075a.tar.gz
ports-16e2f3a07e562662c1e9fa72de64dfa28dfc075a.zip
Notes
Diffstat (limited to 'graphics/pngwriter')
-rw-r--r--graphics/pngwriter/Makefile38
-rw-r--r--graphics/pngwriter/distinfo1
-rw-r--r--graphics/pngwriter/files/patch-make.include.linux14
-rw-r--r--graphics/pngwriter/pkg-descr9
-rw-r--r--graphics/pngwriter/pkg-plist20
5 files changed, 82 insertions, 0 deletions
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
new file mode 100644
index 000000000000..0580f9eb2c7d
--- /dev/null
+++ b/graphics/pngwriter/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: pngwriter
+# Date created: Nov 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pngwriter
+PORTVERSION= 0.3.7
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A C++ library for creating PNG images
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_REINPLACE= yes
+ALL_TARGET= libpngwriter
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/make.include.linux
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/pngwriter.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/src/libpngwriter.a ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/*.cc ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/pngwriter/distinfo b/graphics/pngwriter/distinfo
new file mode 100644
index 000000000000..6d1b41d07b59
--- /dev/null
+++ b/graphics/pngwriter/distinfo
@@ -0,0 +1 @@
+MD5 (pngwriter-0.3.7.tgz) = 72b4e2f09c3b4d81304fe1858b833c3a
diff --git a/graphics/pngwriter/files/patch-make.include.linux b/graphics/pngwriter/files/patch-make.include.linux
new file mode 100644
index 000000000000..190dac39b70e
--- /dev/null
+++ b/graphics/pngwriter/files/patch-make.include.linux
@@ -0,0 +1,14 @@
+--- make.include.linux.orig Fri Oct 17 23:39:10 2003
++++ make.include.linux Fri Nov 7 17:23:01 2003
+@@ -1,7 +1,7 @@
+-CXX=g++
+-CXXFLAGS= -O3 -Wall -Wno-deprecated
+-INC= -I../src
+-LIBS= -L../src -lz -lpng -lpngwriter
++CXX?=g++
++CXXFLAGS+= -Wall -Wno-deprecated
++INC= -I../src -I%%LOCALBASE%%/include
++LIBS= -L../src -lz -lpng -lpngwriter -L%%LOCALBASE%%/lib
+ INSTALL=install
+ DESTDIR=/usr/local
+ SELF=make.include.linux
diff --git a/graphics/pngwriter/pkg-descr b/graphics/pngwriter/pkg-descr
new file mode 100644
index 000000000000..d57870670257
--- /dev/null
+++ b/graphics/pngwriter/pkg-descr
@@ -0,0 +1,9 @@
+The PNGwriter library, which requires libpng, allows you to plot to a 48-bit
+PNG file, saving it directly to disk. Plotting is as easy as specifying the
+red, green, and blue values and the x, y coordinates of the pixel. It includes
+functions for plotting simple geometric shapes (circle, rect, line), reading
+the colour of a pixel, reading in a whole PNG file (great for image analysis),
+plotting and reading in HSV colourspace, and many others that might come in
+handy.
+
+WWW: http://pngwriter.sourceforge.net/
diff --git a/graphics/pngwriter/pkg-plist b/graphics/pngwriter/pkg-plist
new file mode 100644
index 000000000000..15157d00bcc8
--- /dev/null
+++ b/graphics/pngwriter/pkg-plist
@@ -0,0 +1,20 @@
+include/pngwriter.h
+lib/libpngwriter.a
+%%PORTDOCS%%%%DOCSDIR%%/english/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/english/EXAMPLES
+%%PORTDOCS%%%%DOCSDIR%%/english/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/english/PNGwriterQuickReference_EN.pdf
+%%PORTDOCS%%%%DOCSDIR%%/english/README
+%%PORTDOCS%%%%DOCSDIR%%/espaniol/CAMBIOS
+%%PORTDOCS%%%%DOCSDIR%%/espaniol/EJEMPLOS
+%%PORTDOCS%%%%DOCSDIR%%/espaniol/LEAME
+%%PORTDOCS%%%%DOCSDIR%%/espaniol/LICENCIA
+%%PORTDOCS%%%%DOCSDIR%%/espaniol/PNGwriterQuickReference_ES.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/english
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/espaniol
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/lyapunov.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/lyapunov.espaniol.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/pngtest.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/pngtest.espaniol.cc
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%