aboutsummaryrefslogtreecommitdiff
path: root/graphics/podofo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-27 13:10:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-27 13:10:20 +0000
commit22fe192f88d66e4ac80f19709e1664c5ce46ac11 (patch)
tree2a3f99c5273a5b4ede4f51d7b54a3016323cbb65 /graphics/podofo
parentafcd9bf461ee813bd17c0718ef3211b5d09fc890 (diff)
downloadports-22fe192f88d66e4ac80f19709e1664c5ce46ac11.tar.gz
ports-22fe192f88d66e4ac80f19709e1664c5ce46ac11.zip
- Update to 0.9.1
PR: 162728 Submitted by: Armin Pirkovitsch <armin@frozen-zone.org> Feature safe: yes
Notes
Notes: svn path=/head/; revision=286503
Diffstat (limited to 'graphics/podofo')
-rw-r--r--graphics/podofo/Makefile9
-rw-r--r--graphics/podofo/distinfo4
-rw-r--r--graphics/podofo/files/patch-CMakeLists.txt11
-rw-r--r--graphics/podofo/files/patch-src_CMakeLists.txt22
-rw-r--r--graphics/podofo/pkg-plist194
5 files changed, 144 insertions, 96 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index b0bce2513962..ef080bde68b5 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= podofo
-PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTVERSION= 0.9.1
CATEGORIES= graphics print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -29,6 +28,12 @@ CMAKE_ARGS+= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
.include <bsd.port.pre.mk>
+MAN1= podofobox.1 podofoxmp.1 podofouncompress.1 podofomerge.1 \
+ podofoimgextract.1 podofoimg2pdf.1 podofotxtextract.1 \
+ podofoencrypt.1 podofocrop.1 podofopdfinfo.1 podofoimpose.1 \
+ podofoincrementalupdates.1 podofocountpages.1 podofopages.1 \
+ podofotxt2pdf.1
+
.if !defined(WITHOUT_JPEG) || exists(${LOCALBASE}/lib/libjpeg.so)
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
.endif
diff --git a/graphics/podofo/distinfo b/graphics/podofo/distinfo
index b95aa3b97362..8c9de7280b05 100644
--- a/graphics/podofo/distinfo
+++ b/graphics/podofo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (podofo-0.7.0.tar.gz) = 1e57e0b2c0039519e9542302f358bf8d9b8de69ad9b19a030123802d1b2dedc2
-SIZE (podofo-0.7.0.tar.gz) = 1117023
+SHA256 (podofo-0.9.1.tar.gz) = 7b969de0b6c584358f26fc5de23cff0378f46023e678fe058efbb64003ec9745
+SIZE (podofo-0.9.1.tar.gz) = 1080079
diff --git a/graphics/podofo/files/patch-CMakeLists.txt b/graphics/podofo/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1914a35bdf71
--- /dev/null
+++ b/graphics/podofo/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2011-11-20 12:06:58.920967434 +0100
++++ CMakeLists.txt 2011-11-20 12:07:10.055968111 +0100
+@@ -485,7 +485,7 @@
+ #
+ # Setup directories we will need
+ #
+-SET(MANDIR "share/man/")
++SET(MANDIR "man/")
+
+ # Create the config file. It'll be appended to as the subdirs run though
+ # then dependency information will be written to it at the end of the
diff --git a/graphics/podofo/files/patch-src_CMakeLists.txt b/graphics/podofo/files/patch-src_CMakeLists.txt
index b17e52a87307..7118abbdc288 100644
--- a/graphics/podofo/files/patch-src_CMakeLists.txt
+++ b/graphics/podofo/files/patch-src_CMakeLists.txt
@@ -1,24 +1,24 @@
---- src/CMakeLists.txt.orig 2008-11-23 12:37:23.000000000 +0300
-+++ src/CMakeLists.txt 2009-10-17 14:43:48.000000000 +0400
-@@ -199,8 +199,8 @@
- ADD_LIBRARY(podofo_static STATIC ${PODOFO_SOURCES})
+--- src/CMakeLists.txt.orig 2011-03-08 20:21:54.000000000 +0100
++++ src/CMakeLists.txt 2011-11-19 18:56:46.575967234 +0100
+@@ -252,8 +252,8 @@
+ ADD_LIBRARY(podofo_static STATIC ${PODOFO_BASE_SOURCES} ${PODOFO_DOC_SOURCES})
TARGET_LINK_LIBRARIES(podofo_static ${PODOFO_LIB_DEPENDS})
SET_TARGET_PROPERTIES(podofo_static PROPERTIES
-- VERSION "0.6.99"
-- SOVERSION "0.6.99"
+- VERSION "${PODOFO_LIBVERSION}"
+- SOVERSION "${PODOFO_SOVERSION}"
+ VERSION "0"
+ SOVERSION "0"
CLEAN_DIRECT_OUTPUT 1
OUTPUT_NAME "podofo"
- )
-@@ -222,8 +222,8 @@
+ COMPILE_FLAGS "-DBUILDING_PODOFO"
+@@ -276,8 +276,8 @@
# Visual Studio, since it produces invalid warnings about STL
# use.
SET_TARGET_PROPERTIES(podofo_shared PROPERTIES
-- VERSION "0.6.99"
-- SOVERSION "0.6.99"
+- VERSION "${PODOFO_LIBVERSION}"
+- SOVERSION "${PODOFO_SOVERSION}"
+ VERSION "0"
+ SOVERSION "0"
CLEAN_DIRECT_OUTPUT 1
OUTPUT_NAME "podofo"
- )
+ COMPILE_FLAGS "-DBUILDING_PODOFO"
diff --git a/graphics/podofo/pkg-plist b/graphics/podofo/pkg-plist
index d9e92cfcf66f..97b4b54b8bd0 100644
--- a/graphics/podofo/pkg-plist
+++ b/graphics/podofo/pkg-plist
@@ -1,93 +1,125 @@
+bin/podofobox
+bin/podofocolor
+bin/podofocountpages
+bin/podofocrop
bin/podofoencrypt
+bin/podofogc
+bin/podofoimg2pdf
bin/podofoimgextract
bin/podofoimpose
+bin/podofoincrementalupdates
bin/podofomerge
+bin/podofopages
bin/podofopdfinfo
bin/podofotxt2pdf
bin/podofotxtextract
bin/podofouncompress
-include/podofo/Pdf3rdPtyForwardDecl.h
-include/podofo/PdfAcroForm.h
-include/podofo/PdfAction.h
-include/podofo/PdfAnnotation.h
-include/podofo/PdfArray.h
-include/podofo/PdfCanvas.h
-include/podofo/PdfColor.h
-include/podofo/PdfContents.h
-include/podofo/PdfContentsTokenizer.h
-include/podofo/PdfData.h
-include/podofo/PdfDataType.h
-include/podofo/PdfDate.h
-include/podofo/PdfDefines.h
-include/podofo/PdfDestination.h
-include/podofo/PdfDictionary.h
-include/podofo/PdfDifferenceEncoding.h
-include/podofo/PdfDocument.h
-include/podofo/PdfElement.h
-include/podofo/PdfEncoding.h
-include/podofo/PdfEncodingFactory.h
-include/podofo/PdfEncrypt.h
-include/podofo/PdfError.h
-include/podofo/PdfExtGState.h
-include/podofo/PdfField.h
-include/podofo/PdfFileSpec.h
-include/podofo/PdfFileStream.h
-include/podofo/PdfFilter.h
-include/podofo/PdfFiltersPrivate.h
-include/podofo/PdfFont.h
-include/podofo/PdfFontCID.h
-include/podofo/PdfFontCache.h
-include/podofo/PdfFontFactory.h
-include/podofo/PdfFontMetrics.h
-include/podofo/PdfFontSimple.h
-include/podofo/PdfFontTTFSubset.h
-include/podofo/PdfFontTrueType.h
-include/podofo/PdfFontType1.h
-include/podofo/PdfFunction.h
-include/podofo/PdfHintStream.h
-include/podofo/PdfImage.h
-include/podofo/PdfImmediateWriter.h
-include/podofo/PdfInfo.h
-include/podofo/PdfInputDevice.h
-include/podofo/PdfInputStream.h
-include/podofo/PdfLocale.h
-include/podofo/PdfMemDocument.h
-include/podofo/PdfMemStream.h
-include/podofo/PdfName.h
-include/podofo/PdfNamesTree.h
-include/podofo/PdfObject.h
-include/podofo/PdfOutlines.h
-include/podofo/PdfOutputDevice.h
-include/podofo/PdfOutputStream.h
-include/podofo/PdfPage.h
-include/podofo/PdfPagesTree.h
-include/podofo/PdfPainter.h
-include/podofo/PdfPainterMM.h
-include/podofo/PdfParser.h
-include/podofo/PdfParserObject.h
-include/podofo/PdfRect.h
-include/podofo/PdfRefCountedBuffer.h
-include/podofo/PdfRefCountedInputDevice.h
-include/podofo/PdfReference.h
-include/podofo/PdfRijndael.h
-include/podofo/PdfShadingPattern.h
-include/podofo/PdfStream.h
-include/podofo/PdfStreamedDocument.h
-include/podofo/PdfString.h
-include/podofo/PdfTable.h
-include/podofo/PdfTokenizer.h
-include/podofo/PdfVariant.h
-include/podofo/PdfVecObjects.h
-include/podofo/PdfVersion.h
-include/podofo/PdfWriter.h
-include/podofo/PdfXObject.h
-include/podofo/PdfXRef.h
-include/podofo/PdfXRefStream.h
+bin/podofoxmp
+include/podofo/doc/PdfDifferenceEncoding.h
+include/podofo/doc/PdfFontTTFSubset.h
+include/podofo/doc/PdfFontFactoryBase14Data.h
+include/podofo/doc/PdfAnnotation.h
+include/podofo/doc/PdfHintStream.h
+include/podofo/doc/PdfFunction.h
+include/podofo/doc/PdfXObject.h
+include/podofo/doc/PdfInfo.h
+include/podofo/doc/PdfPagesTreeCache.h
+include/podofo/doc/PdfFontFactory.h
+include/podofo/doc/PdfImage.h
+include/podofo/doc/PdfFileSpec.h
+include/podofo/doc/PdfDestination.h
+include/podofo/doc/PdfEncodingObjectFactory.h
+include/podofo/doc/PdfSignOutputDevice.h
+include/podofo/doc/PdfShadingPattern.h
+include/podofo/doc/PdfDocument.h
+include/podofo/doc/PdfIdentityEncoding.h
+include/podofo/doc/PdfField.h
+include/podofo/doc/PdfFontCache.h
+include/podofo/doc/PdfPage.h
+include/podofo/doc/PdfNamesTree.h
+include/podofo/doc/PdfPagesTree.h
+include/podofo/doc/PdfAcroForm.h
+include/podofo/doc/PdfFontMetricsObject.h
+include/podofo/doc/PdfFontMetrics.h
+include/podofo/doc/PdfPainterMM.h
+include/podofo/doc/PdfTable.h
+include/podofo/doc/PdfSignatureField.h
+include/podofo/doc/PdfElement.h
+include/podofo/doc/PdfFontCID.h
+include/podofo/doc/PdfFontTrueType.h
+include/podofo/doc/PdfOutlines.h
+include/podofo/doc/PdfFontMetricsBase14.h
+include/podofo/doc/PdfFontType1Base14.h
+include/podofo/doc/PdfExtGState.h
+include/podofo/doc/PdfFontMetricsFreetype.h
+include/podofo/doc/PdfStreamedDocument.h
+include/podofo/doc/PdfFont.h
+include/podofo/doc/PdfFontType1.h
+include/podofo/doc/PdfFontSimple.h
+include/podofo/doc/PdfAction.h
+include/podofo/doc/PdfMemDocument.h
+include/podofo/doc/PdfContents.h
+include/podofo/doc/PdfPainter.h
+include/podofo/base/PdfCompilerCompatPrivate.h
+include/podofo/base/PdfFiltersPrivate.h
+include/podofo/base/PdfOutputDevice.h
+include/podofo/base/PdfRect.h
+include/podofo/base/PdfObject.h
+include/podofo/base/PdfEncodingFactory.h
+include/podofo/base/PdfEncrypt.h
+include/podofo/base/PdfWriter.h
+include/podofo/base/PdfError.h
+include/podofo/base/PdfArray.h
+include/podofo/base/PdfMemoryManagement.h
+include/podofo/base/PdfLocale.h
+include/podofo/base/PdfCompilerCompat.h
+include/podofo/base/PdfOutputStream.h
+include/podofo/base/PdfColor.h
+include/podofo/base/PdfContentsTokenizer.h
+include/podofo/base/PdfFilter.h
+include/podofo/base/PdfDefines.h
+include/podofo/base/podofo_config.h
+include/podofo/base/PdfTokenizer.h
+include/podofo/base/podofoapi.h
+include/podofo/base/PdfVecObjects.h
+include/podofo/base/PdfRefCountedBuffer.h
+include/podofo/base/PdfData.h
+include/podofo/base/PdfReference.h
+include/podofo/base/PdfXRef.h
+include/podofo/base/PdfCanvas.h
+include/podofo/base/PdfObjectStreamParserObject.h
+include/podofo/base/PdfDate.h
+include/podofo/base/PdfInputDevice.h
+include/podofo/base/PdfDataType.h
+include/podofo/base/PdfVersion.h
+include/podofo/base/PdfXRefStreamParserObject.h
+include/podofo/base/PdfImmediateWriter.h
+include/podofo/base/PdfDictionary.h
+include/podofo/base/PdfParser.h
+include/podofo/base/PdfXRefStream.h
+include/podofo/base/PdfDefinesPrivate.h
+include/podofo/base/util/PdfMutexWrapper.h
+include/podofo/base/util/PdfMutexImpl_win32.h
+include/podofo/base/util/PdfMutexImpl_pthread.h
+include/podofo/base/util/PdfMutexImpl_noop.h
+include/podofo/base/util/PdfMutex.h
+include/podofo/base/PdfName.h
+include/podofo/base/Pdf3rdPtyForwardDecl.h
+include/podofo/base/PdfRefCountedInputDevice.h
+include/podofo/base/PdfInputStream.h
+include/podofo/base/PdfString.h
+include/podofo/base/PdfVariant.h
+include/podofo/base/PdfEncoding.h
+include/podofo/base/PdfParserObject.h
+include/podofo/base/PdfRijndael.h
+include/podofo/base/PdfMemStream.h
+include/podofo/base/PdfFileStream.h
+include/podofo/base/PdfStream.h
include/podofo/podofo.h
-include/podofo/podofoapi.h
-include/podofo/util/PdfMutex.h
-include/podofo/util/PdfMutexWrapper.h
+include/podofo/podofo-base.h
lib/libpodofo.so.0
lib/libpodofo.so
-@dirrm include/podofo/util
+@dirrm include/podofo/base/util
+@dirrm include/podofo/base
+@dirrm include/podofo/doc
@dirrm include/podofo