aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-11-25 12:55:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-11-25 12:55:00 +0000
commite527c1b2f65c583b01144da031c2a4451391e7ea (patch)
treed8669d516b50403a0ddb48ea398c715cf90c53a2 /graphics/poppler
parent2a4f536a634638531a27f2bfe8222e574549f60c (diff)
Notes
Diffstat (limited to 'graphics/poppler')
-rw-r--r--graphics/poppler/Makefile46
-rw-r--r--graphics/poppler/distinfo4
-rw-r--r--graphics/poppler/files/patch-qt5_Makefile.in11
-rw-r--r--graphics/poppler/files/patch-qt5_src_Makefile.in20
-rw-r--r--graphics/poppler/files/patch-utils_Makefile.in10
-rw-r--r--graphics/poppler/pkg-plist19
6 files changed, 72 insertions, 38 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index c3f0ab2d107f..58732ef9a184 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -3,8 +3,8 @@
# $MCom: ports/graphics/poppler/Makefile,v 1.84 2013/03/12 14:53:49 kwm Exp $
PORTNAME= poppler
-PORTVERSION= 0.24.5
-PORTREVISION?= 4
+PORTVERSION= 0.26.3
+PORTREVISION?= 0
CATEGORIES= graphics print
MASTER_SITES= http://poppler.freedesktop.org/
@@ -12,30 +12,37 @@ MAINTAINER?= gnome@FreeBSD.org
COMMENT?= PDF rendering library
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- liblcms2.so:${PORTSDIR}/graphics/lcms2
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= poppler-data>0:${PORTSDIR}/graphics/poppler-data
-USES= gmake libtool:keepla pathfix pkgconfig tar:xz
+USES= gmake libtool pathfix pkgconfig tar:xz
USE_GNOME= libxml2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-zlib \
--enable-xpdf-headers \
--disable-gtk-test \
- --with-html-dir=${DOCSDIR}
+ --without-html-dir \
+ --disable-static
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
# see https://bugs.freedesktop.org/show_bug.cgi?id=72499
CPPFLAGS+= -D__LONG_LONG_SUPPORTED
+INSTALL_TARGET= install-strip
+
.if !defined(SLAVEPORT)
PORTSCOUT= limitw:1,even
-OPTIONS_DEFINE= CAIRO OPENJPEG
+OPTIONS_DEFINE= CAIRO CURL OPENJPEG
OPTIONS_DEFAULT=CAIRO OPENJPEG
USES+= iconv
@@ -48,7 +55,7 @@ PORTSCOUT= ignore:1
LIB_DEPENDS+= libpoppler.so:${PORTSDIR}/graphics/poppler
.if ${SLAVEPORT}==glib
-CONFIGURE_ARGS+=--enable-poppler-glib
+CONFIGURE_ARGS+=--enable-poppler-glib --enable-introspection=yes
USE_GNOME+= cairo gnomehier glib20 introspection:build
BUILD_WRKSRC= ${WRKSRC}/glib
INSTALL_WRKSRC= ${WRKSRC}/glib
@@ -58,7 +65,7 @@ CONFIGURE_ARGS+=--disable-poppler-glib
.if ${SLAVEPORT}==qt4
CONFIGURE_ARGS+=--enable-poppler-qt4
-CONFIGURE_ENV+= ac_cv_prog_MOCQT4=${LOCALBASE}/bin/moc-qt4
+CONFIGURE_ENV+= MOCQT4=${MOC}
USE_QT4= gui corelib xml qtestlib moc_build
BUILD_WRKSRC= ${WRKSRC}/qt4
INSTALL_WRKSRC= ${WRKSRC}/qt4
@@ -66,11 +73,10 @@ INSTALL_WRKSRC= ${WRKSRC}/qt4
CONFIGURE_ARGS+=--disable-poppler-qt4
.endif
-# needs checking when Qt5 is available
.if ${SLAVEPORT}==qt5
CONFIGURE_ARGS+=--enable-poppler-qt5
-CONFIGURE_ENV+= ac_cv_prog_MOCQT4=${LOCALBASE}/bin/moc-qt5
-USE_QT5= gui corelib xml qtestlib moc_build
+CONFIGURE_ENV+= MOCQT5=${MOC}
+USE_QT5= core gui widgets xml buildtools_build testlib_build
BUILD_WRKSRC= ${WRKSRC}/qt5
INSTALL_WRKSRC= ${WRKSRC}/qt5
.else
@@ -100,6 +106,15 @@ CONFIGURE_ARGS+=--disable-cairo-output
PLIST_SUB+= CAIRO="@comment "
.endif
+.if ${PORT_OPTIONS:MCURL}
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--enable-libcurl
+PLIST_SUB+= CURL=""
+.else
+CONFIGURE_ARGS+=--disable-libcurl
+PLIST_SUB+= CURL="@comment "
+.endif
+
.if ${PORT_OPTIONS:MOPENJPEG}
CONFIGURE_ARGS+=--enable-libopenjpeg
LIB_DEPENDS+= libopenjpeg.so:${PORTSDIR}/graphics/openjpeg15
@@ -111,14 +126,6 @@ CONFIGURE_ARGS+=--disable-libopenjpeg
post-patch:
@${REINPLACE_CMD} '/CXXFLAGS.*-ansi/d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-fno-check-new||g' ${WRKSRC}/configure
-.if defined(SLAVEPORT) && ${SLAVEPORT}==qt4
- @${REINPLACE_CMD} -e 's|MOCQT4=`.*|MOCQT4="${LOCALBASE}/bin/moc-qt4"|' \
- ${WRKSRC}/configure
-.endif
-.if defined(SLAVEPORT) && ${SLAVEPORT}==qt5
- @${REINPLACE_CMD} -e 's|MOCQT5=`.*|MOCQT5="${LOCALBASE}/bin/moc-qt5"|' \
- ${WRKSRC}/configure
-.endif
post-install:
.if defined(SLAVEPORT)
@@ -133,6 +140,5 @@ post-install:
${STAGEDIR}${PREFIX}/libdata/pkgconfig
. endif
.endif
- -@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpoppler*.so.*
.include <bsd.port.mk>
diff --git a/graphics/poppler/distinfo b/graphics/poppler/distinfo
index f9205d7462b0..e9365bd4c3bd 100644
--- a/graphics/poppler/distinfo
+++ b/graphics/poppler/distinfo
@@ -1,2 +1,2 @@
-SHA256 (poppler-0.24.5.tar.xz) = a2654910100c923c44e366242495e226db2798254f2fa2781138867348759f84
-SIZE (poppler-0.24.5.tar.xz) = 1512476
+SHA256 (poppler-0.26.3.tar.xz) = 88cb1af3574f861bc08853a681be97ae79bf5302782fbac803f877b879a642b1
+SIZE (poppler-0.26.3.tar.xz) = 1593760
diff --git a/graphics/poppler/files/patch-qt5_Makefile.in b/graphics/poppler/files/patch-qt5_Makefile.in
new file mode 100644
index 000000000000..f0b38d172a29
--- /dev/null
+++ b/graphics/poppler/files/patch-qt5_Makefile.in
@@ -0,0 +1,11 @@
+--- qt5/Makefile.in.orig 2014-11-25 11:49:19 UTC
++++ qt5/Makefile.in
+@@ -384,7 +384,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ win32_libs = @win32_libs@
+-SUBDIRS = src tests demos
++SUBDIRS = src
+ all: all-recursive
+
+ .SUFFIXES:
diff --git a/graphics/poppler/files/patch-qt5_src_Makefile.in b/graphics/poppler/files/patch-qt5_src_Makefile.in
new file mode 100644
index 000000000000..1b1fb04a1bb9
--- /dev/null
+++ b/graphics/poppler/files/patch-qt5_src_Makefile.in
@@ -0,0 +1,20 @@
+--- qt5/src/Makefile.in.orig 2014-11-25 11:49:19 UTC
++++ qt5/src/Makefile.in
+@@ -129,7 +129,7 @@ am__installdirs = "$(DESTDIR)$(libdir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+ libpoppler_qt5_la_DEPENDENCIES = \
+- $(top_builddir)/poppler/libpoppler.la $(am__DEPENDENCIES_1)
++ $(am__DEPENDENCIES_1)
+ am_libpoppler_qt5_la_OBJECTS = libpoppler_qt5_la-poppler-document.lo \
+ libpoppler_qt5_la-poppler-page.lo \
+ libpoppler_qt5_la-poppler-fontinfo.lo \
+@@ -505,7 +505,7 @@ libpoppler_qt5_la_CXXFLAGS = \
+ -Dpoppler_qt5_EXPORTS -fPIC
+
+ libpoppler_qt5_la_LIBADD = \
+- $(top_builddir)/poppler/libpoppler.la \
++ -lpoppler \
+ $(POPPLER_QT5_LIBS)
+
+ libpoppler_qt5_la_LDFLAGS = -version-info 2:0:1 @create_shared_lib@ @auto_import_flags@
diff --git a/graphics/poppler/files/patch-utils_Makefile.in b/graphics/poppler/files/patch-utils_Makefile.in
index 735c224944f5..02dfbc852675 100644
--- a/graphics/poppler/files/patch-utils_Makefile.in
+++ b/graphics/poppler/files/patch-utils_Makefile.in
@@ -1,5 +1,5 @@
---- utils/Makefile.in.orig 2013-12-02 19:00:03.000000000 +0100
-+++ utils/Makefile.in 2013-12-02 19:01:25.000000000 +0100
+--- utils/Makefile.in.orig 2014-11-25 11:49:19 UTC
++++ utils/Makefile.in
@@ -111,7 +111,7 @@
am_pdfdetach_OBJECTS = pdfdetach.$(OBJEXT) $(am__objects_1)
pdfdetach_OBJECTS = $(am_pdfdetach_OBJECTS)
@@ -16,13 +16,13 @@
-pdffonts_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la
+pdffonts_DEPENDENCIES =
am_pdfimages_OBJECTS = pdfimages.$(OBJEXT) ImageOutputDev.$(OBJEXT) \
- $(am__objects_1)
+ JSInfo.$(OBJEXT) $(am__objects_1)
pdfimages_OBJECTS = $(am_pdfimages_OBJECTS)
pdfimages_LDADD = $(LDADD)
-pdfimages_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la
+pdfimages_DEPENDENCIES =
am_pdfinfo_OBJECTS = pdfinfo.$(OBJEXT) printencodings.$(OBJEXT) \
- $(am__objects_1)
+ JSInfo.$(OBJEXT) $(am__objects_1)
pdfinfo_OBJECTS = $(am_pdfinfo_OBJECTS)
pdfinfo_LDADD = $(LDADD)
-pdfinfo_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la
@@ -52,7 +52,7 @@
pdftohtml_OBJECTS = $(am_pdftohtml_OBJECTS)
pdftohtml_LDADD = $(LDADD)
-pdftohtml_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la
-+pdftohtml_DEPENDENCIES =
++pdftohtml_DEPENDENCIES =
pdftohtml_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CXX $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CXXLD) $(pdftohtml_CXXFLAGS) \
$(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
diff --git a/graphics/poppler/pkg-plist b/graphics/poppler/pkg-plist
index bbf394ff7ef7..2bcf0c196b7b 100644
--- a/graphics/poppler/pkg-plist
+++ b/graphics/poppler/pkg-plist
@@ -8,6 +8,8 @@ include/poppler/Catalog.h
include/poppler/CharCodeToUnicode.h
include/poppler/CharTypes.h
include/poppler/CompactFontTables.h
+%%CURL%%include/poppler/CurlCachedFile.h
+%%CURL%%include/poppler/CurlPDFDocBuilder.h
include/poppler/DateInfo.h
include/poppler/Decrypt.h
include/poppler/Dict.h
@@ -30,6 +32,7 @@ include/poppler/Lexer.h
include/poppler/Linearization.h
include/poppler/Link.h
include/poppler/LocalPDFDocBuilder.h
+include/poppler/MarkedContentOutputDev.h
include/poppler/Movie.h
include/poppler/NameToCharCode.h
include/poppler/NameToUnicodeTable.h
@@ -57,6 +60,8 @@ include/poppler/StdinCachedFile.h
include/poppler/StdinPDFDocBuilder.h
include/poppler/Stream-CCITT.h
include/poppler/Stream.h
+include/poppler/StructElement.h
+include/poppler/StructTreeRoot.h
include/poppler/TextOutputDev.h
include/poppler/UTF.h
include/poppler/UTF8.h
@@ -95,6 +100,7 @@ include/poppler/goo/GooString.h
include/poppler/goo/GooTimer.h
include/poppler/goo/ImgWriter.h
include/poppler/goo/JpegWriter.h
+include/poppler/goo/NetPBMWriter.h
include/poppler/goo/PNGWriter.h
include/poppler/goo/TiffWriter.h
include/poppler/goo/gfile.h
@@ -126,22 +132,13 @@ include/poppler/splash/SplashT1FontFile.h
include/poppler/splash/SplashTypes.h
include/poppler/splash/SplashXPath.h
include/poppler/splash/SplashXPathScanner.h
-lib/libpoppler-cpp.a
-lib/libpoppler-cpp.la
lib/libpoppler-cpp.so
lib/libpoppler-cpp.so.0
lib/libpoppler-cpp.so.0.2.0
-lib/libpoppler.a
-lib/libpoppler.la
lib/libpoppler.so
-lib/libpoppler.so.44
-lib/libpoppler.so.44.0.0
+lib/libpoppler.so.46
+lib/libpoppler.so.46.0.0
%%CAIRO%%libdata/pkgconfig/poppler-cairo.pc
libdata/pkgconfig/poppler-cpp.pc
libdata/pkgconfig/poppler-splash.pc
libdata/pkgconfig/poppler.pc
-@dirrm include/poppler/splash
-@dirrm include/poppler/goo
-@dirrm include/poppler/fofi
-@dirrm include/poppler/cpp
-@dirrm include/poppler