aboutsummaryrefslogtreecommitdiff
path: root/graphics/pornview
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/pornview
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'graphics/pornview')
-rw-r--r--graphics/pornview/Makefile7
-rw-r--r--graphics/pornview/files/patch-pixbuf_utils.c19
2 files changed, 23 insertions, 3 deletions
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index eec21308517f..bdadf926e4ae 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pornview
PORTVERSION= 0.2.0.p.1
-PORTREVISION= 25
+PORTREVISION= 26
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/OldFiles
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p./pre/}
@@ -15,8 +15,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p./pre/}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= PornView is an image viewer/manager
-LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif
-LIB_DEPENDS+= xcb-render-util:${PORTSDIR}/x11/xcb-util-renderutil
+LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif \
+ png15:${PORTSDIR}/graphics/png \
+ xcb-render-util:${PORTSDIR}/x11/xcb-util-renderutil
USE_XORG= x11 xi xext xinerama
USE_GNOME= gtk20
diff --git a/graphics/pornview/files/patch-pixbuf_utils.c b/graphics/pornview/files/patch-pixbuf_utils.c
new file mode 100644
index 000000000000..605265e93a68
--- /dev/null
+++ b/graphics/pornview/files/patch-pixbuf_utils.c
@@ -0,0 +1,19 @@
+--- src/support/pixbuf_utils.c.orig 2002-12-13 13:29:28.000000000 +0100
++++ src/support/pixbuf_utils.c 2012-05-09 12:38:26.000000000 +0200
+@@ -18,6 +18,7 @@
+ #endif
+
+ #include <png.h>
++#include <pngpriv.h>
+ #include <gtk/gtk.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+
+@@ -60,7 +61,7 @@
+ return FALSE;
+ }
+
+- if (setjmp (png_ptr->jmpbuf))
++ if (setjmp (png_jmpbuf(png_ptr)))
+ {
+ png_destroy_write_struct (&png_ptr, &info_ptr);
+ fclose (handle);