aboutsummaryrefslogtreecommitdiff
path: root/graphics/potracegui/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2005-03-04 10:59:27 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2005-03-04 10:59:27 +0000
commitdfe4984ca786bf71a10a04b833ccf6fa4ca2e1ac (patch)
treef27345b4b93632d48ebc270e57704f0307969cde /graphics/potracegui/Makefile
parent1b98492dc3dc16d4a716a49e1b5a400162af1ee1 (diff)
downloadports-dfe4984ca786bf71a10a04b833ccf6fa4ca2e1ac.tar.gz
ports-dfe4984ca786bf71a10a04b833ccf6fa4ca2e1ac.zip
Notes
Diffstat (limited to 'graphics/potracegui/Makefile')
-rw-r--r--graphics/potracegui/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/graphics/potracegui/Makefile b/graphics/potracegui/Makefile
index 46ed0d4d2f10..34e366eff90d 100644
--- a/graphics/potracegui/Makefile
+++ b/graphics/potracegui/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= potracegui
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,8 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= markus@FreeBSD.org
COMMENT= GUI for potrace, a program for tracing bitmap images
-RUN_DEPENDS= potrace:${PORTSDIR}/graphics/potrace
-
EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
USE_BZIP2= yes
@@ -24,10 +22,20 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-post-extract:
- @${TOUCH} ${WRKSRC}/config.h.in
+OPTIONS= POTRACE "potrace backend" on \
+ AUTOTRACE "Autotrace backend" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_POTRACE)
+RUN_DEPENDS+= potrace:${PORTSDIR}/graphics/potrace
+.endif
+
+.if !defined(WITHOUT_AUTOTRACE)
+RUN_DEPENDS+= autotrace:${PORTSDIR}/graphics/autotrace
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>