aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray-meta
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-06-20 22:27:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-06-20 22:27:00 +0000
commit01a78a83b15639d4d1995004312f6b0c7a099c03 (patch)
tree6cf3a9a7c501d5472730e876256e55fe6df8d34a /graphics/povray-meta
parent87eb5a13e56fc2e07cd2a09c43d361d62c374b22 (diff)
downloadports-01a78a83b15639d4d1995004312f6b0c7a099c03.tar.gz
ports-01a78a83b15639d4d1995004312f6b0c7a099c03.zip
Notes
Diffstat (limited to 'graphics/povray-meta')
-rw-r--r--graphics/povray-meta/Makefile63
-rw-r--r--graphics/povray-meta/pkg-descr1
2 files changed, 64 insertions, 0 deletions
diff --git a/graphics/povray-meta/Makefile b/graphics/povray-meta/Makefile
new file mode 100644
index 000000000000..9890f20d96d9
--- /dev/null
+++ b/graphics/povray-meta/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: povray-meta
+# Date created: 2011-06-19
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= povray-meta
+PORTVERSION= 0.1
+CATEGORIES= graphics
+MASTER_SITES= #
+DISTFILES= #
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Meta port for all povray ports
+
+NO_BUILD= yes
+PLIST_FILES= bin/povray
+
+POV_VERSIONS_ALL= 31 36 37
+#By default only the following version will be installed and
+#link bin/povray -> bin/povray${DEFAULT_VER} will be created.
+DEFAULT_VER?= 36
+#Additional version can be installed by defining WITH_POVRAY${ver}.
+#To change version linked by default define WITH_DEFAULT${ver}.
+#Please, note that only one of WITH_DEFAULT* can be set at once.
+
+OPT_POVRAY${DEFAULT_VER}= on
+OPT_DEFAULT${DEFAULT_VER}= on
+
+.for ver in ${POV_VERSIONS_ALL}
+POVRAY${ver}_BIN= ${LOCALBASE}/bin/povray${ver}
+POVRAY${ver}_PORT= graphics/povray${ver}
+OPT_POVRAY${ver}?= off
+OPT_DEFAULT${ver}?= off
+OPTIONS+= POVRAY${ver} "Install graphics/povray${ver}" ${OPT_POVRAY${ver}}
+OPTIONS+= DEFAULT${ver} "Create link bin/povray -> bin/povray${ver}" ${OPT_DEFAULT${ver}}
+.endfor
+
+.include <bsd.port.options.mk>
+
+.for ver in ${POV_VERSIONS_ALL}
+. if defined(WITH_DEFAULT${ver})
+WITH_POVRAY${ver}= yes
+. if defined(POV_VERSION)
+IGNORE= can't be build: only one default povray can be chosen
+. else
+POV_VERSION= ${ver}
+. endif
+. endif
+. if defined(WITH_POVRAY${ver})
+RUN_DEPENDS+= ${POVRAY${ver}_BIN}:${PORTSDIR}/${POVRAY${ver}_PORT}
+. endif
+.endfor
+
+.if !defined(POV_VERSION)
+IGNORE= can't be build: one default povray must be chosen
+.endif
+
+do-install:
+ ${LN} -s ${POVRAY${POV_VERSION}_BIN} ${PREFIX}/bin/povray
+
+.include <bsd.port.mk>
diff --git a/graphics/povray-meta/pkg-descr b/graphics/povray-meta/pkg-descr
new file mode 100644
index 000000000000..e967414195f0
--- /dev/null
+++ b/graphics/povray-meta/pkg-descr
@@ -0,0 +1 @@
+Meta port for all povray ports.