aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-03-15 05:54:21 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-03-15 05:54:21 +0000
commitb1f6ab6b4d72e15580db8eef84072c45ae7371ee (patch)
treeb33077e83d0daa23afe8316ea795e7ccf0cd505f /graphics/povray/Makefile
parente2a7e42e4fa303991f89f6c2500fd74c3c26179b (diff)
downloadports-b1f6ab6b4d72e15580db8eef84072c45ae7371ee.tar.gz
ports-b1f6ab6b4d72e15580db8eef84072c45ae7371ee.zip
Notes
Diffstat (limited to 'graphics/povray/Makefile')
-rw-r--r--graphics/povray/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/graphics/povray/Makefile b/graphics/povray/Makefile
index a33814846e82..d9c74fd0dc59 100644
--- a/graphics/povray/Makefile
+++ b/graphics/povray/Makefile
@@ -23,21 +23,24 @@ BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
jpeg:${PORTSDIR}/graphics/jpeg
-.if (${MACHINE_ARCH} == "i386")
-LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
-.endif
+USE_BZIP2= yes
USE_XLIB= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:259
LATEST_LINK= ${PORTNAME}36
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == "i386")
+LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
+.endif
+
.if defined(WITH_OPTIMIZED_FLAGS)
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
-.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
+.if (${ARCH} == "i386" && !${ARCH} == "amd64" )
CFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
CXXFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
@@ -59,10 +62,8 @@ CONFIGURE_ARGS= --x-includes="${X11BASE}/include" --includedir=${LOCALBASE} \
MAN1= povray.1
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} < 500000
-BROKEN= "Does not build on 4.x"
+BROKEN= Does not build on 4.x
.endif
post-patch: