aboutsummaryrefslogtreecommitdiff
path: root/graphics/proj/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2001-11-15 14:53:51 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2001-11-15 14:53:51 +0000
commit9779d111d6f9d568ce12320cfecbdc56555d675a (patch)
tree39cb22e36a1f3d985cd4b06804f5e32c2fb8ba65 /graphics/proj/Makefile
parent9555aa91b9b4bb33afba7eb0d41a4a94ddfc746e (diff)
downloadports-9779d111d6f9d568ce12320cfecbdc56555d675a.tar.gz
ports-9779d111d6f9d568ce12320cfecbdc56555d675a.zip
Notes
Diffstat (limited to 'graphics/proj/Makefile')
-rw-r--r--graphics/proj/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/proj/Makefile b/graphics/proj/Makefile
new file mode 100644
index 000000000000..43ffe1dd5dd4
--- /dev/null
+++ b/graphics/proj/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: proj
+# Date created: 15 November 2001
+# Whom: jedgar@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= proj
+PORTVERSION= 4.4.4
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.remotesensing.org/pub/proj/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${NADFILES}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= jedgar@FreeBSD.org
+
+NADFILES= proj-nad27-1.1.tar.gz
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= cs2cs.1 geod.1 nad2nad.1 proj.1
+MAN3= pj_init.3
+
+post-extract:
+.for file in ${NADFILES}
+ @cd ${WRKSRC}/nad && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${file} ${EXTRACT_AFTER_ARGS}
+.endfor
+
+.include <bsd.port.mk>