aboutsummaryrefslogtreecommitdiff
path: root/graphics/projectm-libvisual
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-14 03:27:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-14 03:27:50 +0000
commit742fdd70775728ede5b9dbedd8e49a911909746e (patch)
treebd906b94afe2e724ebc2d5f741aee79d43ec41e6 /graphics/projectm-libvisual
parent359ee6f331dc34ff5978e1a6616a6eaf97395940 (diff)
downloadports-742fdd70775728ede5b9dbedd8e49a911909746e.tar.gz
ports-742fdd70775728ede5b9dbedd8e49a911909746e.zip
Notes
Diffstat (limited to 'graphics/projectm-libvisual')
-rw-r--r--graphics/projectm-libvisual/Makefile41
-rw-r--r--graphics/projectm-libvisual/distinfo2
-rw-r--r--graphics/projectm-libvisual/files/patch-actor_projectM-cpp18
-rw-r--r--graphics/projectm-libvisual/pkg-descr4
4 files changed, 65 insertions, 0 deletions
diff --git a/graphics/projectm-libvisual/Makefile b/graphics/projectm-libvisual/Makefile
new file mode 100644
index 000000000000..978d30205b4e
--- /dev/null
+++ b/graphics/projectm-libvisual/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: projectM-libvisual
+# Date created: 5 February 2010
+# Whom: utisoft@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= projectM-libvisual
+PORTVERSION= 2.0.1
+CATEGORIES= graphics audio
+MASTER_SITES= SF/${PORTNAME:L:S/-libvisual//}/${PORTVERSION}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}-Source
+
+MAINTAINER= utisoft@gmail.com
+COMMENT= Allows projectM to be used with libvisual
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= projectM:${PORTSDIR}/graphics/libprojectm \
+ visual-${LIBVISUAL_VER}:${PORTSDIR}/graphics/libvisual${LIBVISUAL_VER:S/.//} \
+ SDL:${PORTSDIR}/devel/sdl12
+
+USE_CMAKE= yes
+CMAKE_ARGS+= -DLIBVISUAL_LIBRARIES=visual-${LIBVISUAL_VER}
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+USE_LDCONFIG= yes
+LIBVISUAL_VER= 0.4
+
+PLIST_FILES= lib/libvisual-${LIBVISUAL_VER}/actor/libprojectM_libvisual.so
+PLIST_DIRS= lib/libvisual-${LIBVISUAL_VER}/actor \
+ lib/libvisual-${LIBVISUAL_VER}
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.[hc]*" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's#<libvisual#<libvisual-${LIBVISUAL_VER}/libvisual#g'
+ @${REINPLACE_CMD} -e 's#/usr/local#${PREFIX}#' \
+ ${WRKSRC}/CPackConfig.cmake \
+ ${WRKSRC}/cmake_install.cmake \
+ ${WRKSRC}/CPackSourceConfig.cmake
+
+.include <bsd.port.mk>
diff --git a/graphics/projectm-libvisual/distinfo b/graphics/projectm-libvisual/distinfo
new file mode 100644
index 000000000000..bbcbf29a2dcd
--- /dev/null
+++ b/graphics/projectm-libvisual/distinfo
@@ -0,0 +1,2 @@
+SHA256 (projectM_libvisual-2.0.1-Source.tar.gz) = 8526b8687caebcef5f3374dd61665732f10030e970a7db4804eb65a06da18ea0
+SIZE (projectM_libvisual-2.0.1-Source.tar.gz) = 23128
diff --git a/graphics/projectm-libvisual/files/patch-actor_projectM-cpp b/graphics/projectm-libvisual/files/patch-actor_projectM-cpp
new file mode 100644
index 000000000000..80bdcfc2c5a3
--- /dev/null
+++ b/graphics/projectm-libvisual/files/patch-actor_projectM-cpp
@@ -0,0 +1,18 @@
+--- actor_projectM.cpp.orig 2011-02-06 15:46:19.000000000 +0000
++++ actor_projectM.cpp 2011-02-06 15:46:38.000000000 +0000
+@@ -56,7 +56,6 @@
+ static VisPluginInfo info[1];
+
+ actor[0].requisition = lv_projectm_requisition;
+- actor[0].palette = lv_projectm_palette;
+ actor[0].render = lv_projectm_render;
+ actor[0].vidoptions.depth = VISUAL_VIDEO_DEPTH_GL; /* We want GL clearly */
+
+@@ -209,7 +208,6 @@
+ * we aren't with projectm, so just ignore :) */
+ extern "C" VisPalette *lv_projectm_palette (VisPluginData *plugin)
+ {
+- return NULL;
+ }
+
+ /* This is where the real rendering happens! This function is what we call, many times
diff --git a/graphics/projectm-libvisual/pkg-descr b/graphics/projectm-libvisual/pkg-descr
new file mode 100644
index 000000000000..5db446ed747e
--- /dev/null
+++ b/graphics/projectm-libvisual/pkg-descr
@@ -0,0 +1,4 @@
+projectM is an LGPL'ed reimplementation of Milkdrop under OpenGL. All projectM
+requires is a video card with 3D acceleration and your favorite music.
+
+WWW: http://projectm.sourceforge.net/