aboutsummaryrefslogtreecommitdiff
path: root/graphics/pstoedit
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-09-12 17:28:13 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-09-12 17:28:13 +0000
commitde9c724314595c49c60633716c6da2dd7a9412cb (patch)
treef1c717a82e259ca2626e1f5663c3253ceb7f9def /graphics/pstoedit
parentf85143b8bfbe68ca203b7904b682a189d18ce879 (diff)
downloadports-de9c724314595c49c60633716c6da2dd7a9412cb.tar.gz
ports-de9c724314595c49c60633716c6da2dd7a9412cb.zip
Notes
Diffstat (limited to 'graphics/pstoedit')
-rw-r--r--graphics/pstoedit/Makefile24
-rw-r--r--graphics/pstoedit/distinfo2
-rw-r--r--graphics/pstoedit/files/patch-Makefile.in43
-rw-r--r--graphics/pstoedit/files/patch-config::Makefile.in14
-rw-r--r--graphics/pstoedit/files/patch-configure32
-rw-r--r--graphics/pstoedit/files/patch-drvswf.cpp11
-rw-r--r--graphics/pstoedit/files/patch-src::Makefile.in14
-rw-r--r--graphics/pstoedit/pkg-plist35
8 files changed, 100 insertions, 75 deletions
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index c5f4a410242f..edf7bc0317f7 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -6,42 +6,34 @@
#
PORTNAME= pstoedit
-PORTVERSION= 3.31
+PORTVERSION= 3.32
CATEGORIES= graphics print
MASTER_SITES= http://home.t-online.de/home/helga.glunz/wglunz/pstoedit/
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/ming:extract
+BUILD_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
plot.4:${PORTSDIR}/graphics/plotutils \
plotter.4:${PORTSDIR}/graphics/plotutils
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
-WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/src
-
-USE_ZIP= yes
-GNU_CONFIGURE= yes
-CONFIGURE_SCRIPT= ../config/configure
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-ALL_TARGET= default
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= pstoedit.1
CPPFLAGS= -I${LOCALBASE}/include/ming -I${LOCALBASE}/include \
- -I${X11BASE}/include
+ -I${X11BASE}/include -fpermissive
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-post-extract:
- @${LN} -sf `cd ${PORTSDIR}/graphics/ming && ${MAKE} -V WRKSRC`/../util \
- ${WRKSRC}/util
-
post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/pstoedit.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/../*.htm ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.htm ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/pstoedit/distinfo b/graphics/pstoedit/distinfo
index 885ac1ca4ac5..753504264ba3 100644
--- a/graphics/pstoedit/distinfo
+++ b/graphics/pstoedit/distinfo
@@ -1 +1 @@
-MD5 (pstoedit_3_31.zip) = d1d44bdb21ffafdd767191e8789787a2
+MD5 (pstoedit-3.32.tar.gz) = 3cc02f27c6030448f7b3705f85cba34e
diff --git a/graphics/pstoedit/files/patch-Makefile.in b/graphics/pstoedit/files/patch-Makefile.in
deleted file mode 100644
index f22be5533f06..000000000000
--- a/graphics/pstoedit/files/patch-Makefile.in
+++ /dev/null
@@ -1,43 +0,0 @@
---- Makefile.in.orig Sat Dec 29 01:34:06 2001
-+++ Makefile.in Sat Mar 9 03:58:24 2002
-@@ -19,7 +19,7 @@
- GS=@GS@
-
- # Choose a compiler + linker
--CXXFLAGS=@CXXFLAGS@
-+CXXFLAGS=@CXXFLAGS@ @CPPFLAGS@
- CCC=@CXX@ @SPECIAL_CXXFLAGS@
- LDLIBS=$(LOCALLIBS) @LDLIBS@ -lm @LDL@
- LINK=@LINK@
-@@ -57,9 +57,9 @@
- # without shared libs use LDFLAGS=-lm
- #LDLIBS= $(LOCALLIBS) -lm @LDL@
-
--INSTALL_PROGRAM=$(INSTALL)
--INSTALL_DATA=$(INSTALL) -m 644
--INSTALL_DIR=$(INSTALL) -d -m755 # or: mkdir -p
-+INSTALL_PROGRAM=@INSTALL_PROGRAM@
-+INSTALL_DATA=@INSTALL_DATA@
-+INSTALL_DIR=mkdir -p
- OBJEXT=o
- EXEEXT=
- OUTPUT=-o pstoedit
-@@ -71,7 +71,7 @@
- #LOCALDEFINES=-DHAVE_LIBPLOTTER -I/path/to/plotter.h
- # add -DOLD_LIBPLOTTER for libplot older than 2.3
- LOCALDEFINES=@PLOTCOMPILEFLAGS@ @MINGCOMPILEFLAGS@ @PNGCOMPILEFLAGS@
--LOCALLIBS=-L/path/to/libplot @LPLOTTER@ @LMING@ @PNGLINKFLAGS@
-+LOCALLIBS=@LDFLAGS@ @LIBS@ @LPLOTTER@ @LMING@ @PNGLINKFLAGS@
- #############################################################
-
- ## IRIX 5.3
-@@ -367,8 +367,7 @@
- if [ ! -d $(DESTDIR)$(MANDIR) ] ; then \
- $(INSTALL_DIR) $(DESTDIR)$(MANDIR); \
- fi
-- $(INSTALL_DATA) ../doc/pstoedit.1 $(DESTDIR)$(MANDIR)/pstoedit.$(MANEXT);
-- $(INSTALL_DATA) ../doc/pstoedit.htm $(DESTDIR)$(datadir)
-+ $(INSTALL_DATA) ../doc/pstoedit.1 $(DESTDIR)$(MANDIR)/pstoedit.$(MANEXT)
-
-
- # echo "please copy ../doc/pstoedit.htm to a suitable place"
diff --git a/graphics/pstoedit/files/patch-config::Makefile.in b/graphics/pstoedit/files/patch-config::Makefile.in
new file mode 100644
index 000000000000..d4dad0c930c1
--- /dev/null
+++ b/graphics/pstoedit/files/patch-config::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- config/Makefile.in 2002/09/12 17:18:05 1.1
++++ config/Makefile.in 2002/09/12 17:18:20
+@@ -98,7 +98,7 @@
+
+ EXTRA_DIST = pstoedit.pc.in pstoedit-config.af pstoedit-config.in
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = pstoedit.pc
+
+ bin_SCRIPTS = pstoedit-config
diff --git a/graphics/pstoedit/files/patch-configure b/graphics/pstoedit/files/patch-configure
new file mode 100644
index 000000000000..20088411ee6a
--- /dev/null
+++ b/graphics/pstoedit/files/patch-configure
@@ -0,0 +1,32 @@
+
+$FreeBSD$
+
+--- configure 2002/09/12 16:53:58 1.1
++++ configure 2002/09/12 16:54:04
+@@ -7031,6 +7031,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8016,16 +8017,15 @@
+ echo "${ECHO_T}GNU" >&6
+ SPECIAL_CXXFLAGS="-DBUGGYGPP -pedantic -Wall -Wwrite-strings -Wcast-qual -Wpointer-arith -Wstrict-prototypes"
+ fi
+- CXXFLAGS="-g"
+ elif test `echo "$CXX" | egrep -c 'xlC$'` -eq 1; then
+ echo "$as_me:8021: result: AIX xlC" >&5
+ echo "${ECHO_T}AIX xlC" >&6
+- CXXFLAGS="-D__unix__ -g -+ -I/usr/lpp/xlC/src/nihC/aixinclude"
++ CXXFLAGS="$CXXFLAGS -D__unix__ -+ -I/usr/lpp/xlC/src/nihC/aixinclude"
+ elif test `echo "$CXX" | egrep -c 'cxx$'` -eq 1; then
+ echo "$as_me:8025: result: OSF/1 cxx" >&5
+ echo "${ECHO_T}OSF/1 cxx" >&6
+ SPECIAL_CXXFLAGS=-w
+- CXXFLAGS=-define_templates
++ CXXFLAGS="$CXXFLAGS -define_templates"
+ elif test `echo "$CXX" | egrep -c 'CC$'` -eq 1; then
+ if test "$host_os" = irix5.3; then
+ echo "$as_me:8031: result: Irix 5.3" >&5
diff --git a/graphics/pstoedit/files/patch-drvswf.cpp b/graphics/pstoedit/files/patch-drvswf.cpp
deleted file mode 100644
index f8b7c394c9bf..000000000000
--- a/graphics/pstoedit/files/patch-drvswf.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- drvswf.cpp.orig Mon Dec 31 05:35:23 2001
-+++ drvswf.cpp Sat Mar 9 05:54:59 2002
-@@ -415,7 +415,7 @@
-
- // if the fontnames ends with .fdb, then the file is read, otherwise browser fonts are used.
-
-- SWFFont *f = new SWFFont(fontfilename.value());
-+ SWFFont *f = new SWFFont((char *)fontfilename.value());
- if ((f == NULL) || (f->font == NULL)) {
- errf << "Loading font " << fontfilename.value() << " failed !" << endl;
- return;
diff --git a/graphics/pstoedit/files/patch-src::Makefile.in b/graphics/pstoedit/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..1901bd028200
--- /dev/null
+++ b/graphics/pstoedit/files/patch-src::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/Makefile.in 2002/09/12 17:11:07 1.1
++++ src/Makefile.in 2002/09/12 17:13:02
+@@ -191,7 +191,7 @@
+ psimage.h
+
+
+-CPPFLAGS = \
++CPPFLAGS = @CPPFLAGS@ \
+ ${LIBPLOTTER_CFLAGS} \
+ ${LIBMING_CFLAGS} \
+ ${LIBMAGICK_CFLAGS} \
diff --git a/graphics/pstoedit/pkg-plist b/graphics/pstoedit/pkg-plist
index 8668ba075356..513b6e30d7ae 100644
--- a/graphics/pstoedit/pkg-plist
+++ b/graphics/pstoedit/pkg-plist
@@ -1,11 +1,38 @@
bin/pstoedit
-%%PORTDOCS%%share/doc/pstoedit/changelog.htm
-%%PORTDOCS%%share/doc/pstoedit/index.htm
-%%PORTDOCS%%share/doc/pstoedit/pstoedit.htm
+bin/pstoedit-config
+include/pstoedit/base64writer.h
+include/pstoedit/cppcomp.h
+include/pstoedit/drvbase.h
+include/pstoedit/drvfuncs.h
+include/pstoedit/miscutil.h
+include/pstoedit/poptions.h
+include/pstoedit/psimage.h
+include/pstoedit/pstoedit.h
+include/pstoedit/pstoeditoptions.h
+include/pstoedit/pstoeditoutputlib.h
+include/pstoedit/pstoedll.h
+lib/libpstoedit.a
+lib/libpstoedit.so
+lib/libpstoedit.so.0
+lib/pstoedit/libp2edrvlplot.a
+lib/pstoedit/libp2edrvlplot.so
+lib/pstoedit/libp2edrvlplot.so.0
+lib/pstoedit/libp2edrvstd.a
+lib/pstoedit/libp2edrvstd.so
+lib/pstoedit/libp2edrvstd.so.0
+lib/pstoedit/libp2edrvswf.a
+lib/pstoedit/libp2edrvswf.so
+lib/pstoedit/libp2edrvswf.so.0
+libdata/pkgconfig/pstoedit.pc
+share/doc/pstoedit/pstoedit.htm
share/pstoedit/latex2e.fmp
share/pstoedit/mpost.fmp
+share/pstoedit/safer.ps
share/pstoedit/svg.fmp
share/pstoedit/swffonts/default.fdb
+share/pstoedit/wemf.fmp
@dirrm share/pstoedit/swffonts
@dirrm share/pstoedit
-%%PORTDOCS%%@dirrm share/doc/pstoedit
+@dirrm share/doc/pstoedit
+@dirrm lib/pstoedit
+@dirrm include/pstoedit