aboutsummaryrefslogtreecommitdiff
path: root/graphics/pstoedit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-31 03:23:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-31 03:23:21 +0000
commit13adbe449cef0eee9d4ffa973be825399cfaa404 (patch)
tree06898856cc52c969bc00c508f49d89da3b5351c2 /graphics/pstoedit
parentdd8f577b707a7c7525bbe6d80d147c3461ca63ba (diff)
downloadports-13adbe449cef0eee9d4ffa973be825399cfaa404.tar.gz
ports-13adbe449cef0eee9d4ffa973be825399cfaa404.zip
Notes
Diffstat (limited to 'graphics/pstoedit')
-rw-r--r--graphics/pstoedit/Makefile17
-rw-r--r--graphics/pstoedit/distinfo6
-rw-r--r--graphics/pstoedit/files/patch-configure10
-rw-r--r--graphics/pstoedit/files/patch-src-drvasy.cpp10
-rw-r--r--graphics/pstoedit/pkg-plist8
5 files changed, 31 insertions, 20 deletions
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index 1472e7075fee..4acd2d7a20af 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pstoedit
-PORTVERSION= 3.42
-PORTREVISION= 2
+PORTVERSION= 3.44
CATEGORIES= graphics print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +14,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert PostScript to other vector graphic formats
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+
OPTIONS= IMAGEMAGICK "Enable magick++ interface" on \
EMF "Enable emf interface" on \
MING "Enable swf interface" on \
@@ -22,12 +23,11 @@ OPTIONS= IMAGEMAGICK "Enable magick++ interface" on \
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GHOSTSCRIPT= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
-MAN1= pstoedit.1
+MAN1= pstoedit.1
CPPFLAGS= -I${LOCALBASE}/include/ming -I${LOCALBASE}/include \
-I${X11BASE}/include
@@ -36,7 +36,12 @@ LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
-CFLAGS+= -DHAVESTL -DHAVETYPENAME -DUSE_NEWSTRSTREAM
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CFLAGS+= -DHAVESTL -DHAVETYPENAME -DUSE_NEWSTRSTREAM -DHAVEAUTOPTR
+CPPFLAGS+= -I${LOCALBASE}/include/stlport ${PTHREAD_CFLAGS}
+LDFLAGS+= -lstlport_gcc ${PTHREAD_LIBS}
+
.endif
.if defined(WITHOUT_IMAGEMAGICK)
diff --git a/graphics/pstoedit/distinfo b/graphics/pstoedit/distinfo
index e2eb21dbc0a6..26dce36f9818 100644
--- a/graphics/pstoedit/distinfo
+++ b/graphics/pstoedit/distinfo
@@ -1,3 +1,3 @@
-MD5 (pstoedit-3.42.tar.gz) = be262030dd15bc18cac03fda98f9871b
-SHA256 (pstoedit-3.42.tar.gz) = fcdddaee451c365b61c7f14e4b009b45b7d19ab4e09b6028b856bfa8b9ae3b6e
-SIZE (pstoedit-3.42.tar.gz) = 807598
+MD5 (pstoedit-3.44.tar.gz) = 13f24cb070da3f6af82ed84f4e53f049
+SHA256 (pstoedit-3.44.tar.gz) = 84af13a39dde6e5fd224306d87090fb5350de52ee7fb412e0b1373207af1027e
+SIZE (pstoedit-3.44.tar.gz) = 837147
diff --git a/graphics/pstoedit/files/patch-configure b/graphics/pstoedit/files/patch-configure
new file mode 100644
index 000000000000..cea348b94777
--- /dev/null
+++ b/graphics/pstoedit/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sat Mar 11 07:38:16 2006
++++ configure Sun Mar 26 18:50:43 2006
+@@ -21280,6 +21280,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <stdlib.h>
++#include <unistd.h>
+ char buffer[] = "aaaXXXXXX";
+ int i = mkstemp(buffer);
+ int
diff --git a/graphics/pstoedit/files/patch-src-drvasy.cpp b/graphics/pstoedit/files/patch-src-drvasy.cpp
deleted file mode 100644
index ae7096b0a2a8..000000000000
--- a/graphics/pstoedit/files/patch-src-drvasy.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/drvasy.cpp.orig Sat Mar 12 22:28:38 2005
-+++ src/drvasy.cpp Tue Aug 23 00:05:16 2005
-@@ -37,6 +37,7 @@
-
- #include <limits.h> // PATH_MAX for MSVC
- #include <ctype.h> // Need definition of ispunct()
-+#include <unistd.h>
- #include <sstream>
-
- #if !(defined(unix) || defined(__unix__) || defined(_unix) || defined(__unix) || defined(__EMX__) || defined (NetBSD) )
diff --git a/graphics/pstoedit/pkg-plist b/graphics/pstoedit/pkg-plist
index 70e57dc411d6..c4fc4a64837b 100644
--- a/graphics/pstoedit/pkg-plist
+++ b/graphics/pstoedit/pkg-plist
@@ -1,9 +1,9 @@
bin/pstoedit
-bin/pstoedit-config
include/pstoedit/base64writer.h
include/pstoedit/cppcomp.h
include/pstoedit/drvbase.h
include/pstoedit/drvfuncs.h
+include/pstoedit/genericints.h
include/pstoedit/miscutil.h
include/pstoedit/ordlist.h
include/pstoedit/poptions.h
@@ -12,21 +12,27 @@ include/pstoedit/pstoedit.h
include/pstoedit/pstoeditoptions.h
include/pstoedit/pstoeditoutputlib.h
include/pstoedit/pstoedll.h
+lib/libpstoedit.a
lib/libpstoedit.la
lib/libpstoedit.so
lib/libpstoedit.so.0
+%%PLOTUTILS%%lib/pstoedit/libp2edrvlplot.a
%%PLOTUTILS%%lib/pstoedit/libp2edrvlplot.la
%%PLOTUTILS%%lib/pstoedit/libp2edrvlplot.so
%%PLOTUTILS%%lib/pstoedit/libp2edrvlplot.so.0
+%%IMAGEMAGICK%%lib/pstoedit/libp2edrvmagick++.a
%%IMAGEMAGICK%%lib/pstoedit/libp2edrvmagick++.la
%%IMAGEMAGICK%%lib/pstoedit/libp2edrvmagick++.so
%%IMAGEMAGICK%%lib/pstoedit/libp2edrvmagick++.so.0
+lib/pstoedit/libp2edrvstd.a
lib/pstoedit/libp2edrvstd.la
lib/pstoedit/libp2edrvstd.so
lib/pstoedit/libp2edrvstd.so.0
+%%MING%%lib/pstoedit/libp2edrvswf.a
%%MING%%lib/pstoedit/libp2edrvswf.la
%%MING%%lib/pstoedit/libp2edrvswf.so
%%MING%%lib/pstoedit/libp2edrvswf.so.0
+%%EMF%%lib/pstoedit/libp2edrvwmf.a
%%EMF%%lib/pstoedit/libp2edrvwmf.la
%%EMF%%lib/pstoedit/libp2edrvwmf.so
%%EMF%%lib/pstoedit/libp2edrvwmf.so.0