aboutsummaryrefslogtreecommitdiff
path: root/graphics/pstoepsi
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 00:41:12 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 00:41:12 +0000
commit983b83d7597fbe216f65e1db1f6cbfb99549ec9f (patch)
tree1e36bf6f20b2ab703d5695c2fa7f847f147f9ef5 /graphics/pstoepsi
parent3e5368f271367deb68d3aeb1c38c695bdd4e0f89 (diff)
downloadports-983b83d7597fbe216f65e1db1f6cbfb99549ec9f.tar.gz
ports-983b83d7597fbe216f65e1db1f6cbfb99549ec9f.zip
[PATCH] graphics/pstoepsi: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54933 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=88131
Diffstat (limited to 'graphics/pstoepsi')
-rw-r--r--graphics/pstoepsi/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/pstoepsi/Makefile b/graphics/pstoepsi/Makefile
index 889d81c015c8..f09367980c3c 100644
--- a/graphics/pstoepsi/Makefile
+++ b/graphics/pstoepsi/Makefile
@@ -16,13 +16,27 @@ EXTRACT_ONLY= #empty
MAINTAINER= mita@FreeBSD.org
COMMENT= Wiliam Chia-Wei Cheng's yet another PS to EPSI converter
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
RUN_DEPENDS= pbmtoepsi:${PORTSDIR}/graphics/netpbm \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
NO_WRKSUBDIR= yes
.SILENT:
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
${CP} ${DISTDIR}/${DIST_SUBDIR}/pstoepsi ${WRKDIR}/pstoepsi.prefix
${CP} ${DISTDIR}/${DIST_SUBDIR}/README.this-site ${WRKDIR}