aboutsummaryrefslogtreecommitdiff
path: root/graphics/pure-gl/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-07 14:39:56 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-07 14:39:56 +0000
commit12f39f759de99a2ace4c578ee76cbd6dec731f9c (patch)
tree3e059f685bef946a1192ce801ee60dc0cd9e6d2a /graphics/pure-gl/Makefile
parent94e7271b83cf5e1a3e6820b7bca4282f37cee012 (diff)
1: Stagify.
2: Strip binary.
Notes
Notes: svn path=/head/; revision=364277
Diffstat (limited to 'graphics/pure-gl/Makefile')
-rw-r--r--graphics/pure-gl/Makefile26
1 files changed, 7 insertions, 19 deletions
diff --git a/graphics/pure-gl/Makefile b/graphics/pure-gl/Makefile
index f60228eecace..e33d61b21694 100644
--- a/graphics/pure-gl/Makefile
+++ b/graphics/pure-gl/Makefile
@@ -5,38 +5,26 @@ PORTNAME= pure-gl
PORTVERSION= 0.8
PORTREVISION= 4
CATEGORIES= graphics
-MASTER_SITES https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
DIST_SUBDIR= pure
MAINTAINER= ports@FreeBSD.org
COMMENT= Pure language interface to OpenGL
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USES= pure:ffi
USE_GL= glut
-
MAKE_ARGS+= LinkGL="-lglut -lGLU -lGL"
-
-NO_STAGE= yes
-
PORTDOCS= README
-
PORTEXAMPLES= *
-
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pure/pure-gl.so
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>