aboutsummaryrefslogtreecommitdiff
path: root/graphics/pure-gl
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2013-11-06 22:50:21 +0000
committerXin LI <delphij@FreeBSD.org>2013-11-06 22:50:21 +0000
commitbc0d646198e21b9653ddde161dcdd059533a7d9a (patch)
treef4ca39f0f94b1fc725562cca278474e325706ee3 /graphics/pure-gl
parentae3e5e966b6d57cfc253af140717fe2208286c6b (diff)
downloadports-bc0d646198e21b9653ddde161dcdd059533a7d9a.tar.gz
ports-bc0d646198e21b9653ddde161dcdd059533a7d9a.zip
Notes
Diffstat (limited to 'graphics/pure-gl')
-rw-r--r--graphics/pure-gl/Makefile29
-rw-r--r--graphics/pure-gl/pkg-descr2
2 files changed, 25 insertions, 6 deletions
diff --git a/graphics/pure-gl/Makefile b/graphics/pure-gl/Makefile
index b939116d7589..f022b628c2ee 100644
--- a/graphics/pure-gl/Makefile
+++ b/graphics/pure-gl/Makefile
@@ -3,19 +3,38 @@
PORTNAME= pure-gl
PORTVERSION= 0.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
+MASTER_SITES https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Pure language interface to OpenGL
-RUN_DEPENDS+= ${LOCALBASE}/lib/pure/ffi.pure:${PORTSDIR}/devel/pure-ffi
+LICENSE= BSD
-USE_PURE= yes
-USE_GL= glut
+USES= pure:ffi
+USE_GL= glut
MAKE_ARGS+= LinkGL="-lglut -lGLU -lGL"
NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
+
+PORTDOCS= README
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/pure-gl/pkg-descr b/graphics/pure-gl/pkg-descr
index 0fc1745d21ff..4f82ca903edd 100644
--- a/graphics/pure-gl/pkg-descr
+++ b/graphics/pure-gl/pkg-descr
@@ -3,4 +3,4 @@ covers pretty much all of OpenGL, including the popular extensions.
Extensions are loaded on demand, functions will throw an exception if they
are not available in your OpenGL implementation.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-gl.html
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-gl.html