aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-altair
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 21:28:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 21:28:15 +0000
commit09294c1d88306732fba60e1e06aba8da0dfa5051 (patch)
tree1d99a9ff74b0098db0d171efc2be6d66ad72465d /graphics/py-altair
parentf9afc0398e0ddd318ae5f1834346814d4a1ffeb8 (diff)
downloadports-09294c1d88306732fba60e1e06aba8da0dfa5051.tar.gz
ports-09294c1d88306732fba60e1e06aba8da0dfa5051.zip
Notes
Diffstat (limited to 'graphics/py-altair')
-rw-r--r--graphics/py-altair/Makefile28
-rw-r--r--graphics/py-altair/distinfo3
-rw-r--r--graphics/py-altair/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/py-altair/Makefile b/graphics/py-altair/Makefile
new file mode 100644
index 000000000000..08560ad45d5b
--- /dev/null
+++ b/graphics/py-altair/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= altair
+PORTVERSION= 4.1.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Declarative statistical visualization library for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}entrypoints>=0:devel/py-entrypoints@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.18:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toolz>=0:devel/py-toolz@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-altair/distinfo b/graphics/py-altair/distinfo
new file mode 100644
index 000000000000..35964e7dd5d0
--- /dev/null
+++ b/graphics/py-altair/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607539623
+SHA256 (altair-4.1.0.tar.gz) = 3edd30d4f4bb0a37278b72578e7e60bc72045a8e6704179e2f4738e35bc12931
+SIZE (altair-4.1.0.tar.gz) = 655843
diff --git a/graphics/py-altair/pkg-descr b/graphics/py-altair/pkg-descr
new file mode 100644
index 000000000000..6f99a185a2bb
--- /dev/null
+++ b/graphics/py-altair/pkg-descr
@@ -0,0 +1,7 @@
+Altair is a declarative statistical visualization library for Python. With
+Altair, you can spend more time understanding your data and its meaning.
+Altair's API is simple, friendly and consistent and built on top of the powerful
+Vega-Lite JSON specification. This elegant simplicity produces beautiful and
+effective visualizations with a minimal amount of code.
+
+WWW: https://github.com/altair-viz/altair